RPI4 - HDMI-CEC not working

  • On my QE65Q60 after command echo 'scan' | cec-client -s -d 1

    but not working :(


    did you tried some of the basic commands from here: Raspberry Pi: Power On / Off A TV Connected Via HDMI-CEC - Linux Uprising Blog

    like turn off/on the tv via HDMI-CEC from the PI? or switch the active source with this: 'as' ? I would go with some easy commands to see if the hdmi-cec is working correctly, out of this image for me it is interesting why the Vendor is not known...

    Second option to check. Install add-on Keymap Add-on:Keymap Editor - Official Kodi Wiki (i used this video

    ) with this installed try to check if you remap a left button and push left on your remote, do you get something? (a number or something like in the video?) at the end you do not need to save Keymap :)

    For me I have a samsung tv remote with some pre defined buttons, like Netflix, Prime (i am not happy with it, but that's the way...) and unfortunately the button "Exit" in my old Samsung TV was the simple command to go back, navigate back, previous menu... now in this remote this is not working :D so i needed to remap it to button A(red)...

    Last but not least, i have a Samsung TV with this new Tizen OS (not better, but once again that's the way... :) ) , so in this newSamsung (pictures attached) look-a-like setup when i connect my PI over HDMI to the TV then the HDMI-CEC setup starts... and there is a predefined list of hardwares like blueray players, AVs, XBOX, PS4, soundbars, lot's of stuff... but PI only works for me if I select "PC"... no clue why, as said before this only in the newSamsung Tizen OS.

  • Hi Hlpbob07,

    primarily i Thank you for your Reply and kicking me :)

    Today i discovered maybe mistake with my Samsung QE65Q60 (TizenOS)

    First i disconnect all devices from TV and put only alone Raspberry4 (Libreelec Kodi). First put in HDMI1, after i tried via putty som command "

    echo 'scan' | cec-client -s -d 1". Immediately i become this:

    I see Vendor Samsung, but Samsung Remote controll not working..So i wrote this command:

    1. echo 'on' | cec-client -s -d 1

    nothing success, remote control not working...so after:

    1. echo 'as' | cec-client -s -d 1

    After this command my Samsung show:

    HDMI3 (No signal)...but why? I have Raspberry in HDMI1! Ok, no problem. I put Raspberry to HDMI3.

    After connecting to HDMI3 in Samsung i give Raspberry like "PC", now Samsung Remote control working Well without Addon Keymap Editor and other :-)

    I was really happy...until if i connect other HDMI device (i have only Satelite reciever Amiko HD8150 - without CEC support).

    So i put this device to HDMI1, or 2, or 4 it doesn't matter, beceause Raspberry Kodi in HDMI3 stop working :( S*IT !!!

    There is Problem. If raspberry is alone in HDMI3 and on Samsung like "PC", CEC working well with Samsung remote control (but only in HDMI3 port on TV)

    If i put my Satelite reciever Amiko HD8150 to HDMI1, 2, 4 and with other HDMI cable, CEC in Raspberry stop working and after command:

    1. echo 'scan' | cec-client -s -d 1

    i see this:

    I have all other device disconnect from TV and leave Raspberry 4 alone in HDMI3. If problem on TV? Or Raspberry ?

    Why I have such problems ?!! I'm really unhappy :(

  • Hi, vencakratky,

    first, if you have your TV on already adding on command does not bring you a visible feedback if it really works. Try standby or pow (also described in the link). Secondly have you ever tried to connect all your devices (HDMI port # i think does not matter, but who knows nowadays :) ) and scan them? if they are visible try on and standby and pow or any other visible feedback commands volup and see if they respond. Do not forget maybe you need to add the device # as stated in some examples. If you go one page before, there is a snapshot of my other setup, I have an older samsung tv, connected thru a Receiver and then RPi 2. the Pi sees all 3 devices. So if your Amiko is CEC compatible and the HDMI cable is good, Pi4 should see and control as well.

    Also there are options (i am not sure if you touched that before) inside Kodi when you go Settings/System/Input/Peripherals there you can edit your libCEC which can also affect your setup (+ you have the samsung tv, but honestly i do not see much of an "edit" in TizenOS there)

    I believe CEC is not so straightforward as sometimes it is described, i needed to 4 times install from NOOBs when I was finally found the almost right solution (since my remote is not 100% perfect :D ) and I am still waiting for my new cable from Amazon...

  • I could swear my Rpi4 CEC problems started right after i upgraded the USB3 controller ROM and some other ROM (bootloader?) .. not sure why those would affect CEC.. i tried changing HDMI cables, couldn't get a picture with some cables.. i got it to work once, but then after changing HDMI inputs and back CEC was gone again.. i hope mine will be fixed with 9.2.1 as others have reported here..

    my CEC is also no longer working. I also remember updating the ROMs. Might be a connection between this.

  • Cec issue - all works fine, but when I turn off my tv a and then turn it on cec stops working after few seconds. Same situation after changing source on tv and switch back to Libreelec.

    HW - rpi4, Sony Bravia.

  • If it helps, for me the problem was also the cable.

    With this B00ODTCAYS (Amazon ASIN), no CEC,

    but with this one, B014I8TZXW, bingo. CEC working.

    Thanks to Team Kodi and LE crew.