LCDproc problem

  • I did last weekend made a clean installation of LibreELEC (Krypton) v7.90.007 version.
    Then immediately installed the service.lcdd-8.0.91 version.


    With included HD44780 driver my LCD driver reacts as before, blinking and dimming and no text on the display.
    Then tested with my previous used (100kB) HD44780 driver.


    With this driver the display works without problems as before. ( My display is connected with the I2C interface, maybe that's the difference ).

    Edited once, last by Dinky01 ().

  • The add-on for 8.0 builds should appear in the repo soon. It's probably not perfect as-is, but as long as people intelligently report issues we (mostly Anton) will figure things out and push updates quickly.

  • Hi,


    using here an Alphacool USB-LCD connected to an Hummingboard-i2ex:
    For a few years i had written the package.mk for serdisplib for OpeneELEC ... and using here still an OpeneELEC image on my Hummingboard. :P
    But in the near future i want to switch to LibreELEC, so i give it a try:


    I see the following error message when starting /storage/.kodi/addons/service.lcdd/bin/lcdd.start

    Code
    1. Could not open USB:060C/04EB: libusb-based connections are disabled (library has been built without libusb-support)
    2. Driver [glcd] init failed, return code -1
    3. Could not load driver glcd
    4. There is no output driver
    5. Critical error while initializing, abort.


    so i build lcdd/serdisplib by my own and got this from building serdisplib:



    warning: skipping incompatible /usr/lib64/libusb.so while searching for usb


    ... it tries to link to my host-libs?
    Do we need some LDFLAGS?

    Edited once, last by vitalogy ().


  • vitalogy did you try the version in the repo? It should be built with usb support.


    yes, from LibreELEC repo.
    the link-warning is from serdisplib ... could this be the error, when running lcdd.


    my LCDd.conf:


    [hr]



    LibreELEC with lcdproc as addon


    libserdisp.so.1 => not found

    Code
    1. LibreELEC:~ # ldd .kodi/addons/service.lcdd/lib/libserdisp.so.1
    2. ldd: $warning: you do not have execution permission for `.kodi/addons/service.lcdd/lib/libserdisp.so.1'
    3.     libgcc_s.so.1 => /usr/lib/libgcc_s.so.1 (0xb6f0a000)
    4.     libc.so.6 => /lib/libc.so.6 (0xb6dd5000)
    5.     /lib/ld-linux-armhf.so.3 (0xb6f59000)




    OpenELEC with lcdproc in system



    Edited once, last by vitalogy ().

  • Try running

    Code
    1. . /etc/profile


    Before running ldd


    Also check the LD_LIBRARY_PATH

  • Hi, I updated my LibreELEC to 008 but LCD does not work yet.
    I installed LCDproc from LibreELEC repo and set the driver to hd44780 but nothing happened.
    Does anyone know how to fix it?
    Back to 006 for now! :(

  • After seeing this thread, I was curious whether my OLED 20x4 would run on LibreELEC (Krypton) v7.90.008 ALPHA for Odroid C2.


    Well.. it doesn't... it starts already with the missing i2c-2 address :D :

    Code
    1. HD44780: I2C: open i2c device '/dev/i2c-2' failed: No such file or directory


    On wrxtasys 7.0.x / 7.1 builds it works for i2c-2 and i2c-1. Unfortunately it is wired for i2c-2 right now, so I cannot check i2c-1 easily.


    Besides the question why i2c-2 is not present?, I still have two more questions:

    • I have to use a custom compiled HD44780 because my controller (SSD1311 is not fully compatible to HD44780). On my Raspberry Pi's and on my Odroid C2 with 7.0.x builds I simply had to put the modified driver and config files (hd44780.so, LCDd.conf) into .config directory and LCD.xml into userdata directory. The display worked then right away after enabling HD44780 displaydriver in LibreELEC Configuration / Services. LCDd.conf contained the path to my custom hd44780.so: "/storage/.config/"
      Where do I have to put those files now. LCD.conf in .config seems to be ignored?
    • There are no settings left in lcdproc (no dimming, no scroll speed, no alternative character choice). Is it coming back, or did you dig those configuration options somewhere else?
  • What would the command to enable /dev/i2c-2 be (i have no hw to test, need some hints for debugging)?


    A1. Config folder is now in /storage/.kodi/userdata/addon_data/service.lcdd, accessible via ssh and smb


    A2. Settings should be in settings folder

    @


  • What would the command to enable /dev/i2c-2 be (i have no hw to test, need some hints for debugging)?


    A1. Config folder is now in /storage/.kodi/userdata/addon_data/service.lcdd, accessible via ssh and smb


    A2. Settings should be in settings folder


    good question hmm... I just know that I had to modify in LCDd.conf the line Device=/dev/i2c-1 to Device=/dev/i2c-2


    # Device of the serial interface [default: /dev/lcd]
    #Device=/dev/i2c-1
    Device=/dev/i2c-2


    It is visible on my LibreELEC 7.0.x setups on RPi and C2:

    And it is not present when using LibreELEC Krypton 008 alpha build. But I am not sure what is responsible that the file appears in the directory /dev/i2c-x :/.


    Regarding A2: So no settings in GUI like in old builds? You mean the settings.xml or are you referring to the lcd.xml where you set what infolabels should be displayed?

  • OMG I have my lcd i2c working after using info from here i played for ages and wasn't getting it right was about to give up when wife called me to come eat dinner i had rebooted pi and one last time after making no additional changes which had not work prior to that but i was like wtf...when i returned i had display


    my other screen was on a different address so i changed address and rebooted "nothing" played more and "nothing" so i left it to go make coffee when i returned it worked so basically im saying when testing leave for a minute or two before u change more settings as you might have it right an not know it


    hope this useless info helps someone LibreELEC (Krypton) v7.90.008


    i :) :) :) :) :) :) :) :) :) :) :) :)


    if anyone needs it here are my files
    /storage/.kodi/userdata
    lcd.rar
    /storage/.kodi/addons
    service.lcdd.rar
    [hr]
    [hr]
    last but not least is the hd44780 file that gors into /storage/lcd
    lcd.rar

    Edited once, last by irishfrog ().


  • will need support added in our linux-amlogic kernel and support in the device tree before you can use it.