LibreELEC (Leia) 9.2 ALPHA1 with Raspberry Pi 4B Support

  • No, there are no more 9.0.x releases planned. Please upgrade to 9.1/9.2 - RPi0-3 and x86 should work without problems, as the 9.0 releases before.


    so long,


    Hias

  • No, there are no more 9.0.x releases planned. Please upgrade to 9.1/9.2 - RPi0-3 and x86 should work without problems, as the 9.0 releases before.


    so long,


    Hias

    After upgrading to LibreELEC-Generic.x86_64-9.1.001.img.gz from 9.02 the TVHeadend-Server does not startup anymore. I had to connect an external TVHeadend-Server from another PC to the Libreelec-HTS-Client, otherwise TV would be unavailable.

  • Is it possible the the missing shared library (libssl.so.1.0.0) could cause my problem?

    Yes, this is quite certainly the problem. Make sure you have the current tvheadend42 addon installed. Kodi log will show that info, just use the logfile uploader in LE settings and post the link here.


    BTW: very often (addon) update problems are caused by slow network initialization (kodi log will show that, too). Enable "Wait for network" in LE settings makes sure the network is up before kodi start and fixes these issues.


    so long,


    Hias

  • Thanks for your help but it seems i could solve my problem:).

    Wait for network in LE settings was already aktive (10s). I have additionately activated maximal time to wait for network in KODI-settings and have set it to 20 s. Now tvheadend-server starts up without any problem and ... also without this change tvheadend-server starts up without problem now.

    It appears to be a little bit curious for me because i have not seen any similar problems in the past using libreelec from the first releases until now (and openelec before).


    I see :P - maybe the real reason for solving the problem is the update to tvheadend-plugin 9.1.900.119. There was only 9.1.900.118 available some minutes before.

    Anyway - thank you for your quick service :)

    Edited 4 times, last by psifi ().

  • Hey guys. Anyone having problems getting LE running on their Pi4? Ive tried everything I can think of to get it working with ZERO progress. I posted the specific problem and details under [General Support] the post is called "RPi 4b/4gb - boots up and immediately freezes, can't do anything..." It seems I'm not the only one who is having this issue. If anyone has any insight at all on getting this up and running, I would love to hear it.

  • I'm a little confused about versions. The alpha1 for Rpi4 is supposed to be LibreElec 9.2? The only image I've found on the site is LibreELEC-RPi4.arm-9.1.001.img.gz. Is it a typo or what am I missing? In System information on my Pi4 with LibreElec it also says "LibreElec (official): 9.1.001". Where can I find 9.2?

  • I'm a little confused about versions. The alpha1 for Rpi4 is supposed to be LibreElec 9.2? The only image I've found on the site is LibreELEC-RPi4.arm-9.1.001.img.gz. Is it a typo or what am I missing? In System information on my Pi4 with LibreElec it also says "LibreElec (official): 9.1.001". Where can I find 9.2?

    My understanding is that 9.1.001 is the alpha version of the upcoming 9.2. If you look at Raspberry Pi 3 / 3+ – LibreELEC, it shows 9.1.001 under LibreELEC 9.2.

  • According to LibreELEC (Leia) 9.2 ALPHA1 with Raspberry Pi 4B Support – LibreELEC, LibreELEC Kodi currently outputs to 1 screen. I'm wondering if it would be theoretically possible to output to both HDMIs ports in mirror configuration. I understand Linux should allow this via command line using xrandr --output HDMI1 --same-as HDMI2. Shouldn't it be able to mirror in LibreELEC as well? Can any LibreELEC devs answer this?


    If you're wondering why would anyone want this, this might allow people to forgo buying a HDMI splitter (for example, to connect to a soundbar with HDMI 1.4 and a 4KTV with HDMI 2.0)

  • Hi. Just received my rpi4 2gb and installed latest libreelec on it.

    I have very laggish stuttering movie playback and also interface have some vsync problems - so much horizontal lines when animation appeared.

    Only 700mb films works OK. 12-16GB Bdrips files works like on pentium 3.

    How to fix movie lags and turn vsync on?

  • According to LibreELEC (Leia) 9.2 ALPHA1 with Raspberry Pi 4B Support – LibreELEC, LibreELEC Kodi currently outputs to 1 screen. I'm wondering if it would be theoretically possible to output to both HDMIs ports in mirror configuration. I understand Linux should allow this via command line using xrandr --output HDMI1 --same-as HDMI2. Shouldn't it be able to mirror in LibreELEC as well? Can any LibreELEC devs answer this?


    If you're wondering why would anyone want this, this might allow people to forgo buying a HDMI splitter (for example, to connect to a soundbar with HDMI 1.4 and a 4KTV with HDMI 2.0)


    Yeah I raised a feature request for this for this exact reason.

  • How to build an image for the rpi4 from the Github source? I've tried the build instructions and used device=rpi4 but that doesn't seem to work.