[S812] MIII Plus 2Gb\16Gb eMMC

  • Hi balbes150,

    can you make new script s805_autoscript for s812 m8s with bmc4335 wifi box with possibility to boot images from Alexelec.

    With his aml_autoscript i see only logo m8s when i try his image from usb-0 port.I ask Alex to make some fix in his image then i can use your latest universal boot script v05 with his image but i didnt get his answer yet about this problem .Thanks!

  • Hello balbes150,

    when i insert libreelec for m8s latest 17.6 from 22.01.2018 on usb and after i turn off later i cant turn on libreelec from usb and it show me on tv "no signal".I dont know what is problem...Can you fix that in future version for proper turn off/on for my box m8s s812 AP6330 .Thanks!

  • Thank you for answer...I did not understund what information?If you mean his latest build for m8s you can find here: Releases · AlexELEC/AlexELEC-AML · GitHub.

    I will be very thankful if you make script to load Alexelec build for m8s android box.Thanks again...

    To create a script, need support in the image to be able to work with it. Ie need to make small changes to the image itself, then I will be able to collect the right script. If Alex is interested, can easily resolve this issue, I am ready to take part in it.



    when i insert libreelec for m8s latest 17.6 from 22.01.2018 on usb and after i turn off later i cant turn on libreelec from usb and it show me on tv "no signal".I dont know what is problem...Can you fix that in future version for proper turn off/on for my box m8s s812 AP6330 .Thanks!

    I hope to release an update soon, maybe it will fix the error.



    is the still being developed ?

    the alexelec seems to be Russian only ?


    i'm not into retro gaming

    Yeah, I keep working on the LE for the s812. The good news is Martin is gradually adding support for the s812 to the kernel mainline. Now you can use s812 as a server (there is no HDMI output yet).

  • The good news is Martin is gradually adding support for the s812 to the kernel mainline. Now you can use s812 as a server (there is no HDMI output yet).

    Nice to hear the mainline kernel for the S812 is also getting shape. Your armbian build made me dust of my M8S. Now I have to find the proper DTB. Hopefully HDMI will be functional soon.

  • Nice to hear the mainline kernel for the S812 is also getting shape. Your armbian build made me dust of my M8S. Now I have to find the proper DTB. Hopefully HDMI will be functional soon.

    All images Armbian for s812 core 3.x works with HDMI and all other components. I don't have enough time to add KODI with HW to them.

  • FYI, had an error trying to download the img.gz for MXIII plus and the tar images. The img.gz shows this error -



    and the .tar does not have a tab with the download arrow to download the image.

    MXIII-G, M8 and Beeklink MXIII Plus LE 8.2.2 - Demetris, Mecool M8S Pro+/Abox A1, Abox A1 Max Coreelec 9.0.2. Thanks to all.

  • Balbes150, I downloaded this file Libreelec-S812.arm_18.0_20180522-MXIII_Plus.img.gz. and flashed it to a formatted MicroSD card using win32diskimager. This was a fresh flash, not a .tar update.


    1- I attempted a toothpick boot into LE. The first attempt the Android splash started then the screen went blank and the LE splash came up on screen. There was no progress from this point, just an error at the top left:

    Nothing progressed from the # shown on the last line.


    forum.libreelec.tv/core/attachment/3747/


    2- I pulled the plug and did another toothpick reboot and the Android splash came up, flashed off then flashed on and this repeated until I pulled the power plug. No progress towards the LE splash screen was made.


    3- I gave up and restarted the box without toothpick. The Android splash came up, then the Libreelec splash opened and a full page of data flashed quickly on screen (too quickly to record), then the boot dialogue started on the left top of the page, it counts down 3 seconds and then reboots and restarts the whole process again, over and over. LE never completes the loading and opening Leia.

    forum.libreelec.tv/core/attachment/3749/


    4- I reflashed the card and tried another toothpick boot. This time the box went right to step 3 and continued rebooting.

    I'm not sure what is wrong and could use some help. I have a Beelink MXIII Plus with 2g 16g

    I'm not sure if I was to activate multiboot in a different way -

    "To start the system from external media, you must use a universal multi-boot. This variant of multi-loading system is fully compatible with Armbian etc systems for TV boxes. If it is already activated with the previous images, you do not need to repeat the activation".


    Would be helpful if you could start another thread for Leia S802/S812.

  • balbes150


    I tried your Leia version for the 100Mb network. Following things I noticed:


    1) It keeps on rebooting because it can't delete the file .please_resize_me, after manualy deleting this file as root and expanding the filesystem myself I was able to boot.

    2) When in Kodi after a few seconds it freezes, sometimes kodi restarts itself another time I had to pull the plug.

    3) The script "install to internal" doesn't seem to work, or there is something wrong with uboot of my M8S.


    I see on the download page there is a folder for the 100Mb network with two folders, both with an image. What is the difference between all the 100Mb images. I used the one from the front page.