[S812] MIII Plus 2Gb\16Gb eMMC

  • Thanks for response.


    So the boot.scr that came as part of the image is the correct one to use.


    I will create a folder named boot on my SDCard and USB, and move the file boot.scr to it and retest, starting with the toothpick method and the SDCard..


    Yes.


    All your steps to enable multi-boot on Minix (using the "toothpick method") , without the presence of the SD card /boot/boot.scr is not working. Create a directory /boot and then move the file "boot.scr" . Then, once again run the "toothpick method".

    Created a folder named 'boot' on both my SDCard and USB, and moved the already installed boot.scr file into the new 'boot' folder on both.


    With modified SDCard used toothpick boot and got the 120 second message power off or press any key, powered off Minix.


    Left SDCard in Minix and rebooted, got the 120 second message again.


    Removed SDCard, plugged in modified USB and rebooted Minix. Minix logo was displayed a lot longer than usual, then Minix booted into Android.


    So no benefit in doing suggested changes.

  • Try to record on the USB flash drive image MXIII_Plus, that does not change it, connect to the Minix and turn on the power.

    Same result as Minix image.


    Burnt this image :- LibreELEC-S812.arm-17.4_20170830-MXIII_Plus.img.gz to USB


    After inserting USB and rebooting Minix, Minix Android stays on longer than usual then boots into android.


    While the Minix Android logo is displayed my USB light is on continuously, then flashes a couple of times, then boots into Android.


    This is pic of my USB LibreELEC partition:-

  • balbes150


    Nice work. I only have a small problem since I updated to krypton. I have a dvd/hdd combo like this one -> USB Portable DVD/CD Writer and HDD All-In-One Combo

    But when there is a cd in the tray, the hdd doesn't mount anymore. Strange as it wasn't a problem on Jarvis. I got to investigate it further, maybe it's a hardware problem that occured on the same time I upgraded to Krypton.

    As I had to much issues with the 30/08 build, I tried the latest build of Demetris (just burn it to sd and added Balbes S805_autoscript). Boots fine and everything works, even my dvd/hdd combo. So something should probably be wrong in Balbes150 image.

    Regarding the cpu, in Demetris image I have also constantely 1 cpu at 100%.

  • I was forced to give a try to LE because of problems with DTS sound in Android images on my Minix X8-H.


    I'm very happy that LE works well and I can enjoy DTS 5.1 if available in my video archive. It seems to me that video is smoother too than on any Android image I used. Thanks to all developers here !


    My questions is, how to keep all my LE settings after upgrade to future release of LE. I expect that I'll have to flash a new LE image to SD card and all my configuration data will be lost.


    Maybe it is enough to copy out the ~/.kodi/userdata/ folder before flashing a new image to SD card and copy it back after flashing + reboot.


    Thanks for help.

  • You just copy the upgrade file, tar, or gz to the update folder in kodi. Reboot, & that is that.


    from windows explorer \\ipaddress of your box update folder is there


    you won't lose your settings


    just check to see if there is a newer device tree, if so also copy that to the update folder

    Samsung RU7400 Onkyo HTX22HDX Nvidia Shield HD Homerun Duo (Living Room)

    Samsung UE40ES5500 H96 Pro, X96+, Fire TV 4K Stick (Bedroom)

    Synology DS920+ Plex Pass

    :)

  • I've been successful in getting Balbes's Libreelec-812.MXIII_Plusarm-17.3 (June 8 2017 ) running via SD card on an M8S box. I then immediately updated to LibreELEC-S812.arm-17.4_20170915-MXIII_Plus.tar. So far so good. The build hasn't shown any problems.

    Thanks again balbes 150 for all your help.

    MXIII-G, M8 and Beeklink MXIII Plus LE 8.2.2 - Demetris, Mecool M8S Pro+/Abox A1, Abox A1 Max Coreelec 9.0.2. Thanks to all.

  • Tried 20170915 - still no Wifi and error at startup when loading kernel modules.

    Downgraded to LibreELEC-S812.LAN1000.arm-8.0.1.tar - Wifi works. I can see the module 8723bs, which probably is the correct one for Wifi.


    Code
    [ [email protected]] RTL871X: module init start
    [ [email protected]] RTL871X: rtl8723bs v4.3.16_13854.20150410_BTCOEX20150119-5844
    [ [email protected]] RTL871X: rtl8723bs BT-Coex version = BTCOEX20150119-5844
    [ [email protected]] wifi_setup_dt
    ...
    [ [email protected]] RTL871X: rtw_set_802_11_connect(wlan0) fw_state=0x00000008
  • balbes150


    2 systemd error messages:


    -> systemd-module-load.service:

    Sep 29 10:17:51 LibreELEC systemd[1]: Starting Load Kernel Modules...

    Sep 29 10:17:51 LibreELEC systemd-modules-load[2196]: Failed to find module 'aml

    videodri'

    Sep 29 10:17:51 LibreELEC systemd[1]: systemd-modules-load.service: Main process

    exited, code=exited, status=1/FAILURE

    Sep 29 10:17:51 LibreELEC systemd[1]: Failed to start Load Kernel Modules.

    Sep 29 10:17:51 LibreELEC systemd[1]: systemd-modules-load.service: Unit entered

    failed state.

    Sep 29 10:17:51 LibreELEC systemd[1]: systemd-modules-load.service: Failed with

    result 'exit-code'.


    and


    ->kodi-aml-hdmimonitor.service:

    Sep 30 11:34:59 LibreELEC systemd[1]: Started Kodi Amlogic HDMI connection monit

    or.

    Sep 30 11:34:59 LibreELEC systemd[1]: kodi-aml-hdmimonitor.service: Main process

    exited, code=exited, status=1/FAILURE

    Sep 30 11:34:59 LibreELEC systemd[1]: kodi-aml-hdmimonitor.service: Unit entered

    failed state.

    Sep 30 11:34:59 LibreELEC systemd[1]: kodi-aml-hdmimonitor.service: Failed with

    result 'exit-code'.

  • I'm getting corrupt file system with both versions of 20170925.

    If I back down to a previous version, everything works again.

  • balbes150, will you be uploading a 17.5 image? Thanks for all your efforts with this project.

    MXIII-G, M8 and Beeklink MXIII Plus LE 8.2.2 - Demetris, Mecool M8S Pro+/Abox A1, Abox A1 Max Coreelec 9.0.2. Thanks to all.

  • Hi,


    Newbie here :)


    So happy to find this forum!


    I have a MXIII 4K unit, looks to be S812 based with 2G/8G.


    Just tried LibreELEC-S812.MXIII_Plus.arm-8.0.2.img after LibreELEC-S812.arm-17.5_20171102-MXIII_Plus.img -- both on USB via multiboot. Both booted up properly & mythtv addon both functioned, with wired connection. Wireless connected, but have not tested with streaming yet.


    Want to report a curious observation: with LibreELEC-S812.arm-17.5_20171102-MXIII_Plus.img, with all of the hardware decoding options turned on, it was not able to keep up with NFL network channel, which was streaming at around 2MB/s -- video was in slow motion, and constantly skipping. I ssh'ed into the box, and top revealed kodi.bin was running at near 300% of the CPU (keeping all 4 cores at above 70%). I fiddled with the the hardware acceleration options, no change.


    (I tried to google for some command line to check for the GPU utilization, but was not able to find any.)


    So I decided to give the 8.0.2 image a try. Same setup, this time, streaming NFL network channel, still at around 2MB/s, kodi.bin used only about 60% of CPU in total. And the video images were very smooth and pretty.


    So I am wondering whether the GPU codec or utilization between the two version have changed, or whether there are any configurations adjustments that I have missed. Thanks for the help!


    And, a HUGE thanks to balbes50 for making all of these work and making them available -- otherwise I was about to give up on this unit altogether!


    One more thing, when I tried to switch over to 4K resolution, both versions shrank the display to the top left quardrant. Are there settings to adjust for this too? Thanks!

  • clams Can you create a separate thread with full logs and describing your issue with NHL addon? It seems to be common for Amlogic devices and it would be much easier if someone created a thread with logs to look into it. Instructions on log collection are in the sticky post.