LibreELEC-RR 9.x [ Emulationstation | Retroarch | Pegasus | DolphinQT | Moonlight | Chrome | Spotify ]

  • Well you got that wrong -> I use a complete different way to configure the audio backend because autodetect won't work reliable. But if you include all of escalade commits it should work but might break compatibility to other Kodi stuff. Been there, done that. Last time I tried to use PA in Kodi it broke audio passthrough for me so I keep it to the emulation stuff.

    I am not worried about Kodi, I removed it, the build I am working on is pure emulation

  • Does passthrough even work with PA at all? From my testing i think PA performs better when remixing menu/videos in ES, perhaps the optimal solution is using PA then pasuspender for emus. PA has gotten quite good over the years, perhaps it can be tuned further to get perfect sound and performance in every case.


    As for autodetection, I think there won’t be one solution that suits everyone. I think the manual steps for special setups isn’t too bad and can be done by noobs with proper docs.


    niabi


    Did you find the script useful? Let me know if u have ideas to improve it. I have some changes i will commit later. Also im interested in a cleaned up wifi script, waiting for u to get that right ;)

  • I do like the script, seems like a seamless integration of what I was looking for, I just didn't manage to get it working yet I am sure I am missing something obvious.

    The Wifi script is working amazingly well, it just needs fbterm if you want to see the output :P but it does need cleanup, will let you know on GH when its done so maybe you can take a second look at it.

    Edited once, last by niabi ().

  • Is there a way I can resize dolphin window to be viewable on a 800x484 resolution?


    Actually I'm not able to view all the configuration windows entirely so it's very hard (or even impossible) to access all the configuration options.


    Thank you

  • Is anybody else getting screen tearing during video playback in Chrome?


    I've been running RR-20190404-1cc7fad on an Asus Chromebox (Haswell Celeron 2955u model with integrated Intel graphics) with no issues, but after a recent Chrome update, video playback started to display horrible tearing (best exhibited by opening this YouTube tearing test: YouTube. This same YouTube video doesn't tear in the YouTube Kodi add-on and neither do any videos I playback directly in Kodi or the Plex addon).


    I updated to RR-20190423-716b9f8 and this made no difference at all. I also tried creating a custom xorg.conf in the ~/.config directory with the following settings:

    This didn't make a difference. I also tried this xorg.conf:

    Code
    1. Section "Device"
    2. Identifier "Intel Graphics"
    3. Driver "intel"
    4. Option "AccelMethod" "sna"
    5. Option "TearFree" "true"
    6. EndSection

    as detailed here: Tearing Intel Xorg but again no dice.


    Maybe something in Chrome has changed recently?


    Debug log file here:


    http://ix.io/1hy7

  • Hi there,


    I'm having trouble with the last update on my RPi3, but I've managed to solve it myself. I'm reporting this here, just in case someone has the same problem:


    Since the last update, 04-04-19, I was having a very low performance on some 3D emulators, for instance, PSX one, barely having 3-5fps ingame on any game, even on "easily emulable" ones like Castelvania.


    I have the feeling that libretro core isn't working fine, or that it's using armhf one. So I downloaded the last core from libretro nightlie's server (linux/armv7-neon-hf), and replaced it using WinSCP. Just copy the downloaded pcsx_rearmed_libreretro.so file and replace it on /tmp/cores/. Then fully reboot the Pi, and you are good to go.


    Please, for future releases, please look into this. I assure the performance lose is big.


    Thanks for your time, and forgive my english :)

  • Is there a way I can resize dolphin window to be viewable on a 800x484 resolution?


    Actually I'm not able to view all the configuration windows entirely so it's very hard (or even impossible) to access all the configuration options.


    Thank you

    You can try to set custom dpi but I guess they have some fixed minimum sizes which won't play along with such low resolutions.


    Is anybody else getting screen tearing during video playback in Chrome?


    I've been running RR-20190404-1cc7fad on an Asus Chromebox (Haswell Celeron 2955u model with integrated Intel graphics) with no issues, but after a recent Chrome update, video playback started to display horrible tearing (best exhibited by opening this YouTube tearing test: YouTube. This same YouTube video doesn't tear in the YouTube Kodi add-on and neither do any videos I playback directly in Kodi or the Plex addon).


    I updated to RR-20190423-716b9f8 and this made no difference at all. I also tried creating a custom xorg.conf in the ~/.config directory with the following settings:

    If it started after a Chrome update it's probably related to Chrome. So I guess we have to wait for a bugfix then.


    The latest version I've uploaded was compiled at the 23.04. and not the 19.04. so you don't use the latest version. I've checked pcsx on my RPi3B (again) and it runs fine. I tested GT2 & Castelvania, if you get 3-5fps this is most likely not related to any missing optimizations because if the emulator is build without NEON then it runs slower but not at 5-10% of the original speed.


    Also /tmp/cores should not be touched the. If you download cores they should be placed in /storage/.config/retroarch/cores

  • I dont know if its me or if i'm lacking a method here. i have retroarch on multiple devices and OSes (two biggest ones are this and windows.) but when i transfer the .srm file (which is the save pak) from windows (1.7.3) to here (1.7.6) i always get a corrupt mempak error and its deletes my save and fill the mempak with a bunch of zero files. this prevent me from taking my game with me when im not at home....

    so.....are the saves in retroarch transferable?

    Edited once, last by Animejin: filling in details ().

  • I dont know if its me or if i'm lacking a method here. i have retroarch on multiple devices and OSes (two biggest ones are this and windows.) but when i transfer the .srm file (which is the save pak) from windows (1.7.3) to here (1.7.6) i always get a corrupt mempak error and its deletes my save and fill the mempak with a bunch of zero files. this prevent me from taking my game with me when im not at home....

    so.....are the saves in retroarch transferable?

    Well I can't give an exact answer about this. I have all my roms on my NAS & use Generic / RPi & KVIM builds with different emulators to run the same games. So I can play Link to the past on all systems with different emulators but all systems run the same RA version and are Linux builds. Have you tried to update your RA version? I mean 1.7.3 is about one year old and almost 4800 commits were merged since then.

  • If it started after a Chrome update it's probably related to Chrome. So I guess we have to wait for a bugfix then.

    Chrome just updated and tearing is still present (particularly the top third of both windowed and full screen video playback). Could anybody else who is on an Intel integrated GPU check this video in Chrome and see if they experience screen tearing?:


  • Hello.


    I currently use this build on an older hp aio with a Nvidia 9300m so it defaults to using the legacy driver.


    However this driver is bugged and causes freezes after 30 minutes.


    Is it possible to change it to use the nouveau driver or the patched 340 driver that stops the crashes?


    Thank you for all your work

  • Do you have a link to the 340 patch set? If there is one it should be no problem to build the driver with this patches. Nouveau on the other hand is basically no option at the moment. Well at least without complete rewrite how LE handles Nvidia drivers right now.

  • I was mistaken.. it seems like it may be a kernel issue.


    I've been trying various driver revisions on Ubuntu and it freezes after 30secs to 2 mins with the Nvidia proprietary drivers but doesn't with nouveau.. so may be a driver/kernel issue but I have no idea.


    But back to libreelec/rr


    Kodi works flawlessly if I play a movie without freezing but as soon as I leave it idle without playing anything it will freeze and only powering off will help.


    Same with emulation.. if I'm actively playing a game it doesn't lock up.. but if I let it go idle it will freeze.


    What could be the issue?

  • Would it help if I posted my logs? I had a quick look through them all but can't see the event that locks the system up.


    On a side note.. once the system locks up I can still access the samba share but the screen is completely unresponsive.


    Again.. it only happens when the system is doing nothing.


    When playing media or a game is running.. even if noone is doing inputs.. it doesn't lockup.

    But if it's left on any screen idle doing nothing.. it will lock up within 1 minute.

  • Maybe this question is dumb but is there no way to leave the spotify home screen? :/ I usually dont use this app I just tested for the aeon mq7 skinner if all the reborn remix apps work in his skin because he doesnt have libreelec.

    And the only way I found to exit spotify was to reboot the system in putty :D

  • Maybe this question is dumb but is there no way to leave the spotify home screen? :/ I usually dont use this app I just tested for the aeon mq7 skinner if all the reborn remix apps work in his skin because he doesnt have libreelec.

    And the only way I found to exit spotify was to reboot the system in putty :D

    On your keyboard alt-esc

  • Maybe this question is dumb but is there no way to leave the spotify home screen? :/ I usually dont use this app I just tested for the aeon mq7 skinner if all the reborn remix apps work in his skin because he doesnt have libreelec.

    And the only way I found to exit spotify was to reboot the system in putty :D

    From the first post:

    Keyboard buttons in different apps

    • Kodi shutdown menu = S
    • Kodi context menu = C
    • Spotify exit = Alt+Esc
    • Emulationstation menu = Alt

    ;)

    HTPC 1 : Intel Core i7-7700, MSI GTX 1050 2GT LP, 4GB, Asus H170M-E D3, 60GB SSD(LibreELEC 9.x RR),Origen AE S10V

    HTPC 2 : ASRock N3150-ITX , 4GB , 60GB SSD (LibreELEC 9.x RR), Silverstone Lascala LC19B-R

    NAS : Synology DS3617xs , 6 x 8TB WD Red(Movie/Serie) , 4 x 4TB WD Red(Roms/backup)