Geniatech Mygica HDStar DVB-S2 USB HD not working

  • my media_build updated, must support up to 5.5 kernels

    m88ds3103 frontend driver now with ds3103b support from Brad Love media_tree

    ds3103b specific firmware included dvb-firmwares.tar.bz2

    crazycat

    I didn't find the dvb-usb-id5520se for TBS5520SE in the zip.

    Do you have any information about it?

    It is useless knowledge if not shared the world.

  • please from stable 5,3 kernel ubuntu 19.10 (or latest 18.04.xx LTS with hwe kernel 5.3 now).


    P.S. 5,5 kernel support some buggy with current media_build

    here it is (ubuntu 19.10 5.3.0 kernel)

    External Content pastebin.com
    Content embedded from external sources will not be displayed without your consent.
    Through the activation of external content, you agree that personal data may be transferred to third party platforms. We have provided more information on this in our privacy policy.

    thank you,

    sdf

  • Just an update.

    Compiled successfully and perfectly working against latest ubuntu kernel 5.5.3

    Thank you Crazycat!

    sdf

  • Tried new Milhouse builds, but seems that "crazycat tbs drivers" are from "linux-tbs-drivers" repository and not from "media_build" one.

    So in Libreleelec we have three drivers to choose from: normal, media_build (not Crazycat's) and Crazycat tbs.

    Unfortunately neither of them has support for our hdstar v3.

    There's no possibility to include Crazycat media_build in future releases?

    Thank you,

    sdf

  • likely its the same that does not build with latest kernels, he wanted to push a fix for it soon so it should be doable soon

    wonderful!

    thank you,

    sdf

  • Crazycat,

    just to say that with your media_build latest version had a compile error against kernel 5.5.8

    normal media_build (linuxtv.org) compiles normally

    will try with 5.6 rc

    thank you,

    sdf

  • Forgot compile log, sorry

    External Content pastebin.com
    Content embedded from external sources will not be displayed without your consent.
    Through the activation of external content, you agree that personal data may be transferred to third party platforms. We have provided more information on this in our privacy policy.

  • likely its the same that does not build with latest kernels, he wanted to push a fix for it soon so it should be doable soon :)

    this patchset have only one "Warrning" when compile media_build from linuxtv and works

    Ubuntu-media-tree-kernel-builder/patches/mainline-extra/tip/80.montage.3103b at master · b-rad-NDi/Ubuntu-media-tree-kernel-builder · GitHub try this, if 3103b devices included works with upstream media_build you can create additional pack for testing dvb drivers something like "media_build from upstram + occasional patches"

  • just to say that with your media_build latest version had a compile error against kernel 5.5.8

    normal media_build (linuxtv.org) compiles normally

    Fixed, try again.

  • Compiled last crazycat's media_build over kernel 5.3.0-42-generic in Ubuntu 18.04.

    My HDStar still fails:


    ... I'm probably doing something wrong.

    Installation steps that I've followed:


    git clone Bitbucket

    cd media_build

    make distclean

    make

    sudo make install

  • OK, it is working now. But I have my dmesg log flooded by:


  • For me compile error with latest 5.5.11 kernel

    Same error with linuxtv media_build

    External Content pastebin.com
    Content embedded from external sources will not be displayed without your consent.
    Through the activation of external content, you agree that personal data may be transferred to third party platforms. We have provided more information on this in our privacy policy.

    Thank you

    sdf

  • OK, it is working now.

    Hi Meiden. Are you using a Rpi?

    Would be good to know if anyone has the HD Star v3 or equivalent working on RPi and if so what they are using to give me something to persist with? I've lost countless hours now and all I've got to show for it is a bit more familiarity with the command line.