Test LibreELEC images with KODI-18 for S9xxx

  • Any update on anlogue audio for s905w? I can help with testing..

    ..as far as I know no progress for internal av port..easiest way around is a still a cheapo 1$/€ sound card. I tried several, but on libreelec and armbian this one does the best job best for me(there is a black 7.1 device also around that price, which is often not recognized properly and wider blocking other ports little more, so blue one is better choice. If you need both usb ports already, take a simple passive 3-port usb hub (cost under 3€) which works perfect on my tx3mini s905w; on x96mini prefer one with a short cable because hubs(2ports on back and one on top ) are too thick and you need to turn box upside down or place something under box to equalize hub..

  • ..as far as I know no progress for internal av port..easiest way around is a still a cheapo 1$/€ sound card. I tried several, but on libreelec and armbian this one does the best job best for me(there is a black 7.1 device also around that price, which is often not recognized properly and wider blocking other ports little more, so blue one is better choice. If you need both usb ports already, take a simple passive 3-port usb hub (cost under 3€) which works perfect on my tx3mini s905w; on x96mini prefer one with a short cable because hubs(2ports on back and one on top ) are too thick and you need to turn box upside down or place something under box to equalize hub..

    thanks usb sound card works fine :)


    Any pointers in getting remote to work??

  • TX3 mini should have working 2.0 audio out-of-box - no need for a USB soundcard unless you're chasing multi-channel support. We have a sponsor for that work now, but due to existing commitments with the sponsor and the implementor it will be a while before it happens.


    G12A/B hardware now has working 2.0 audio and multi-channel should follow (before we see it on GX). I'm refining the config but it should appear in balbes150 images 'soon' ..


    Remotes should work fine as long as you have a keymap configured. Infrared Remotes [LibreELEC.wiki] has all the info needed.

  • TX3 mini should have working 2.0 audio out-of-box - no need for a USB soundcard unless you're chasing multi-channel support. We have a sponsor for that work now, but due to existing commitments with the sponsor and the implementor it will be a while before it happens.


    G12A/B hardware now has working 2.0 audio and multi-channel should follow (before we see it on GX). I'm refining the config but it should appear in balbes150 images 'soon' ..


    Remotes should work fine as long as you have a keymap configured. Infrared Remotes [LibreELEC.wiki] has all the info needed.

    Thanks im testing on an m8s pro w and have no sound out of the box (but usb works fine) will do some more trials on remote once i get home.. Also i cannot see internal storage of box so i must run from sdcard.


    If you need any help with testing let me know.

  • Aarch64 or Arm?


    Any one image best from all choices?

    If you do not use Netflix (or other add-ons that are only for the arm version), then the aacrh64 version works 20-30% faster. :)



    Tried the ARM image but similar results ...... wired NIC does not work.


    I have not had a some way functional wired NIC since the last 'rii' image I tried.


    Seems these images are not compatible with the 2GB X96 Max which has a 100Mb/s NIC.

    I do not have such a model for testing and finding errors.



    Tnx

  • TX3 mini should have working 2.0 audio out-of-box

    ..on todays build I got no audio on tx3 mini via 3.5mm jack in av port..maybe HDMI analog audio works oob, but all my monitors got no speakers so I'm not sure.

  • Thanks for these early builds.


    Just to report that I don't see any improvement in playback of HEVC files compared to the previous builds.


    About half of my vids (so far) don't play - just buffers to 100% and gets stuck, and others that do play have issues with ff,rw, skip seek etc causing lockups (as in previous builds).


    If debug logs are needed etc, just let me know.

  • Just to report that I don't see any improvement in playback of HEVC files compared to the previous builds.

    Unfortunately there have been no improvements in regards of HW decoding.


    The only thing to test in the latest build is perhaps HDMI audio on S905X2 and S922X: patches are included, I cannot say if they work or not as I have no "next-gen" device.

  • Unfortunately there have been no improvements in regards of HW decoding.


    The only thing to test in the latest build is perhaps HDMI audio on S905X2 and S922X: patches are included, I cannot say if they work or not as I have no "next-gen" device.

    Thanks for the info kszaq ,


    Great to see that you are still involved.

  • If there is anything I can do to help please let me know.

  • hi

    kernel 5,2 rc1 is out

    When we try lima 450 mali with kernel 5,2

    These images have been running lima for Mali-450 (and panfrost for Mali-T820) for some time already. Look in Kodi SysInfo.

  • Just to report that I don't see any improvement in playback of HEVC files compared to the previous builds.

    About half of my vids (so far) don't play - just buffers to 100% and gets stuck, and others that do play have issues with ff,rw, skip seek etc causing lockups (as in previous builds).

    HEVC has some rough spots but should generally play fine on GX (not G12A/B which has zero support for HEVC at the moment) hardware with 8-bit media. Most streamed HEVC media is 8-bit, but most ripped HEVC media is 10-bit and right now there is no 10-bit support in the HDMI driver. Once 10-bit support lands; then some work can be done to continue development on the HEVC decoder. There's no need for bug reports - we're engaged with the developers doing that work and we have a good and library of bad media for testing with.

  • KI Pro: LibreELEC-AMLGX.arm-9.1-devel-20190521


    I still have the same problems reported by me here earlier.

    And now a new problem!

    And when you shut down the boxed system it restarts, and hangs on the libreelec screen.

    There are 2 channels that lock the picture after 5 seconds plus audio works.

    http://ix.io/1ih9

    CEC: I turn KI Pro off and the TV remains on.

    The quality of the SD image leaves something to be desired.

    Interface kodi a bit unstable. (Trembling)


    The update with .tar file is not working.

    LibreELEC-AMLGX.arm-9.1-devel-20190521114453-a41fdf1-box.tar

    Thank you, balbes150

  • HEVC has some rough spots but should generally play fine on GX (not G12A/B which has zero support for HEVC at the moment) hardware with 8-bit media. Most streamed HEVC media is 8-bit, but most ripped HEVC media is 10-bit and right now there is no 10-bit support in the HDMI driver.


    I hadn't thought of 8-bit vs 10-bit HW decode of HEVC. I have some 10-bit HEVC videos that do play fine, but most are unplayable with HW decoding on. I'll check some 8-bit vids. All of my older vids are 8-bit, the new ones are 10-bit. This is on GX player (S905x)