@balbes150 LE images with Kodi-19 for S9xxx

  • Thanks guys for the repo, it works fine. However, I am getting this annoying screen flikering both on moivies and Live Tv play back, even when nothing is been playe, it still filker, I have changed HDMI cable hoping this would resolved this issue but it did not. I did not experienced this issue with Libreelec Generic version connected to this same TV issue same HDMI cable.

    I read through this link similar issue was reported but there was no clear solution to the problem, I am womdering if some hae similar issue and how it was resolved.

    [SOLVED] [S905x | 8.0.1e) Screen flickering/turning black for a moment - Nexbox A95x




  • Thank you balbes150 for these images!

    I recently installed the images from 22th Oct 2018 on my S912 Minix U9-H without problems. The only thing is to select the right DTB in the ini-file on the SD card, but you already mentioned that!

    Playback of UHD directory images now works perfectly. Also mkv-files of UHD-HDR content, no problem!

    The only major problem I have, ist that sound seems to be very buggy! Perhaps some downmix problems?

    My Minix is directly connected to the TV via HDMI cable. I have an older Onkyo 507 with TOSLINK connected to the Minix to get the sound done.

    If the files have an older Dolby Digital oder DTS track the sound works perfect. But if you have a newer DD True HD or Atmos Track, or even an old MPEG2 Audio track (streaming oder via TV) the sound is terrible. Either the sounds are too high or way too low, with a lot of hearable artefacts and dropouts.

    Of course I setup the sound config to 5.0 channels und setup that my AVR can only handle DD or DTS not the newer formats.

    These sound problems are not there with wrxtasys builds for example!

    Perhaps anyone could verify these problems or has an hint to get these things fixed?!

    Unfortunatelly I don't have any latest AVR to test with HDMI audio directly. The TOSLINK is of course just a temporary solution till a new AVR makes it into the living room...

    Update: As my TV gets the sound via HDMI I can confirm the same problem here. AC-3 and DTS play well, all other formats are either way too slow (deep voices) or either way too high (high voices).

    And I also recognized that automatic resolution change does not work. I've got 1080p50 set as standard, but UHD films won't change to 2160p24 automatically. I have to change manually.

    Edited once, last by Dom82 ().

  • Hi,

    I have found a bug? In the video playback.

    I have some MP4 files downloaded from NRK online and they play for about 3-5 seconds then crash. They are fine on my other libreelec boxes and my phone.

    Does this log ahead any light on the issue?


    Thank you!

  • Detalhes

    Thank you balbes150 for your patience!:angel:

    my friend without success, I can not boot

    I have a mecool (S905D) KI Pro.

    I would like to be testing this new kernel as I said before!

    I followed some steps of his said in the forum khadas

    I tried everything./shrug

    any suggestion?:idea:

    It is useless knowledge if not shared the world.

  • balbes150

    1. If I install your LE version to eMMC (and erase the Android OS), then update settings on it, how can I then copy back this .img LE version to USB/SD card ?

    2. I only saw Khadas Vim section under the Add-ons folder link. Has the arm vs aarch64 problem been solved for Kodi Add-ons on other TV box models too?

  • balbes150

    1. On my A95X-B7N (S905X) 1/8 G box, your Oct 22 S905-arm and S905-aarch failed to load from SD card. I keep getting the Nexbox logo flashed but nothing more.

    Only once I saw the LE logo flash after the A95X flash but it didn't proceed. Upon redoing the toothpick method, I reverted to the A95X logo hanging.

    On the aarch version I used device trees for g212-1g generic, g281-1g generic and a95xr2-1g; for the arm version g212-1g generic version.

    FYI, CoreElec 8.95.3 and work fine. Boot from Android is fine too.

    2. On the other hand, after a 2nd try, my X96mini 2/16 G booted fine. Was able to set up WiFi and redo the X96 keymaps config to make the remote control work again.

    3. In either of above X96mini or A95X cases, the HDMI works, but AV (CVBS, RCA) only shows the tvBox logo, then LE logo, and then goes blank screen (same experience with CE.)

    Is there a solution to the AV problem at least?

    $ echo "cvbs576" [or 576cvbs] > /sys/class/display/mode doesn't work. Android works ok with cvbs.

    I would like to try out your version because of the advanced features you offer.

    Edited 4 times, last by shippy: Update. ().

  • Hey

    Can I use this with my Nano Pi K2? Which file should I use and which device tree file will work with my board?

    Thank you very much 🙏

  • New images 20180920 (kernel 3.14).

    I draw attention to the changes. Now the process of installing the system in eMMC has changed. The default install of the additional copy of the LE at eMMC without uninstalling regular Android. Now, to install LE in eMMC, there is a special menu item in "Libreelec->Services->eMMC->Install to eMMC". When you select this menu item, LE will be copied to eMMC in parallel to Android (Android is fully saved and can be used). Also in the new images added two menu items to create and restore a full copy of the eMMC on external media (along with the bootloader, settings and all data). I recommend that you make sure you create a full copy of eMMC before installing LE on eMMC. Depending on the type of external media and how busy eMMC data is, the backup process can take anywhere from 5 to 30 minutes. After the copy is created or restored, the system automatically shuts down. It is not recommended to use the system during creation and recovery (to reduce the risk of errors). For those who want to install LE in eMMC with delete Android, you need to rename the script on the external media beforehand "full_install2emmc.sh" to "install2emmc.sh", start the system from external media and also select the item in the menu. The system will execute the installation LE to replace eMMC with Android on LE.

    Hi Balbes,

    I current have this version LibreELEC-S905_SD_USB.aarch64-17.6_20180122.img working in my Tronsmart s905 emmc.

    Also I have burned this version LibreELEC-S905.aarch64-9.0-devel-20181114151758-cbfbde4.img into SD card and is working fine, each time I tried to write this version in emmc I get an error message.

    The process will start with write to emmc, after a short time the box will power off.

    Next I removed the SD and power on the box, then a script message pop up

    "Never touch boot=in ex linux.conf /cmdline.txt!

    if you don't know what you are doing,

    your installation is now broken.

    normal startup in 60s....20"

    after the above several lines of scripts is written

    "FAILED] failed to start load kernel models"

    Could you advice where I have gone wrong, How to update S905.aarch64-9.0 into existing emmc S905_SD_USB.aarch64-17.6.


  • I've got the 812 version running on a tronsmart s89, thank you for that.

    Only question is where are the CEC controls, will they return?

  • I'm a little confused...

    Is the aim of this thread to test ports of LE v9 on Amlogic devices, essentially picking up where kzsaq left off? Or are the builds using LE v8, with Kodi v18 installed instead of v17?

  • Hello. I just install the Leia libreelec to my mxiii-g TV box. The only thing that is not working is my tv remote control not working (cooperates) with the tv box anymore. It was working before through the Anynet /HDMI -CEC operation. Is this operation is missing ? Is this a bug ?

  • I found an incompatibility with the Embuary Leai skin... Which makes me think the latest version of Kodi is not included with this release? When testing that skin on the Libreelec x64 there is no such incompatibility.

  • Hello!

    Could you point me to location where I can download builds for VIMs?

    I've got Khadas VIM2 Pro looking to run LibreELEC on it