@balbes150 LE images with Kodi-19 for S9xxx

  • Took delivery of my N2+ Yesterday (Sunday) - DHL working all days at the moment....

    after a bit of stuffing around and a pointer from tobetter. My notes to install Ubuntu 20.10 with 5.10rc and panfrost on the device - http://ix.io/2G19


    In reading your chewitt logs in the mainline, it seems this N2+ is really only just now being supported in mainline without the ARM mali binaries.


    start [linux-meson]


    Looking forward to running up LE on this.need to get back to coding.

  • Thank you all for help and your kind words. This is truly a great community! So receptive and eager to help out! This will definetly make me eager to donate and contribute too! Real top notch! /s


    Thanks for nothing!

  • After this commit N2 and N2+ use the same boot fips. I have separate odroid-n2 and odroiod-n2-plus folders only to stop people asking me "do the N2 files work on N2 plus?" .. the files in both folders are identical.

    I don't have such equipment, I don't know if it works or not. That's why I don't release such images.



    To all - ver 20201203

  • I flashed your LibreELEC-ARMv8.arm-9.80-devel-20201204143803-d174eba-odroid-c2.img.gz to emmc and tried to boot. It didn't work.


    Serial log shows following


    So it Seams that does not detect the emmc.


    According to u-boot list the last working u-boot to boot from on Odroid-c2 is 2020.04. Is this the reason why it don't boot further?

  • There's a bug in recent u-boot where a clock is set incorrectly and this impacts mmc on C2 and likely other GXBB devices. It's reported in the Armbian forums but I forget where and didn't test the hack that was posted (which is a hack not a fix).

  • Yes, I looked at the log. U-boot in my image is not suitable for direct launch in SD\eMMC mode for N2+. Need to build a different version of u-boot for your model. But I don't have an N2+ sample, so I'm sorry, I can't help you. The standard u-boot, which is in SPI, uses a clueless PITEBOOT that interferes with the direct execution of u-boot commands, so I doubt that you will be able to use my image in SPI mode (using boot.ini). For the N2 model (not plus), I created a special version of UbootSPI that allows you to run any system with USB \ SD\eMMC\LAN, but I think it will not work on N2+, need to create a special version for N2+.

    I discovered that part of my issues with booting LibreELEC on my N2+ were caused by a failure to boot my Sandisk Ultra 8GB microSD. Eventually, I started to use a Samsung 16GB microSD card. @chewitt's builds boot ok, but your builds still fail to boot on my N2+

  • on the aarch64 g12b from 17.12. I noticed:
    * panfrost misbehaving (artifacts on display)

    * random segfaults in hrtimers (causes complete freeze)

    * null ptr dereference related to squashfs (random on bootup; tried two different sd-cards occurs on all)


    Unexpectedly unstable behavior of 5.10.1


    Nullptr:

    Edited once, last by phlp11 ().

  • Hi there


    Apologies as i'm pretty new to this but as an experiment I wanted to try and flash your LibreELEC-ARMv8.aarch64-9.80-devel-20201228140110-d174eba-amlgxbb.img.gz image to my old S905 box (Arnubox Pure Linux 64bit) which is currently running the latest CE nightly image from emmc

    I successfully managed to boot from SD card using the Wetek Play2 dtb in the extlinux config (also tried meson-gxbb-p200 first assuming that would work - it didn't.)

    However i was surprised and pleased that the image did boot from SD. The main things not working for me using this image:

    Assigns a random mac address to the box (and generating different random IP's on each reboot) won't allow me to set a manual IP either

    CEC doesn't work (although a message does appear saying it's connecting)

    Some video files play, some don't (from shared SMB NAS drive)

    No sound output via HDMI and SPDIF output disables during boot (tried all the audio output options) I assume it's the Wetek Play2 sound card profile not working with this box?

    I understand running CE on internal might affect this working properly anyway as per your notes for install.


    Here's the boot log:

    http://ix.io/2Lxb


    Anyway - just wanted to give it a shot to see if it was at all possible to run the image (and therefore Kodi Matrix beta) on an older box - so didn't expect to get this far!


    Thanks

  • Hello!

    Thanx balbes150 for his work!

    I'm trying to install LE on my new X96max (S905x2 4Gb DDR4 32Gb), but have some interesting issue. Secont stage U-boot (mainline) works soooo sloooow for my setup. from starting to autoboot more than 1 min, console freezes so much, loading KERNEL from sd-card about 3 mins, from network about 10 mins, After kernel is started box speeds up and all looks fine, what's happen?


    Detail explaination:

    Have uart connected, sd-card with fat partition wih u-boot.ext, DTBs, KERNEL, SYSTEM is inserted.

    1. Power up box, start pressing much <Enter>s

    2. we got first-stage u-boot shell. all works fine (even network), but can't load KENEL because it is EFI image. old u-boot don't know EFI.

    3. Okay, fatload mmc 0 0x100000 u-boot.ext; go 0x100000

    4. Second-stage u-boot is started. and slowmotion is started tooo....

    5. start pressing <Enter>s. await 1 min. we got second u-boot shell.

    6. all work fine except speed. Even console type so slow.

    7. fatload KERNEL, fatload DTB, bootefi blah-blah

    8. kernel is started and all works fine.

    problem is a booting speed - 5 mins for me in total from sd, 10+ from network.

  • Quote

    Why are you breaking the launch ?

    Because i want to boot from network by my own u-boot startup scripts. On my five s905x systems with old LE (old 3.x aml kernel) it works fine.

    Quote

    What firmware is in eMMC ?

    Sorry, don't known. Original Android firmware. Only one thing is interesting - u-boot.

    Quote

    Show the output of " printenv"

    No prob.

  • Latest aarch64 14.01.2021:
    ```
    Jan 14 21:01:24 LibreELEC systemd[1]: kodi.service: Main process exited, code=exited, status=255/EXCEPTION

    Jan 14 21:01:24 LibreELEC systemd[1]: kodi.service: Failed with result 'exit-code'.

    Jan 14 21:01:24 LibreELEC systemd[1]: systemd-hostnamed.service: Succeeded.

    Jan 14 21:01:26 LibreELEC systemd[1]: kodi.service: Scheduled restart job, restart counter is at 7.

    Jan 14 21:01:26 LibreELEC systemd[1]: Stopped Kodi Media Center.

    Jan 14 21:01:26 LibreELEC systemd[1]: Condition check resulted in Kodi user autostart script being skipped.

    Jan 14 21:01:26 LibreELEC systemd[1]: Starting Kodi Media Center...

    Jan 14 21:01:26 LibreELEC systemd[1]: Started Kodi Media Center.

    Jan 14 21:01:27 LibreELEC kodi.sh[3762]: MESA-LOADER: failed to open meson: libzstd.so.1: cannot open shared object file: No such file or directory (search

    Jan 14 21:01:27 LibreELEC kodi.sh[3762]: failed to load driver: meson

    Jan 14 21:01:27 LibreELEC kodi.sh[3762]: MESA-LOADER: failed to open kms_swrast: /usr/lib/dri/kms_swrast_dri.so: cannot open shared object file: No such fil

    Jan 14 21:01:27 LibreELEC kodi.sh[3762]: failed to load driver: kms_swrast

    Jan 14 21:01:27 LibreELEC kodi.sh[3762]: MESA-LOADER: failed to open swrast: /usr/lib/dri/swrast_dri.so: cannot open shared object file: No such file or dir

    Jan 14 21:01:27 LibreELEC kodi.sh[3762]: failed to load swrast driver


    ```