@balbes150 LE images with Kodi-19 for S9xxx

  • Please help.

    Emmc bott kodi 19. Full great ok.

    Edenwood tv remote not configured. cec non....

    remotte conf ordel complet mission?

  • First off I wanted to clarify that what I mentioned are just observations and not necessarily need fixing. I rarely have access to the Odroid, because it's not mine and therefore just used the opportunity to make a quick test :)

    The TP-Link is indeed a Realtek chipset, but maybe with mainline support. It tries to use the rtl8xxxu driver, but I think this driver doesn't work that well, but it was really long ago that I tried that on a regular Ubuntu machine (and used a DKMS module in the end which is a pain). The Rock64 Libreelec build uses RTL871X, but I'm not sure it's a kernel module. dmesg output:

    Regarding the long shutdown/reboot, thanks for the explanation. Sounds like a sensible workaround then.

    CEC worked at some point with 5.3.0 I think, but it was also not reliably recognized. Just noticed that it doesn't seem to be activated at all now (old LG TV). CEC on that TV is not useable anyway as CECStandby doesnt seem to be supported by the TV, but in general it is probably a wanted feature I guess.

  • Just did a fresh install of "LibreELEC-ARM-ALL.aarch64-9.80-devel-20200311121833-569f834-amlg12.img" on my Khadas Vim 3. I was trying to setup auto mount of my network shares but failed for some reason. The error message said "Can not access a needed shared library" (please see attached text file.

    My auto mount scripts used to work flawlessly in the past. I have no idea what library is missing in this build.


  • Hi,

    my 2 cents on 20200311-aarch64 (s905w p281 [MECOOL M8S pro w] ), I've been a regular user of the images since kernel v5.x release.

    - different MAC on each boot (causes connman to create multiple configs; this was okay on previous releases)

    - weird behavior when hw decoding is enabled -> each time I scroll a video forward / backwards kodi freezes

    - no CEC (even though device detected) (was working okay in initial kernel 5x releases)
    - emmc not detected (was never working)

    - wifi not detected ( SV6051P not mainlined; don't care)

    - occasional sound garbling (probably regression; this was never present on previous images)

    Let me know if I can be of any service.


  • Hello,

    I have an Beelink Mini MX 1g/8g S905 with bluetooth and wifi. I actually managed to make work LibreELEC with gxbb_p200_1G_1Gbit.dtb device tree (unfortunately bluetooth doesn't work, but I won't need it for now).

    The same SD card actually work with a box I have which is called MXV, which is closed to a S905 MXQ pro but not exactly (board S905-BOX_Ver_C 2016.03.28 // firmware p201-userdebug 5.1.1 LMY47V)

    But I don't manage to make this build work, probably for not having the correct dtb, I tried various but it doesn't boot. Any available ? thanks

    • Official Post

    The mainline kernel handles RAM size dynamically so there are no 1G/2G/3G variants of devices trees. You should be able to boot the p200 device-tree. The WeTek Hub dtb is also for a 1G S905 device. NB: You cannot use legacy kernel dtb's on mainline. You can also try the AMLGX-box image from official nightlies, the boot arrangements are slightly different to Oleg's images in this thread. See: Index of /

  • I manage to get it working with wetek hub dtb, didn't with P200 (i tried it initially).

    But I have some issue, like french language making it crash at init (I imagine for nightly) and remote not working. Is there any 9.2 stable build for amlogic ? I didn't find. Thanks chewitt!

  • The tuner appears in the USB options, but drivers do not recognize th tuner.


    My device GT-King-Pro + TBSE5520 USB Tuner

    dmesg | paste


    Edited 6 times, last by crazyturk ().

  • Make it work! balbes150  chewitt

    We need to have fun with your images.

    amid quarantine!8o

  • What may have changed this time? balbes150 Where can the problem be this time?

    KI Pro Do not boot, image without boot.


    Also tested with aarch64 images to no avail.

    Previous images work.

    APPEND=boot=LABEL=LIBREELEC disk=LABEL=STORAGE quiet console=ttyAML0,115200n8 console=tty0 systemd.debug_shell=ttyAML0
    APPEND=boot=LABEL=LIBREELEC disk=LABEL=STORAGE quiet console=ttyAML0,115200n8 console=tty0 systemd.debug_shell=ttyAML0