[8.2.4.1] LibreELEC Kodi Krypton - S905 & S912 devices

  • chipset doesn't really matter.


    In an S912 topic? ;)

    ODROID N2_S922 4G - 1GB Ethernet, X92_S912_q201 3/32G - 1GB Ethernet Box_Android 7.1.2, Mocool KM8_S905X 2/16 0.1GB Ethernet Box_Android 8.0, X96Mini_S905W 2/16G 0.1GB Ethernet Box_Android 7.1.2

  • Hi wrxtasy! first of all, many thanks for this update! My Minix Neo U9-H has been sitting in a corner for months (due to the subtitles bug).


    I've copied the image along with the dtb file specific for the Minix into a sd card and it installed fine. I used this guide ([HOWTO] Boot from SD card, use internal memory for data) to put the data on the internal memory, then I changed a few other settings and rebooted.


    I copied advancedsettings.xml (I have around 1k movies in mysql library).Then I tested a few files, all good, no stutter. Very happy!


    Then I was just navigating my movies (scrolling down fast) the fanarts would appear quickly but then kodi restarted. It also restarts when I change the viewtype quickly. The bug is reproducible


    At first I thought that maybe this dtb was not compatible with my mmc memory so I put the data back on the sd card and I have more or less the same results. Now that I think of it could still be the dtb file, but which one should I try.


    Thanks again for your work. If some body has the same issue please report it.


  • I would suggest testing by SSH logging in and settings the Kodi GUI options to default values:

    Code
    1. mv .kodi/userdata/guisettings.xml .kodi/userdata/guisettings.xml.backup
    2. reboot

    c_g_f Try this, it helped with my freezing issue.

  • c_g_f -- I have the same problem.


    Also manifests itself when playing certain videos (immediately upon pressing play). I tried what zonly1 suggested, but that didn't help. It isn't a full reboot, just a restart of Kodi.


    Crash log attached. Hopefully it can tell somebody, something.

  • Are you using the standard Estuary Kodi Krypton Skin ?


    Everything goes pear shaped when attempting to load Skin settings.

    Quote

    23:45:06.009 T:3833590624 WARNING: CSkinInfo: failed to load skin settings

  • @wrxtasy:

    when i power off LE, the box goes to standby instead of off like on android. can this be changed?

    i dont use the box daily and the standby LED is a bit annoying me

    Minix U9

    Zidoo X7

    Bqeel MVR9

  • c_g_f -- I have the same problem.


    Also manifests itself when playing certain videos (immediately upon pressing play). I tried what zonly1 suggested, but that didn't help. It isn't a full reboot, just a restart of Kodi.


    Crash log attached. Hopefully it can tell somebody, something.

    I just tried with another skin (Confluence) and it's the same. I installed 8.2.4.subtitles-ff image and it's also there. I'll do a clean install in another sd card and try again. I'll send the logs later.

  • I am indeed using the standard Estuary Kodi Krypton Skim.


    Not sure if any of this helps shed some light:

    Left the unit on (doing nothing) overnight and it did not crash.

    I can watch some videos without any problems.

    I can watch live tv (nextpvr addon) no problem.


    And ... an aha! moment. The crash happens if there is a subtitle (srt) file in the directory of the video. If I remove the srt file, then it does not crash!


    EDIT:

    To clarify a bit here, as I noted earlier I can cause the crash by either watching some movies, or by scrolling through a large db of movies.


    The watching crash seems related to the subtitles. That's the one where if (a) an SRT file exists in the directory where the movie is located AND (b) the SRT files is names with the same filename as the movie (mymovie.mkv and mymovie.eng.srt) then it crashes upon selecting the movie (not pressing play on the movie, just going into the detail screen for that given movie). If I rename the SRT file to something else (but still with the SRT extension) then I can go into the detail screen and can play the movie.


    The other crash where scrolling through a large collection of movies, still seems to occur. In that scenario, if I just go into the "Movie" list and even do NOTHING, it crashes after a few seconds. This does NOT happen if I go into TV Shows.

  • The watching crash seems related to the subtitles. That's the one where if (a) an SRT file exists in the directory where the movie is located AND (b) the SRT files is names with the same filename as the movie (mymovie.mkv and mymovie.eng.srt) then it crashes upon selecting the movie (not pressing play on the movie, just going into the detail screen for that given movie). If I rename the SRT file to something else (but still with the SRT extension) then I can go into the detail screen and can play the movie.


    The convention is same name for movie and (.srt) subtitle => mymovie.mkv and mymovie.srt, maybe that is the problem.

    With the same image version on my box, with the same names for video and subtitle, I cannot get it to crash, or provoke one what ever I try...

    ODROID N2_S922 4G - 1GB Ethernet, X92_S912_q201 3/32G - 1GB Ethernet Box_Android 7.1.2, Mocool KM8_S905X 2/16 0.1GB Ethernet Box_Android 8.0, X96Mini_S905W 2/16G 0.1GB Ethernet Box_Android 7.1.2

  • Good finding vinbot3000! I just reproduced the bug with a tv show with srt subtitles..


    Sholander do you also have a mysql library? (I noticed in the log from vinbot3000 that he uses mysql library). Maybe the problem only happens for mysql libraries?

  • The convention is same name for movie and (.srt) subtitle => mymovie.mkv and mymovie.srt, maybe that is the problem.

    With the same image version on my box, with the same names for video and subtitle, I cannot get it to crash, or provoke one what ever I try...


    Hmmm, based on Subtitles - Official Kodi Wiki it is valid to have the language indicated in the name of the file. Regardless I tried renaming it to mymovie.srt - still crashes.


    As c_g_f noted, I'm using a mysql db for all my platforms. Everything works fine on my other platforms, LE running on an NVIDIA ION (Acer Aspire REVO R1600). It is only the Minix NEO U9-H that crashes.


    EDIT:

    Turned on a bunch of debug logging. Here's what happens when I press Select on the Movie up until it crashes.


    EDIT 2:

    For the issue where it crashes just by going to "Movies" - again with debugging turned on, even if I don't choose any file in the Movies, I can see it crashing due to the subtitle file (.idx this time) for one of the movies. I think by going into Movie Kodi stars scanning and when it finds this subtitle it crashes. If I remove that one specific .IDX file, then it no longer crashes just by going to Movies (but it still crashes when I try to Select a movie that has subtitles).


    So to summarize


    Problem 1: Crashes when going to Movies

    -In my case it was due to a specific IDX file.


    Problem 2: Crashes when selecting any Movie that has an associated subtitle file

    -Through trial and error I can see that it crashed if there are more than about 68 lines of data in the SRT file (ie: if I delete everything after line 68, then when I select that movie, it does not crash). I tried this on several randomly selected movies and it is consistent.


    I don't know why it caused Kodi to crash, and it doesn't cause it to crash on my non-s912 setups.


    Anybody have any thoughts, suggestions, ideas?

    Files

    • bp.log

      (12.66 kB, downloaded 148 times, last: )

    Edited 2 times, last by vinbot3000 ().

  • Good finding vinbot3000! I just reproduced the bug with a tv show with srt subtitles..


    Sholander do you also have a mysql library? (I noticed in the log from vinbot3000 that he uses mysql library). Maybe the problem only happens for mysql libraries?


    No, don't have mysql library...

    ODROID N2_S922 4G - 1GB Ethernet, X92_S912_q201 3/32G - 1GB Ethernet Box_Android 7.1.2, Mocool KM8_S905X 2/16 0.1GB Ethernet Box_Android 8.0, X96Mini_S905W 2/16G 0.1GB Ethernet Box_Android 7.1.2

  • OK my subtitle issue is not related to the mysql database.

    It is related to SMB.


    If I have the subtitle file in the same directory as the movie on an SMB source - CRASH

    If I have the subtitle file in the same directory as the movie on an NFS source - WORKS

    If I have the subtitle file in the same directory as the movie on an LOCAL source - WORKS


    So I guess I can work around this by having a custom dir located on an NFS (or LOCAL) share for the subtitles (I've never tried this before, but I think I've seen settings for this)? I'll try it out later this week.


    Odd that the movie is fine over SMB, it is just the subtitle files that cause problems.


    Anyway, if anybody has any ideas as to why subtitles over SMB causes crashes - I'm all ears.

  • how do you mount your SMB share, via LE or Kodi? If you are mounting via Kodi then try to mount via LE.

  • Hi,


    I've installed 8.2.4.1 on a Minix U9 and since then I'm experiencing like a loss of sync while playing 4K HEVC 23.976 content. When I start playing the file I am able to see about a minute before the sync losses start and then they happen about every 10-15 sec.

    Chroma subsampling and OC are enabled. The problem didn't occur with 8.2.4-Subtitles-ff. I've bought a new HDMI cable to take that out of the equation.


    Here's the log in case it helps: