LibreELEC 9.0 / Kodi 18.X for Minix X8,X8H,X8H+

  • Thank you so much for your advice, I don't have SD card at the moment, I will try it soon when I prepared a SD card.

    Have you tried the USB Burning Tool and another?

    I write through Google translator ;(
  • I have a number of Minix X8H-Plus boxes that have been running LibreELEC 16 for a few year.

    12 Months back I had tested LibreELEC 17 from an SD card.

    Recently I updated them to LibreELEC 17 using the update directory method using this build


    I have tried to upgrade to 18 using builds from post 1 using the the update directory method.

    However I always get the message that the build is not compatible with X8-H_PlusGen1.arm hardware

    I also tried to burn 8.3 to SD and booted with toothpick but I end ups with a message after the 120 seconds as below

    invalid argument...

    ...3.0.28 2015-05-16

    read only file system

    1.49.9 (8 Feb... only file system while /dev/mmcblk0p2


    fsck failed .... Your system is broken beyond repair


    if I boot the box without sd it goes to internal 17.7 fine.


    This morning I went back and put the 8.3 tar from page 1 + .ncompat in the 17.6 update directory.

    This worked and I now have 18.3 installed.

    However it appears the repositories are a bit strange

    I compared to my RP3 and both have LibreELEC Add-Ons 9.01 but when I go in there is way less categories and in particular PVR clients has old versions listed that ar not compatible.

    eg PVR Clients

    Argus TV is on PI and in Minix box

    The Enigma2 Addon I need is not listed just the old VU+ one.

    Is there a way to clean out the repository structure ?

    I tried a complete reset of Libreelec and now when I try to access the Libreelec repository it says it can't connect ?


    The problem is that the LibreELEC Add-Ons Repository - Team LibreELEC - 9.0.1 is not available to download .

    Any advice would be appreciated

    Edited 10 times, last by craigh1960 ().

  • With the AE builds you may have to try a different more suitable to S802 file as the compiled in wifi maybe different....

    The S812 and S802 are close in most ways but the wifi chipsets maybe different between them and even board revisions within the same SoC not always had the same chipsets...

    You could try using a different dtb from within the same build with the file that your trying and see if that helps...

    That is assuming your using the X8H and not the X8H-plus.... ( the plus is S812)....

  • I've update my x8h+ with the last 18.3.

    Now work perfect the static IP and Mac adress but... it's possible to use the wol packet?

    I've test with Yatse app, but the minix don't power on.

  • I've been using 17.6-final (PlusGen1) on X8-H+ and it was great!
    Updating directly to 18.3 broke the file system, since I had to use .nocompat to even get it going.
    Flashing stock RC2 fixed it, but RC2_NEWBOOT also fixes the shutdown bug, so that's the one I ended up using.
    Freezes during playback went away with these:

    - refresh rate = 50
    - adjust display refresh rate = always
    - sync playback to display = on

    Ethernet MAC is set to "1E:00:00:00:00:00" and wireless to "00:90:4C:11:22:33" - at least it's consistently wrong so its not a big deal.

    Access to HTTPS that uses a self signed certificate now requires adding it to ".config/cacert.pem" - CN has to match the hostname as well.

    There are some errors in kodi_crash.log, such as:

    ERROR: ## LibreELEC Addon ## oe::load_url(releases.json) ## ERROR: (URLError(gaierror(-3, 'Temporary failure in name resolution'),))
    ERROR: ## LibreELEC Addon ## oe::load_url(updates.php?i=nostats&d=libreelec&pa=x8-h_plus.arm&v=le9-kodi_18.3&f=) ## ERROR: (URLError(gaierror(-3, 'Temporary failure in name resolution'),))

    Even after disabling all of auto-updating, they still appear.
    Using wget on first one worked, but I noticed that "telnet" is unable to connect to anything outside of LAN.
    There were no problems installing add-ons, so I guess its not a big deal.

    To sum it up, when it first broke I considered getting a newer box, but with this update there is no point, it works pretty damn good!

    Thanks datrh for your work!

  • Hi, Owned Minix X8H running Minix Offical Firmware (KOT49H.20160324). Wanted to try LibreELEC 9.X with Kodi 18.

    Attempt update using USB Burn Tool

    - Unable upgrade via USB Burn Tool, receive error "Parse burning image fail" while loading LibreELEC-X8-X8H.arm-LE9-Kodi_18.3.img.

    - Re-downlaod img and upgrade via USB Burn Tool, receive error "Parse burning image fail" while loading LibreELEC-X8-X8H.arm-LE9-Kodi_18.3.img.

    - Re-downlaod img and upgrade via USB Burn Tool, receive error "Parse burning image fail" while loading LibreELEC-X8-X8H.arm-LE9-Kodi_18.2.img

    Next, trying update using SD

    - Tried Update Bootloader - Not working for me - Burn the GZ img to a SD using LibreELEC.USB-SD.Creator.Win32, Browse the SD and rename "boot_autoscript" to "boot.scr", Insert the SD in the minix and boot the minix while holding reset switch for 5 -6 sec (the bootloader will be patched)

    Result: Boot into recovery mode, but not sure which to select such as apply update from ADB, apply update from ET and etc.

    Burn the GZ img on 32GB SD

    Result: LibreELEC.USB-SD.Creator.Win32 created two partition 511MB and 32MB.

    Both method doesn't seem happening for me. I believed i should have missed out some important step or confused with sequence.

    My plan is to make the box with Kodi 18, prefer running on internal memory. instead of boot from SD.

    Forgive me, i am newbie for Android. Need serious help here.||||||

  • Great work, thank you so much for keeping my X8H+ alive and kicking!

    It all works perfectly for me with a small exception: I cannot seem to get audio directly through the optical port. I have the AML-M8AUDIO, S/PDIF selected as the audio output device and it sends audio through the HDMI cable to the TV which is fine most of the time. (and I can connect my audio amp to the TV's optical port through S/PDIF which works while the TV is on). For music though I would prefer to connect my amp directly to the X8H+ optical port while having the TV off, but I cannot seem to get that working. Any ideas, please?

  • humantoz

    Burn image (LibreELEC-X8-X8H.arm-LE9-Kodi_18.3.img) to SD ! with the TOOL under downloads (Black Banner above) . ( I mostly run the SD burning tool as ADMIN!

    how to patch the minix bootloader :

    burn the GZ img to a SD

    browse the SD and rename "boot_autoscript" to "boot.scr"

    insert the SD in the minix

    boot the minix while holding reset switch for 5 -6 sec (the bootloader will be patched) (little hole on the back - paper-clip worx fine)

    let Libreelec boot and configure ssh, etc

    restore your cfg if needed

    After you boot to LE, connect to your box over SSH and run installtointernal command. This will copy LE from SD card to internal memory with all your data. (user will be root and password will be your password)

    You dont BURN the image straight to the box :-)

    Happy holidays

    Edited 2 times, last by Klaver7 ().

  • Thank you very much, Klaver7.

    My Minix X8H make alive again with your clear guideline. Successfully installed LibreELEC-X8-X8H.arm-LE9-Kodi_18.3.img.

    - Adjust refresh rate to 50Mhz, box to resolve screen freeze issues

    Wanna find out more about shutdown function behavior

    - When power button push on minix neo, choose shutdown from menu. -> minix shut-off TV (which is known behavior)

    - When i power on TV after 10 minutes, the shutdown screen remain.

    - Thus, i will need to unplug and plug power in order to power-up minix.

    Is this normal?

    Did some reading on the forum, it mentioned to fix shutdown issues, reflash minix with minix_x8_x8plus_x8_h_newbootloader_FW9 or X8H_PLUS_LOLLIPOP_RC2_NEWBOOT.

    What is the difference of both version?

    Which one is running Kodi 18?

  • Yes with the "Stock" ROM it is ! Now - "minix_x8_x8plus_x8_h_newbootloader_FW9" - firmware will give you proper shutdown, Just be patient after flashing and starting it back up > it can take a long time to boot up android as it has to build all the cache files etc. so be patient.

    After that you will again have to hold the reset to break the bootlaoder again with the LibrElecec SD. :-)

    and btw dont freak out with a black screen during first startup Android, so be patient!

    Edited once, last by Klaver7 ().