feedback for test build LibreELEC-RK3328

  • I have the issue where some 4 of my HD free to air channels are played at 50 fps and other 2 are still played at 25 fps.

    I have not tested your samples yet, but is the issue that a 25hz mode is selected? You can remove the 25hz modes from the resolution whitelist and keep the 50hz modes, that way a 50hz mode will be selected when a 25hz video is starting (same as in Krypton).

  • but is the issue that a 25hz mode is selected? You can remove the 25hz modes from the resolution whitelist

    Looked at all those settings.

    I have no 25hz whatsoever in my resolution options to whitelist or disable.

    I'll see what you get when you try playback on those recordings.

    Damn only 2 channels are affected which confuses me as to why. :/


  • Looked at all those settings.

    I have no 25hz whatsoever in my resolution options to whitelist or disable.

    I'll see what you get when you try playback on those recordings.

    Damn only 2 channels are affected which confuses me as to why. :/


    you can try to deselect 24 hz

  • kostaman can you try removing one mode from the whitelist and then save/OK, possible that the default whitelist we ship is used.

    I will test your samples later.


    Also dmesg and Kodi debug log when you start one 50fps and one 25fps channel could help identify what is happening.

  • I've just tried the build from 09-Sep-2018 on my Rock64 - and WOW! Tvheadend finally works, both for SD and HD channels :thumbup::thumbup: Also 4K seems to work, although I have only one channel to test it with.



    One thing I have noticed - the board often does not boot from your images unless I take SD card to my macbook and run FirstAid tool.


    Many thanks for your effort.

    A user of Rock64 boards and Tvheadend

  • I've just tried the build from 09-Sep-2018 on my Rock64 - and WOW! Tvheadend finally works, both for SD and HD channels :thumbup::thumbup: Also 4K seems to work, although I have only one channel to test it with.


    Many thanks for your effort.

    how about deinterlacing?

    Is it working?

    Can you change deinterlace settings in osd?

  • how about deinterlacing?

    Is it working?

    Can you change deinterlace settings in osd?

    The option to change it is still inactive (greyed out), but picture quality increased visibly, especially at dynamic scenes - like if something was enabled by default.

    A user of Rock64 boards and Tvheadend

  • can you try removing one mode from the whitelist and then save/OK, possible that the default whitelist we ship is used.

    I will test your samples later.

    I removed all EXCEPT 1920 x 1080p 50 Hz from whitelist.

    No good. Still the same 25fps on the 2 HD channels that have this behaviour.

    I reverted back to my initial Whitelist as #291

    Took Logs


    ABC HD 25 fps playback log

    Code
    1. Librerock64:~ # paste /storage/.kodi/temp/kodi.log
    2. http://ix.io/1mnJ
    3. Librerock64:~ # dmesg | paste
    4. http://ix.io/1mnK

    SBS HD 50 fps playback log


    Code
    1. Librerock64:~ # paste /storage/.kodi/temp/kodi.log
    2. http://ix.io/1mnM
    3. Librerock64:~ # dmesg | paste
    4. http://ix.io/1mnN
  • The option to change it is still inactive (greyed out), but picture quality increased visibly, especially at dynamic scenes - like if something was enabled by default.

    You are correct, the deinterlacer should be activated automatically when needed by rkmpp and as you have noticed it is not showing in Kodi video settings.

    The options for deinterlacer in video settings is only applicable when EGL/GLES is used for video rendering, and not the case for direct-to-plane rendering.

  • H264 1080i deinterlacing working well.

    Very stable now.

    I hope mpeg2 1080i can also be possible, still plays with ffmpeg rkmpp mpeg2 (SW) decoding. Software decoding is only fast enough for <720p. H264 is replacing mpeg2 now, but would be great if it's still supported.

  • You are correct, the deinterlacer should be activated automatically when needed by rkmpp and as you have noticed it is not showing in Kodi video settings.

    The options for deinterlacer in video settings is only applicable when EGL/GLES is used for video rendering, and not the case for direct-to-plane rendering.

    That’s great thanks!

    Will try this tonight!

    Where i can find this testbuild?

  • Kwiboo

    I tested latest CvH build on my mvr9 box, but after some minutes watching livetv (720p50) I get buffering, sometimes box hang after some minutes and sometimes I get a reboot. Others report here stable playback of livetv.

    Do I have wrong settings, could it have to do with disable debug shell?


    this is the relevant debug log http://ix.io/1mpa


    Maybe a temperature problem? After some minutes in home screen livetv works again for some minutes then puffering starts again.


    EDIT: Obviously no temperature problem, yesterday after cold boot I watched a 720p50 livetv channel for about 2 hours without hickups. (temp was around 80 °C).

    Edited 4 times, last by polo_joe ().

  • I am seeing some odd behavior on my Rock64 when pausing videos for a long period of time.

    Frequently I will pause a video and leave it that way for hours.

    After I installed the last test release videos which have been paused for a long time will resume and continue to play.

    However when they are stopped, the system will stop outputting video rather than returning to the Kodi GUI.

    I can access it remotely, so it has not completely crashed.

    Is anyone else seeing this behavior, or do I need to try reloading my image again?

    -Written by a team of angry monkeys.

  • I also saw this behavior on mvr9 box sometimes when I stop livetv channels. Issue is not reproduceable regularly.

    Only way to get video output back was to reboot with ssh.

    systemctl restart kodi didn't help for me.

  • Anyone know if it's possible to burn LibreELEC to emmc storage, erasing Android instead of running from a micro-sd card? I saw it was done for rk3399 but looked a bit complicated.