Bluetooth audio stops working after a while

  • I have been trying to use my bluetooth headphones ( sony mdr-zx770bn ) with my raspberry pi 3 for a while now (onboard bluetooth), and it's easy to get working with either OSMC, the latest openELEC beta or the latest LibreELEC build (I just took the file from the downloads page) but it always stops working after a while (20 minutes the last time I tried it). I have to completely disable the bluetooth audio out (set output to hdmi, disable bluetooth) and then reboot, set it up again (bluetooth on, connect to headphones, change to Pulseaudio bluetooth) to make it work again for some time (in my anectodal evidence the time it worked the second time was significantly shorter, I believe 10 minutes). I can provide logs if you tell me how to.

    Also, what is going on with openELEC and LibreELEC? I don't get it, is openelec dead? Is it true all the developers moved over here? And why?

  • but it always stops working after a while (20 minutes the last time I tried it)

    Same problem here with a TaoTronics bluetooth headset. No error message, even the headset still says it's connected. But the sound is just gone.

  • I would start in the following way...

    enable debug logging and providing the following logs if everything works as expected...each row is a single command:

    dmesg | pastebinit
    pastebinit /stoarge/.kodi/temp/kodi.log

    Then use the headphones until they stop working. Then provide the same logs again to compare what might happen.

    Without logs it's only guessing.

  • I have the same Issue with Librelec 7.0.2 and a LG Bluetooth soundbar LAS350B

    Here is the log when audio stopped ( video keeps on working) :

    Seems to happen only with one file Which is 5.1 Dolby.

    Hope this helps? Let me know if you need additional details.

    Edited once, last by lrusak ().

  • I have the same issue, raspberry pi 3 LibreELEC v7.90.006, any solution?

    I have this issue too. No solution so far, for me is maximum 1 minute and also the video is freezing.

  • Also, what is going on with openELEC and LibreELEC? I don't get it, is openelec dead? Is it true all the developers moved over here? And why?

    Let’s rock this gig! – LibreELEC <= that's the best explanation we'll make in public. The only thing that changed since is the number of active developers working on LE increased a load.

  • Same here! Audio stopped, video keeps running, BT Headphone still connected. Works sometimes 60-90min sometimes only 10-20min.
    Next days i will post a log.

    And the usability is also terrible:
    Raspi connected on AV receiver with passthrough mode on HDMI out.
    To hear over BT Headset i must disable passthrough mode, power on the BT Headphone and connect with Raspi and the switch to Pulse Audio.
    Other way doesnt work.

    Try this: LibreELEC ;)

    LibreElec 7.02, Philips BT SHB9150BT.

    Edited once, last by Cris_ ().

  • Have a play with current alpha builds, i've seen multiple comments about BT stability being better (although not in a pulse audio context).

  • Having the same issue here.
    Works fine if I use a BT USB adapter though, but this defeats the purpose of having onboard BT...

  • Hi All,

    I've the same issue on my RPi3.
    I did a fresh install of LibreELEC some days ago

    here are the LOGs:

    I didn't realice that could be problem with DTS-5.1 audo...
    So, in the next days i will do more tests regarding this issue and provide more logs or details!

    Please, let me know any idea on how to provide useful information

    Hope this can be fixed!!

  • Same problem here, bluetooth speaker stops working after less than 1 min, using Rpi3 with onboard bluetooth

  • Here a debug log from starting a AC3 5.1 .mkv (little bit cleaned the log).

    LibreElec 7.0.2 + SHB9150 Stereo Bluetooth Headphones


    • kodi.log

      (70.59 kB, downloaded 259 times, last: )
  • I've been chasing down the same problem--very difficult to trace the problems, but it doesn't seem to be anything wrong in Kodi, it's actually in the bluetooth stack. With a bluetooth keyboard connected, I found when the Dolby Digital audio started to cause problems it also caused the keyboard not to work.

    In trying to troubleshoot, I found other references to problems with the built-in bluetooth device on the Pi3. Since I happened to have a Bluetooth USB dongle, I disabled the built-in bluetooth by adding the following to /flash/config.txt


    This disabled the built-in bluetooth, but does not disable USB bluetooth. Interestingly the built-in bluetooth is not USB, and I believe the root issue is actually the bandwidth for the data interface with the built-in bluetooth being insufficient for hi definition audio.

    Anyway, with USB bluetooth device streaming audio works perfectly even with Dolby Digital. Seems annoying to have such a limitation on the built-in hardware.

  • but it always stops working after a while (20 minutes the last time I tried it).

    Same problem - I'm using "August EP650 Headphones" - have to do a reboot when the transmission stops

  • Sold my Amazon Fire TV and bought a PI 3 and it turned out to be a bad move on my part. Optical connection to my amp is disconnected and Bluetooth headset is giving me grieve non stop till I stopped using it..
    I experienced the audio disconnect problem just like everyone else that posted here before me but I just kept trying different setup every couple of days and until recently I discovered something by accident.
    If I load a video file into the sdcard and play the file from there, I can be on the Bluetooth headset for hours and I never had the audio disconnect on me. The minute I played a video from YouTube and the audio would just disconnect at random time. And this behaviour exhibits in both OpenElec as well as LibreElec. And I never had this Bluetooth headset problem when I was running either Kodi or SPMC on my Amazon Fire TV.
    Which brings me to suspect the PI3 hardware itself. So I was playing with different video/audio setting, changing buffer memory size in advancesetting.xml and non of those solved the problem.
    Earlier on this morning I downloaded the Pi configuration add-on and played with different setting and finally I was watching video on YouTube without my Bluetooth audio quitting on me for 4 hours non stop.
    Guys...If you are still having problem with your PI3 Bluetooth audio, please clock your PI3 to turbo at 1000 or higher and enable "Disable dynamic overclock" option to confirm my findings.
    Thank you.
    Time to shop for a 8 core Android box with Bluetooth and optical out.

  • Same problem - I'm using "August EP650 Headphones" - have to do a reboot when the transmission stops

    I guess, the most important line in /flash/config.txt is:

    force_turbo=1 #Voids Warranty! (uncomment to avoid CPU scaling down to 600Mhz)

    It seems, that bluetooth stops, if the CPU frequency goes down to 600 Mhz.
    If you enable force_turbo, you also may set:


    1000 Mhz is fast enough. If you don't set arm_freq, it will be set to the default value, 1200 Mhz.
    You can determine the current CPU frequency with the command:

    sudo cat /sys/devices/system/cpu/cpu0/cpufreq/cpuinfo_cur_freq

  • same problem for me, if i listen to shoutcast2 plugin sometimes works good, sometimes the sound is stopped and i am forced to reboot the system to make it work. If i play any movie (plugins too) the sound is droping after 10-20sec (the video is freezing too) and i need to reboot the system too. this problem is only when i use onboard bluetooth connected to my portable bluetooth receiver with analog output or with my bluetooth headphones.
    Please fix this in the new version of LibreELEC!!
    I am using LibreELEC (Krypton) v7.95.2 BETA installed as single OS (without any thing like "Noobs" or "Berryboot" or smtg) on a Raspberry Pi 3 Model B (microSDHC Samsung evo+ 16gb)

    already i have tried this, and the problem persist... still not working