LE9.0 remote configs ir-keytable Amlogic devices

  • I am using exactly the files boot2k3 was posting in #229. In Coreelec 8.90.1 it works in nightly-20150428 not.

    When using nightly ir-keytable is saying this for example:

    Thanks for testing!

    I was just told that there's currently an Amlogic specific bug in Kodi which prevents lirc events (which is used by default in LE for remote handling) from working.

    A workaround for that issue was PRed here: [aml]Register lirc in AML after #13761 by gelotus · Pull Request #13798 · xbmc/xbmc · GitHub - but it looks like it needs a bit of rework.

    It'll probably take a couple more days until this issue is fixed in Kodi, then a bit until Kodi is updated in LE. Until that's resolved IR remotes will stay broken in nightly Amlogic LE builds.

    so long,


  • Shoog this thread is titled "LE9.0 remote configs ir-keytable Amlogic devices". It would be good if CoreELEC specific stuff could be kept in separate threads, otherwise it gets really confusing.

    I think that is the point Shoog was making, regarding this

    I am using exactly the files boot2k3 was posting in #229. In Coreelec 8.90.1 it works in nightly-20150428 not.

  • Where do you get your CoreElec nightly builds ?

    There's no CoreELEC nightly builds, Legitwarrior referred to LibreELEC nightly builds available here.

    When this thread started, adamg's build was still named LibreELEC but now changed to CoreELEC, while LibreELEC started posting test builds for various devices. I also tested certain of them, remote control doesn't work. As told by adamg, this was due to Kodi, not LibreELEC or CoreELEC. In fact, adamg did a lot of work to make it works.

  • I have already gotten the keycodes but I am stuck about how to create the keymap and the rc_maps.cfg files.

    May I get help?, the link to explain the way to create the keymap file is not working.

    Edited once, last by guil70 (May 4, 2018 at 5:01 PM).

  • Teste imagens LibreELEC com KODI-18 para S9xxx

    Gentlemen tried everything I could not get by the remote to work

    If someone here uses KI Pro and got it to work please say how

    If possible remote control file.

    Thank you.

  • I'd like to add that from Coreelec 8.90.1 onwards "longpress" is supported but you have to switch from remote.xml to keyboard.xml for it to work.

    Do you mean you have to create a different file for keyboard buttons? I thought it was specified in the format of the file for example <keymap><global><keyboard> and for remote it is for example <keymap><global><remote>. As I understood, with the ir-keytable method all button presses where interpreted as keyboard inputs. Or am I wrong?

  • IR_KEYTABLE can operate in either keyboard or remote modes. Keyboard restricts you to using just the keyboard buttons defined within Kodi. Remote mode is more flexible. The first thing you need to do is decide which mode your system supports.

    This is where LIRCD comes in as it allows you to create a Frankenstein's monster of a hybrid when using a remote with Keyboard mode and allows you to trigger additional events beyond the standard keycodes of KODI. However it is nowhere well documented how to achieve this in LE, and it tends to disrupted the KODI keyboard keymap as well degrading its behavior.

    I consider the use of Lirc as a work around as highly unsatisfactory and so turn it off for a somewhat pure KEYBOARD remote experience.


    Edited 4 times, last by Shoog (May 20, 2018 at 9:34 AM).

  • I'm a bit late to the party. How can you use ir-keytable with keyboard keymaps? I'm asking because I usually use double maps for remotes via modifier ("longpress"). This is currently only possible in keyboard keymaps iirc.

    PS.: Is it normal that certain protocols such as NEC (and I think sanyo and JVC as well) are not really working well, having erratic multipresses? Not a big issue for me, just asking.

  • Sorry for a stupid question, but I am failing to map my own remote.conf in LE, and I found the same remote controller here. Is this method applicable on LE Thank you!

  • Hi there,
    I have a x96 with S905X. The system is working well, but just the remote control is not working.

    When I run `ir-keytable` OR `ir-keytable -t` and I get:

    `/sys/class/rc/: No such file or directory`

    I refer Infrared Remotes [LibreELEC.wiki] and found out the driver is not loaded.

    But I got no idea how to load the driver.

    Anyone can give me a clue?