LE9.0 remote configs ir-keytable Amlogic devices

  • These are the keymap files for M9Cmax remote:

    fgIX460.jpg


    UPDATE: the new package attached here includes also a XML file that lets Kodi to recognize correctly the backspace button in its virtual keyboard!

    Please read INSTALL.txt for instructions about the installation ;)

    Files

    • M9Cmax.zip

      (1.36 kB, downloaded 488 times, last: )

    Edited 2 times, last by redsquirrel87: New version with backspace working! ().

  • redsquirrel87, didn't see you posted earlier regarding the M9C.

    I started this morning to get the M9C max remote working. This is the keymaps.xml I'm using.

    Am testing right now, seems to work.


    By the way: I also recommend using Notepad++. Make sure you have only LF (line Feeds) between each command, there should be no CR (Carriage Returns). One can also fix this using the "replace" option and play with /n and /r.


    M9C:


    # table M9C type: NEC

    0x40404d KEY_POWER

    0x404043 KEY_MUTE

    0x404017 KEY_VOLUMEDOWN

    0x404018 KEY_VOLUMEUP

    0x40400b KEY_UP

    0x404010 KEY_LEFT

    0x40400d KEY_ENTER

    0x404011 KEY_RIGHT

    0x40400e KEY_DOWN

    0x40401a KEY_HOME

    0x404045 KEY_MENU

    0x404042 KEY_BACK

    0x404047 KEY_CONTEXT_MENU

    0x40400c KEY_BACKSPACE

    0x404000 KEY_0

    0x404001 KEY_1

    0x404002 KEY_2

    0x404003 KEY_3

    0x404004 KEY_4

    0x404005 KEY_5

    0x404006 KEY_6

    0x404007 KEY_7

    0x404008 KEY_8

    0x404009 KEY_9




    rc_maps.cfg


    # Keymaps table

    #

    # This table creates an association between a keycode file and a kernel

    # driver. It can be used to automatically override a keycode definition.

    #

    #

    # Format:

    # driver - name of the driver provided via uevent - use * for any driver

    # table - RC keymap table, provided via uevent - use * for any table

    # file - file name. If directory is not specified, it is first looked up

    # in /storage/.config/rc_keymaps, then /usr/lib/udev/rc_keymaps

    #

    # For example:

    #

    # driver table file

    #

    # gpio-rc-recv rc-streamzap streamzap

    # gpio-rc-recv * justboom

    # * rc-rc6-mce rc6_mce_new

    # * * hauppauge_new

    # table tanix, type: NEC

    meson-ir * M9C

    Edited 2 times, last by hansje ().


  • Thank you, I already posted the files in a previous post but it is waiting for moderation, so it is not visible for now xD

    However since you have the same tvbox, could I ask you a couple of questions? First of all, the backspace button works for you in the kodi virtual keyboard? Because for me if I map it to KEY_BACKSPACE it got the same function of the KEY_BACK button (so it closes the virtual keyboard instead of deleting the last character typed). Is the same for you?

    And about the 0-9 buttons, on previous versions they simply wrote the corresponding number in the virtual keyboard (I mean, I pressed 2 and in the keyboard appeared "2"), now they give a "old cellphone" keyboard function (for example if I press 2 in the keyboard appears "a", with another click it changes into "b" etc...), is the same for you too?

    Thx

  • Thank you for the confirmations, I spent hours to test all the available KEY values to find one that could reproduce the "real" backspace function but none worked :( At the end as I wrote in the (for now invisible) post above I chose to map it to KEY_DELETE value, so that at least you can re-map it to the real backspace function by using the Keymap Editor addon (since if you use the KEY_BACK/BACKSPACE value then it can not be used in the addon to remap any function). Same thing about the 0-9 buttons (I could not find any way to reproduce the old behaviour), but for them well, it's not a big issue since even the new function is not so pointless at the end xD

  • Interestingly, I also tested the KEY_DELETE earlier, but that didn't do anything here either :(


    The other issue I have right now is that the KEY_HOME and/or KEY_HOMEPAGE don't do anything (tried both).

    Shouldn't this bring you back to the Kodi home menu regardless of where you are?


    I'm not an expert, and still very much learning... Thank you for the tip with the Keymap editor, will check that out!

  • Has anybody got the remote working for the Nexbox A95X yet? I've tried what was mentioned earlier (on page 2) and it didn't work. No response whatsoever. I'm getting super frustrated with this by now :(

    If any of you got it working for your A95X, could you please zip all the relevant files up and help me out a bit? I'd be very grateful

  • redsquirrel87 , hansje ,

    you can check my post LE9.0 remote configs ir-keytable Amlogic devices for deeper configuration. I manually assign the keys. there are 2 examples, OLD is without longpress buttons and x92_keyboard with longpress(configured as keyboard)

    And backspace work as backspace for text and as back in other cases.

    Thank you very much, I edited my post with a new package that now includes also the XML keymap file. In this way now the backspace button works like it should xD

  • mini_m8sII:


    # table mini_m8sii, type: nec

    0x8030 KEY_NUMERIC_0

    0x8031 KEY_NUMERIC_1

    0x8032 KEY_NUMERIC_2

    0x8033 KEY_NUMERIC_3

    0x8034 KEY_NUMERIC_4

    0x8035 KEY_NUMERIC_5

    0x8036 KEY_NUMERIC_6

    0x8037 KEY_NUMERIC_7

    0x8038 KEY_NUMERIC_8

    0x8039 KEY_NUMERIC_9

    0x8051 KEY_POWER

    0x804d KEY_MUTE

    0x8053 KEY_HOME

    0x804e KEY_VOLUMEUP

    0x8056 KEY_VOLUMEDOWN

    0x80bb KEY_FASTFORWARD

    0x80bd KEY_REWIND

    0x8058 KEY_STOP # 1/a button on remote

    0x8026 KEY_UP

    0x8028 KEY_DOWN

    0x8025 KEY_LEFT

    0x8027 KEY_RIGHT

    0x800d KEY_OK

    0x8044 KEY_BACKSPACE

    0x8009 KEY_RED

    0x8011 KEY_GREEN

    0x8054 KEY_YELLOW

    0x804f KEY_BLUE

    0x8049 KEY_MENU

    0x801b KEY_BACK



    Edited 2 times, last by korcsi ().

  • Have a user the egoiggo s95x Remote Config?

    The Remote is this: LE9.0 remote configs ir-keytable Amlogic devices


    When i enter : ir-keytable -t
    then, returned "No devices found"


    Edited 4 times, last by TheMexx ().

  • X96:


    # table X96, type: nec

    0x101 KEY_NUMERIC_0

    0x14e KEY_NUMERIC_1

    0x10d KEY_NUMERIC_2

    0x10c KEY_NUMERIC_3

    0x14a KEY_NUMERIC_4

    0x109 KEY_NUMERIC_5

    0x108 KEY_NUMERIC_6

    0x146 KEY_NUMERIC_7

    0x105 KEY_NUMERIC_8

    0x104 KEY_NUMERIC_9

    0x140 KEY_POWER

    0x141 KEY_MUTE

    0x111 KEY_HOME

    0x1f5 KEY_VOLUMEUP

    0x1f4 KEY_VOLUMEDOWN

    0x116 KEY_UP

    0x11a KEY_DOWN

    0x151 KEY_LEFT

    0x150 KEY_RIGHT

    0x113 KEY_OK

    0x142 KEY_BACKSPACE

    0x143 KEY_RED

    0x10f KEY_GREEN

    0x110 KEY_YELLOW

    0x118 KEY_BLUE

    0x14c KEY_MENU

    0x119 KEY_BACK

    0x1f2 KEY_CONFIG

    Edited once, last by korcsi ().

  • Have a user the egoiggo s95x Remote Config?

    The Remote is this: LE9.0 remote configs ir-keytable Amlogic devices


    When i enter : ir-keytable -t
    then, returned "No devices found"


    You need to update your DTB Index of /releases/dtb

  • @CtrlAltDelEnter Why do you copy the files with Filezilla over SSH and not just copy them on samba shared folders?


  • excuse me

    I did not understand you

    I do not quite understand in English

    if it is not hard for you tell me where to get remote config for kIII pro s912?

    I have a remot.config that works on 8.90.11a, but it does not work on 8.90.4

    Thank you