Posts by isidoros

    @CtrlAltDelEnter Why do you copy the files with Filezilla over SSH and not just copy them on samba shared folders?


    Hi guys,

    I have an S905x minim8S which was updated to Adamg's 8.90.4 LibreELEC 9.0 Alpha and lost remote control functionality. I spend most of my Saturday reading the forums and i tried many configuration files from here but nothing works. I've tried the following remote.conf that i've found for my device but didn't work. When i scan my remote, the hex codes i receive are 0x8052, 0x8025, 0x8027 etc. I replaced on wordpad "0x" with "0x80" but again it didn't work. Can anyone help? Thanks a lot.


    Hello GDPR-2 . I uploaded here: Paste.ee - View paste 5Vo66 my log regarding the problem i had playing videos via wifi on local samba share. For anyone that missed my previous posts, my mini m8s s905x used to play perfectly any videos via wifi from my samba share while on kszaq builds. On latest adamg builds, most of my videos play 1-2 seconds and stop. Of course i love adamg builds and this is why i want to make them work again. Thanks :)

    Update: also from usb i can't play the same videos. I tried copying to usb a couple of them.

    I confirm that this problem is solved on the latest version. Good work!

    I appreciate your having issues but there is not a great deal that I can do about streaming issues, you have provided me with no useable information (logs) to be able to assist you.


    This release shares the same kernel and drivers as kszaqs build with the main difference only really being to the version of Kodi that is in so I really can't see the issue at present.


    I would ask that you test the file locally with a USB stick and if the issue resolves itself then it's obviously a network issue. Samba is the number 1 cause of these issues 9/10x as well, if you are using a NAS it should already support NFS.

    Hello GDPR-2 . I uploaded here: Paste.ee - View paste 5Vo66 my log regarding the problem i had playing videos via wifi on local samba share. For anyone that missed my previous posts, my mini m8s s905x used to play perfectly any videos via wifi from my samba share while on kszaq builds. On latest adamg builds, most of my videos play 1-2 seconds and stop. Of course i love adamg builds and this is why i want to make them work again. Thanks :)

    Update: also from usb i can't play the same videos. I tried copying to usb a couple of them.

    I'm repeating that i used to play flawlessly x264 & x265 up to 1080p videos from my samba nas over wifi. Some buffering from time to time is expected. But since the last couple upgrades most of the videos stop after 1-2 seconds after i press start. I mean they stop completely and go to previous menu. No buffering at all. I also tried a clean install without any improvement. If i find some time, I'll try to find more info on the logs. In the meantime i reverted to latest kszaq release and i confirm that it plays again flawlessly. In the future i'll switch to nfs as you suggested adam.

    Thanks for your time.

    First of all congratulations for the good work guys! You make our boxes smarter and we thank you for your effort. :)

    Your last version , even though it's pre-alpha, looks quite stable to me. I've got an s905x mini m8s. I've noticed just one bug after your last 1-2 updates. When i start playing videos from my nas over wifi, most of them stop after 1-2 seconds. Some play normally. I haven't noticed a pattern. I tried both x264 and x265, 720 and 1080. It didn't happen before with the first adamg or with all kszaq releases. Maybe is it a buffering issue? Should i change any setting?

    Thank you guys and i wish you a happy 2018.


    I also own a Mini M8S II (2G/8G, I loan it to my friend last Friday to test with his new 4K TV though). Optical output or SPDIF has been working from the very early days. Once you select HDMI audio output on System Settings menu, audio will output through SPDIF at the same time. Of course, I only connect the optical output to my AV receiver. You said 'I can get audio via my tv's toslink', it might be some misunderstanding. TV's toslink is only for optical audio output, not for audio input, at least in North America. TV Audio input always comes from HDMI, and then output the audio signal to your AV receiver via toslink.


    For 'passthrough', it means your Mini M8S II will not process (or doing any conversion) on the audio track(s) and pass it out to your AV receiver through HDMI or SPDIF.


    As for CEC, I found it works flawlessly (except suspend) with all my TVs since 005 or even before that (2 Toshiba, 1 Panansonic and 1 LG). Usually you need to turn this feature of your TV on first, then it will recognize how many devices connected to the TV are using CEC.


    Yes, I made a mistake regarding the SPDIF passthrough. I meant i wanted to send DTS audio from M8SII to my tv via HDMI and from my tv via toslink to my AV receiver. But i realize that to do it, my tv should support SPDIF passthrough probably.
    Also now the optical output of M8SII sends sound to my AV receiver successfully. So I suppose there was a problem with my cable or my toslink switch or something. I confirm toslink output works.
    I also tried to change my HDMI cable and now I have CEC working.
    I'm sorry for posting without having tested thoroughly first. :)
    So i think pretty much everything is ok with Libreelec and my box.

    I confirm that 008 version of kszaq works perfectly from SD on my MINIM8S II (8GB ROM with 2GB RAM) . It has hevc 10bit hardware acceleration, something i was trying to fix long time as the initial firmware doesn't support it although S905X supports it. Wifi works, everything works, even the remote control works quite well. The remote control can even turn the device off and on.
    The only thing I can't make it work is audio via Optical toslink output. On settings i see 2 hdmi and 1 Bluetooth outputs. I've tried them but couldn't make the Spdif work. I haven't tried passthrough. If it works i can get audio via my tv's toslink.
    Also CEC i think worked but now it's dead.
    Thanks a lot kszaq for the good work. I hope you can fix also toslink and CEC. :)