LE9.0 remote configs ir-keytable Amlogic devices

  • Right, but as mentioned above, there is a bug in 3.14 kernel for Amlogic (right?) that dramatically reduces precision. I can only repeat again, the same remote, NEC protocol works much better on PC, actually I see no difference remote vs usb keboard.

    BTW maybe option to choose which mode to use ("keyboard mode" with old remote.conf or ir mode as it's set currently) could be possible? Whe remote acts as keyboard, even very cheap remote works much better.

    BTW I see no benefits from buying remote that costs more than box itself :) while I can get this cheap air mouse remote: wechip-w1-mini-air-mouse-akumulator-englishrussian-2-4-ghz-wireless-keyboard-pilot-dla-systemu-windows.jpg_640x640.jpg - it works super fast, as wiereless keyboard and air mouse is also there.

  • Thanks very much for the quick and friendly responses.

    I do have an airmouse/kb controller which works and I love, but my wife hates it!!

    Anyway all is working now, I had an error on line 1 of my config file (total n00b!!) :cry:

    Thanks again!!


  • How can I load the configuration of a remote control when I create a new compilation of librelec? I already have a file with the mapped keys.

  • How can I load the configuration of a remote control when I create a new compilation of librelec? I already have a file with the mapped keys.

    you cannot load the files until after the initial setup is carried out using a keyboard, or perhaps wireless remote.

    After the reboot, I use coreftplite to copy the files over to the correct location. then reboot again, & remote should work.

    Samsung RU7400 Onkyo HTX22HDX Nvidia Shield HD Homerun Duo (Living Room)

    Samsung UE40ES5500 X96 Max+, Fire TV 4K Stick (Bedroom)

    Synology DS920+ Plex Pass


  • Coreelec brings back old remote.conf support. If remote.conf is there, it will be used. Otherwise, new config will be used. This is excellent.

    Edited once, last by giaur509 ().

  • all warmly welcome!

    and immediately apologize for my English.

    not sure what I'm writing in the right topic, but still.

    I have a Raspberry Pi 3 B+ with libreelec 8.95.001 installed.

    I decided to fasten it to the IR remote.(at once I will make a reservation, in Linux I am full 0, but the Internet+(ctrl+C and ctrl+V) solves)

    stuck the sensor to the GPIO, the console I have from iconbit media player.

    table for remote control found here in this topic.

    the table contents are copied to /storage/.config/rc_keymaps / rc_maps.cfg

    the content of the table:

    now try:

    LibreELEC:~ # ir-keytable
    Found /sys/class/rc/rc0/ (/dev/input/event4) with:
    Name: gpio_ir_recv
    Driver: gpio_ir_recv, table: rc-rc6-mce
    lirc device: /dev/lirc0
    Supported protocols: other lirc rc-5 rc-5-sz jvc sony nec sanyo mce_kbd rc-6 sharp xmp
    Enabled protocols: lirc nec rc-6
    bus: 25, vendor/product: 0001:0001, version: 0x0100
    Repeat delay = 500 ms, repeat period = 125 ms

    yeah, it works!

    see if the machine can see the signals from the remote.

    this is a reaction to the OK(Enter) button on the remote:

    LibreELEC:~ # ir-keytable -t
    Testing events. Please, press CTRL-C to abort.
    3938.642988: lirc protocol(necx): scancode = 0x9f02
    3938.643011: event type EV_MSC(0x04): scancode = 0x9f02
    3938.643011: event type EV_SYN(0x00).

    yeah, there is a reaction!

    and now I face a problem when trying to register the keys from the table to the system:

    LibreELEC:~ # ir-keytable -a /storage/.config/rc_keymaps/rc_maps.cfg -s rc0
    Invalid parameter on line 2 of /storage/.config/rc_keymaps/rc_maps.cfg
    ir-keytable: Failed to read config file /storage/.config/rc_keymaps/rc_maps.cfg
    Try `ir-keytable --help' or `ir-keytable --usage' for more information.

    LibreELEC:~ # ir-keytable -c -w /storage/.config/rc_keymaps/rc_maps.cfg
    invalid NEC
    Invalid parameter on line 1 of /storage/.config/rc_keymaps/rc_maps.cfg
    ir-keytable: Failed to read table file /storage/.config/rc_keymaps/rc_maps.cfg
    Try `ir-keytable --help' or `ir-keytable --usage' for more information.

    what's wrong? What to do?

    thank you for your attention!

  • Hi all,

    I've created a keymap for WeTek Pro Remote by "porting" the remote.conf that was baked in LE 8.2.5 and it works fine. Now the Problem is that I don't know the corresponding commands to some buttons, especially the share button. Is there a way to determine the command by using the information from the remote.conf so the remote would behave like it did in LE 8.2.5.

    Greetings Jan

  • Ok found a way myself.

    Table for WeTek Pro Remote

  • Hi Kurogane Jan!

    I also have a problem with the Wetek Pro Remote under LE9. Can you tell me exactly what you did or which files need to be created or changed? Did you get the keyboard up and running?



  • Hi,

    I have generated a config file for my Beelink GT1 and GT1U remote. I think the ir codes are the same with the Mini MV III II. I have mapped a few keys to use it with Libreelec. Please take a look in the beelink_gt1 file.

    Hello nice, I also have the Beelink GT1 Ultimate and my remote does not work on Coreelec 9.0.1.

    I do not know where to put your "beelink_gt1.zip" file. I was looking for /storage/.config/rc_keymaps but did not find it.

    Can you please write me exactly where to put it. I do not understand much.

    Thank you for the information

  • hi there just follow the instructions in the first post. You can skip noting each key and just use the codes I've posted. AFAIK the keyboard doesn't use IR but something other which is why the pro remote comes with a short usb dongle which you have to connect to your device.

    Sincerely Jan

  • I've got Wetek Play 2 and faced with an issue: remote key codes were totally remapped in LE9.0, and, moreover, several keys represented as obc255:

    DEBUG: HandleKey: 0 (0x00, obc255) pressed, action is

    Here's a tiny fix to make these keys, like * (KEY_FAVORITES), work in KeyMap Editor.

    Create a custom Lircmap.xml (vi /storage/.kodi/userdata/Lircmap.xml):

      <remote device="devinput">

    It re-binds malfunctioning keys to some basic XBMC keys, which exist in Kodi.

    Edited 3 times, last by i3laze ().

  • Could somebody help me please? I have been struggling for 2 nights to make the remote working in CoreElec 9.01 on a sd card for a Rikomagic MK22 box S912 2G/16G.

    I managed to produce a file called mk22 and saved it in /storage/.config/rc_keymaps together with the file rc_maps.cfg containing this line meson-ir * mk22. After executing the command ir-keytable -a /storage/.config/rc_keymaps/rc_maps.cfg -s rc0 the result in putty is:

    OLD keytable cleared

    Wrote 12 keycode(s) to driver

    Protocols changed to nec

    Then my remote works fine in Kodi, but after reboot it stops working, and I have to start all over again. What am I doing wrong? I am lost.

    I tried several device trees, gxm_q200_2g, gxm_q201_2g_1gbit and qxm_q200_2g_minix_neo_u9.dtb.

    I also tried installing CoreElec 9.00 first, make the remote work and then let it upgrade to 9.01, during update I read that device tree is being updated, aml_autoscript is updated and remote-toggle/meson-ir/ is enabled in device tree. After that remote is also not working anymore.

  • Could somebody help me please? I have been struggling for 2 nights to make the remote working in CoreElec 9.01 on a sd card for a Rikomagic MK22 box S912 2G/16G.

    Wrong Forum.

    Please take your issue to CoreELEC Forum.

  • Hope someone of this great Comunity can help me for my Problem.

    I`ve installed LE 9.0.1 to the micro SD Card on my Probox2 AIR.

    LE is running and the original "AirMouse" Remote control (2,4 Ghz) works fine out of the Box.

    But my second IR Remote ( similar to the one like Lordjontan in post #47) does not work.

    Lordjontan : I put your files (m8s and rc_maps.cfg) in the specific folders and executed ir-keytable -a /storage/.config/rc_maps.cfg -s rc0 and ir-ctl -t 50000  and ir-keytable -D 375 -P 100

    After that the Remote Protocol is changed from rc-6 to nec and everything works fine.:)

    But after a reboot of the box i have to execute this three commands again to change the Protocol back to NEC and the delay time etc...

    Hoy can I permanently "set" the Protocol from "rc-6" to "nec"??

    Thank you....

    Edited once, last by gohakn ().

  • you can add the lines to your autostart.sh stored in /storage/.config

    remember to make this file executeable



  • Hello everybody,

    yesterday I upgraded fom LE 8.2.5 to LE 9.0.2.

    My XBox-One IR works with my old ir-keytable config and out of the box as well!

    But, what would happen, if everything works proper, after an upgrade? ;)

    So I realized, if I press a button often a little faster, some click events are skipped, or nothing happens anymore till I press another button!

    So I played a little with some ir-keytable settings and found these ones for acceptable:

    ir-keytable -D 200 -P 120
    ir-ctl -t 20000

    But these are not perfect compared with LE 8.2.5, so maybe someone has found out some nicer settings for this remote.

    Thanks for support,


    PS: Great work with LE 9