WebGrab+Plus

  • Tried to install latest service.webgrabplus-8.2.104l.zip preview on rpi3 running LibreELEC (official): 8.1.1 8.2, kernel: Linux ARM 32-bit version 4.9.43 and recived a dependency error kodi.log


    RMuDW38.png

    Have you downgraded your LibreELEC from Milhouse to 8.2?

    if so, then your LibreELEC Add-ons repository and Mono points to 9.0

    Try to install Mono (8.2.x) then WebGrab+Plus

    Looking forward to your feedback

    @

  • Yes you were right I had downgraded from a Milhouse nightly at some point in past, re-installing Mono from libreELEC addons repository resolved issue of installing latest version of service.webgrabplus. Thanks, will now test new version...see whats changed and what if any user files needs re-creating etc.

    RPi4, (LibreELEC 10.0 Nightlies) hdmi0 -> Philips 55PUS7304 4K TV, hdmi1 -> Onkyo TX-SR608 AV Receiver

  • Here is a preview of a new revision of the webgrabplus addon. service.webgrabplus-8.2.104l.zip
    Thank you for testing and providing feedback.

    Tested with following observations :-

    • Backup folder with contents within, does not appear to have been created in /storage/.kodi/userdata/addon_data/service.webgrabplus.backup. upon installation of latest preview version.
    • Copying WegGrab++.config.xml from my own previously saved settings into /storage/.kodi/userdata/addon_data/service.webgrabplus and then running program manually appears to work just fine with no perceived issues :-)
    • When service.webgrabplus user configuration settings are modified, they are retained correctly when next viewing configuration settings for any modification. (I removed the run after boot 300 value and changed run time from 3 to 4 a.m.) ;-) :-)  lYHtKTi.png


    Thanks for the update :-) :-)

    RPi4, (LibreELEC 10.0 Nightlies) hdmi0 -> Philips 55PUS7304 4K TV, hdmi1 -> Onkyo TX-SR608 AV Receiver

    Edited once, last by MikeKL ().

  • Hi, I have not tested the latest version but noticed that the parsing fails with this error:


    Code
    Config syntax exception:
          file: WebGrab++.config.xml
       message: 
    WG.Common.InvalidConfigException: [Error   ] Corrupt config file[Error   ] An error occurred while parsing EntityName. Line 157, position 86.
      at WGconsole.Config..ctor (System.String ConfigurationFilePath) [0x00082] in <156d31036d71438db116fb7c359c6068>:0

    when the channel name contains an & value.


    So for example sky cinema sci fi & horror causes the parse error.


    I guess it needs to be escaped such as

    Code
     &amp;

    but hoping it could be done in the addon code.


    Thanks

  • Slight update from use of latest service.webgrabplus-8.2.104l.zip preview.


    hmmmm Is latest preview version + Kodi behaving correctly with regard to a combination of overall timezone i.e. UTC + DST?

    (This is one of change areas mentioned for latest 2.x versions of webgrabplus)


    My Kodi/Libreelec Regional settings are to "Timezone Country = Britain (UK)" "Timezone Europe/London" and time is definitely correct in Kodi GUI, however when I use TV Guide Fullscreen with a guide.xml created with latest webgrabplus preview version all EPG timings are behind by one hour.

    (Currently still on British Summer time in UK which if i understand correctly is UTC + DST)


    For reference I am using latest UK's radiotimes.com.ini for webgrabplus to create my guide.xml


    Another rpi device is currently working with timezone fully correctly (without any manual/modification intervention) using previous full release version of webgrabplus with possibly/probably an earlier version of radiotimes.com.ini (I am slowly checking through everything on both devices for fuller understanding of differences that could cause my issue)


    ----edit----


    Both rpi's running libreelec indicate date information with an understanding of BST i.e.


    LibreELEC:~ # date

    Mon Sep 25 18:18:43 BST 2017


    Wegrabplus log header information for rpi2 running current release version of wegbrabplus


    Wegrabplus log header information for rpi3 running latest preview version of wegbrabplus


    RPi4, (LibreELEC 10.0 Nightlies) hdmi0 -> Philips 55PUS7304 4K TV, hdmi1 -> Onkyo TX-SR608 AV Receiver

    Edited once, last by MikeKL ().

  • R U saying the latest WebGrab+ has been on LE v8.1.9?

    Yes you can install and test latest preview version of webgrabplus on your libreelec installation as explained with obvious preview usage "warnings" in this post by awiouy ;)

    RPi4, (LibreELEC 10.0 Nightlies) hdmi0 -> Philips 55PUS7304 4K TV, hdmi1 -> Onkyo TX-SR608 AV Receiver

  • Yes you can install and test latest preview version of webgrabplus on your libreelec installation as explained with obvious preview usage "warnings" in this post by awiouy ;)

    If WebGrab+ 2 has been on LE 8.1.9, why would I want to re-install it?

  • I cannot get this to work with tvh. Can anyone help? keep getting:


    Code
    xmltv: /storage/.kodi/addons/service.tvheadend42/bin/tv_grab_file: no output detected
    xmltv: /storage/.kodi/addons/service.tvheadend42/bin/tv_grab_file: grab returned no data


    Have pointed file to a folder in .kodi and not userdata. I have pointed to the correct file (which is grabbing data from sites and making the xml file which is 6mb big)

  • I cannot get this to work with tvh. Can anyone help? keep getting:


    Code
    xmltv: /storage/.kodi/addons/service.tvheadend42/bin/tv_grab_file: no output detected
        xmltv: /storage/.kodi/addons/service.tvheadend42/bin/tv_grab_file: grab returned no data


    Have pointed file to a folder in .kodi and not userdata. I have pointed to the correct file (which is grabbing data from sites and making the xml file which is 6mb big)

    I may have run into the same problem and found a workaround:


    Assuming you have set up wg++ correctly and performed a run, your epg data should be located here:

    /storage/.kodi/userdata/addon_data/service.webgrabplus/guide_wgp.xml


    Following the instructions from here I downloaded tv_grab_wg++

    Since /usr/bin is read only on LibreELEC I put it in /storage/.kodi/addons/service.tvheadend42/bin/ where TvHeadend is certain to find it.


    LibreELEC's busybox has issues with this bash script however ("bashisms"), so it needs to be edited:

    - replace line1 with:

    #!/bin/sh

    - point xmltv_file_location in line4 to the wg++'s guide_wgp.xml

    - replace line9 with:

    if [ $# -lt 1 ]

    - replace line26 with:

    *) [ "${arg:0:1}" = "-" ] || delim="\""


    Oops, there are no smileys in scripts...remove one of the doubled opening and closing brackets, and equal signs, respectively.


    Deactivate/activate TvHeadend and choose tv_grab_wg++ as XMLTV grabber module.

    Click on "Re-run Internal EPG Grabbers".

  • Could some one tell me how to run multiple instances of the same program?


    I want to run webgrabplus simultaneously 3 instances to reduce the time and then join it all together in one process.


    My current download takes 4-5 hours to complete.

  • Hello


    Is webgrab++ still working for horizon.tv (nl). with mono?


    I read on the webgrab++ forum that horizon.tv changed something and mono on linux doesn't like that anymore.


    Thanks

  • Hi,

    there are programs for windows and android to watch online stream tv / radio channels.

    Also for user that is using webgrabplus+ for epg guide.xml generating there is a very simple windows tools

    xmlgrabplus to create the complicate webgrabconfig.xml on the fly (it also can automate webgrab++ to generate the epg xml)


    A nice windows tool is also xml&store4me to generate the guide.xml and distribute it somewhere local on disc, lan or on webspace.

    Now you can access your prefered epg guide from everywhere you want and on each device that can handle guide.xml bases data


    www.manyplay.de


    manyplay(windows/android) is free to play each start for one hour without donation.


    xmlgrabplus and xml&store4me are free to use and working on windows without installation.

    Edited once, last by manyplay ().

  • In addon there is old version of WebGrab+Plus - V1.57 .

    New site.ini files require version 2.1 or 2.1.5

    How do I upgrade WebGrab+Plus? I don't want to wait another year.


  • Hi everyone, this is my first post, and I am writing to you for a problem with this addon.


    Thanks to the modification of Leo D, I managed to make WebGrab work on my Wetek Play 2 with the Libreelec version of Raybuntu and Tvheadend, the problem now is that some channels do not receive the downloaded EPG, in fact some channels are empty, even if I inserted the channell in the .config.


    What can I check to see why the EPG is not added to these channels?


    Sorry for my English ;)

  • Here is a preview of the webgrabplus addon, which provides webgrabplus 2.1.5.

    It should run on any LibreELEC system.


    Configuration files have considerably changed.

    BACKUP YOUR CONFIGURATION BEFORE INSTALLING.

  • Here is a preview of the webgrabplus addon, which provides webgrabplus 2.1.5.

    It should run on any LibreELEC system.


    Configuration files have considerably changed.

    BACKUP YOUR CONFIGURATION BEFORE INSTALLING.

    Is the above the manual or the program itself?