8.0.2 to 8.2.0 update problem(s)

  • Thanks but I don't use Homegroups. If using them would solve my sharing issue, I'm all ears. For the meantime, I'm sticking with LE 8.0.2 until I find a work-around.


    did you try giving the guest account a password and using that?


    but yes it should solve the issue... it did for me. I wasn't able to share anything until i started using the homegroupuser and password.

  • That fixed my problem. I haven't rebooted my computer yet to see if there's no login needed, but for the time being I can now access all my media. It took about an hour since I had to enter all the new paths. I don't think I had to add "kodi" to "share with" on my PC since I already had "everyone" but I did it anyway. Kodi asked for "server name" instead of address. That confused me, but I added 192.168.x.x and it worked. Someone needs to post a complete step-by-step procedure on the forums so it can help others.


    Thanks everyone - especially CypherZ

  • Glad it works! No Thanks. You can now upgrade libreelec anytime. The settings Will be saved!

    Using : Intel NUC6CAYS - 8GB Ram - 32GB SSD - LibreElec 8.2.0

  • I'm going crazy over this as well.


    I have windows 10 with my share folders upstairs with intel nuc with libreelec 8.2 downstairs. When I try to browse for samba shares it doesn't even see any. Not even libreelec's...


    Is there an alternative to samba?

  • I'm going crazy over this as well.


    I have windows 10 with my share folders upstairs with intel nuc with libreelec 8.2 downstairs. When I try to browse for samba shares it doesn't even see any. Not even libreelec's...


    Is there an alternative to samba?

    Try zeroconf instead of samba as a workaround till you get used how to use the new libreelec smb...you ll have to install Bonjour on your windows 10 tough

  • I'm going crazy over this as well.


    I have windows 10 with my share folders upstairs with intel nuc with libreelec 8.2 downstairs. When I try to browse for samba shares it doesn't even see any. Not even libreelec's...


    Is there an alternative to samba?

    Did you read this entire thread. I had the exact same issue as you and it's fixed now. Your Windows 10 shares must have a login and password assigned. In Kodi, edit the source for your media and click browse - go to the bottom of the list to add network path (or something like that). Then add your Windows 10 IP address (192.168.x.x) where it asks for network share name. Add the name of the share path (videos, movies, etc) and then the login and password for the shares. You may have to edit the Windows "share with" to include the login name for the shared paths. Yes, I stumbled trying to figure this out too - even with help. A clear step-by-step guide or YouTube video would really be helpful.

  • blueribb, perhaps you could write guide? even if you do a basic it guide, it would help. Place under a new thread, so it doesn't get lost in this one.


    Although I have a windows 10 pc. I use nfs to the storage on my nas.

    Samsung RU7400 Onkyo HTX22HDX Nvidia Shield HD Homerun Duo (Living Room)

    Samsung UE40ES5500 H96 Pro, X96+, Fire TV 4K Stick (Bedroom)

    Synology DS414 Plex Pass

    :)

  • The exact steps are in this thread. Just read

    Using : Intel NUC6CAYS - 8GB Ram - 32GB SSD - LibreElec 8.2.0

  • yes, but blueribb suggested someone wrote a guide, to make it easier.

    Samsung RU7400 Onkyo HTX22HDX Nvidia Shield HD Homerun Duo (Living Room)

    Samsung UE40ES5500 H96 Pro, X96+, Fire TV 4K Stick (Bedroom)

    Synology DS414 Plex Pass

    :)

  • A very easy solution is to install Plex server on you windows server machine, then you can share via UpnP automagically. Add the Plex app to Kodi and it takes a step away.


    That's what I've been doing until I get around to fixing samba.

  • Simply read this topic and iT works. No need for a manual

    Using : Intel NUC6CAYS - 8GB Ram - 32GB SSD - LibreElec 8.2.0

  • Why are people suggesting to change from hostname to ip address in the smb path?


    There should be no reason to do this, in fact I have just done the upgrade and the only changes I had to make were add the local user to the shares in Windows then add the credentials to the hostname from file manager in kodi and set it to remember the credentials for the path. All media now working again.

  • That is not the suggestion.


    The new Windows samba does not allow BROWSING to the path, so you have to type the actual path.


    You used to be able to browse the windows network to find the path. Now you can't get farther than smb//windows network/...


    The solution is to type the path and add your credential.


    In my case; all of my shares are owned by the admin account and they are shared to "everyone". The account must have a password.

    In windows 10 you don't have to login in at every boot; if you run>netplwiz uncheck the "users must enter name an password" box, if you have more than one account you can add them in the box; click save. done.


    I am the only one in my house with access to the computers so I try to disable as much security as I can.

    Edited once, last by donbrew ().

  • You described the samba wizard in post #27.


    That is the part about typing the path then entering the user and password in sources.


    What is confusing is they still include the "browse" option that does not work anymore. I guess they could modify that to "type the network address here, they follow the directions".


    I had to read this thread and your post #27 to understand it, but it is easy.