Help with TX5 Pro

  • Hi, at all



    I have tried to run LibreELEC on this device from USB many times but without success.



    I've download the IMG for s905x and i've tried to use default dtb, and downloaded version of this for 2GB version, i've burned with RUFUS without problem and i've added the fake.zip to use the 2 method to boot, i've also triedthe reset button, but here i have a problem, the box go into recovery with this screen and no way to run ELEC, someone please can help me?


    20171026_200412.jpg

  • Does it boot to Android?

    If it does install Terminal Emulator from Play Store.

    Remove the fake.zip file from USB. It's not needed in this case.

    Insert USB pendrive into USB port which is closer to microSD slot (this is very important).

    In Terminal Emulator enter this command:

    reboot update

    Your box should boot from USB.

    This method worked with my TX5 Pro.

    The toothpick method never worked for me.

    TX5 PRO S905X

    Edited 4 times, last by yatoya ().

  • I had no problems using a microsd card with Libreelec. But you have to use the app update&restore in android click on browse and then choose any zip file. Then click on update and it should work.

  • There must be something you're doing wrong or there's a problem with USB pendrive or USB port itself.

    One more time:

    1. Download LibreELEC-S905.arm-8.2-8.1.10.img.gz

    2. Download this dtb gxl_p212_2g.dtb

    3. Remove all partitions from your USB, create new one and quick format it. If you don't know how here's a tutorial or use different pendrive.

    4. Burn LibreELEC-S905.arm-8.2-8.1.10.img.gz with Rufus. Don't change any settings in it. Best if you download Rufus one more time and use with default settings as it is.

    5. (optional) Remove dtb.img and copy gxl_p212_2g.dtb to pendrive. Rename it to dtb.img

    TX5 Pro should boot with default dtb.img as well so you can skip this part.

    6. Now follow the steps from my previous post.


    1b. Boot to Android.

    2b. Install Terminal Emulator.

    3b. Insert USB pendrive into USB port which is closer to microSD slot (this is very important). Only one USB port will do the trick. If you're using the wrong one it won't boot.

    4b. In Terminal Emulator enter this command:

    reboot update


    That's it.

    If your box still hangs in Recovery I advise to use microSD card instead of USB pendrive.

    If the problem will persist even with microSD card you can install TWRP Recovery using this Official TWRP App and repeat the whole process one more time.

    TX5 PRO S905X

    Edited 2 times, last by yatoya ().