Parsec addon

  • Is there anyway to install parsec in libreelec??

    Or update the moonlight addon with support for Parsec?

    It works in raspbian/retropie and osmc.

    But are all debian based os.


    Parsec works with more gpu's.


    Any help or advice would be appreciated

  • Thanks for your input much appreciated. So from what I read it may be possible. But unfortunately I think its beyond my skills at this time. Not that I wont try. lol

  • Could you provide some links to it? Google is messed up due the astronomical unit parsec and i can't find anything about it.

  • It works really really well.

    The easiest method I found to install was by kozova1



    Parsec-Integration-With-RetroPie/README.md at master · Kozova1/Parsec-Integration-With-RetroPie · GitHub


    It works in retropie following his install method also works in osmc as I tried it but having issues launching it from kodi itself. I can only launch it by ssh by typing Parsec or Parsec.sh


    Out of all the systems I run on my Pi I prefer Libreelec the most would love to implement it in some way if at all possible.

  • Could you try to download parsec-rpi.deb

    extract the deb and take the parsec binary (parsec-rpi.deb\data.tar\.\usr\bin\parsec) and copy it to your pi.


    login via shell

    chmod +x parsec

    systemctl stop kodi

    ./parsec


    Idk if this is maybe already enough.


    As it is an property system not that easy to test without an account.

  • Im at home now. Does connect ok and quickly.


    issues are:


    It seems to work even passing keyboard input etc through.

    Seems to crash and stop service when games and video are played.

    No audio pass through when media is played to. So couple of little problems.


    Below is my session without my IP/server addresse marked as (censored)


    Connecting to 192.168.0.2 port 22, please wait...

    login as:

    [email protected]'s password:

    ##############################################

    # LibreELEC #

    # LibreELEC – Just enough OS for KODI #

    ##############################################


    LibreELEC (official) Version: 8.0.2

    Lounge:~ # cd /storage/.parsec/

    Lounge:~/.parsec # ./parsec

    -sh: ./parsec: Permission denied

    Lounge:~/.parsec # chmod +x parsec

    Lounge:~/.parsec # ./parsec

    [2017-10-17 17:37:27 D] APP.hostname = Lounge

    [2017-10-17 17:37:27 D] APP.local_ip = 192.168.0.2

    Parsec Build 133-6 on rpi


    USER LOGIN

    ----------

    Email address: [email protected]

    Password:




    Save password? (y/n): y


    [2017-10-17 17:37:50 D] APP.build = 133-6

    [2017-10-17 17:37:50 D] APP.platform = rpi

    [2017-10-17 17:37:50 D] APP.user_id = censored


    SERVER LIST

    -----------

    1) Mothership (Scott)


    Select server: 1


    [2017-10-17 17:37:54 D] CLI.server_id = censored

    [2017-10-17 17:37:54 D] CLI.try_lan = 1

    [2017-10-17 17:37:54 D] CLI.nat_local = 111000

    [2017-10-17 17:37:54 D] CLI.nat_remote = 111000

    [2017-10-17 17:37:54 D] CLI.bud0 = 192.168.0.10:10686

    [2017-10-17 17:37:54 D] CLI.bud1 = 192.168.0.10:10687

    [2017-10-17 17:37:54 D] CLI.bud2 = 192.168.0.10:10688

    [2017-10-17 17:37:54 D] CLI.client_x = 1920

    [2017-10-17 17:37:54 D] CLI.client_y = 1080

    [2017-10-17 17:37:54 D] CLI.decoder = omx

    ALSA lib /home/chewitt/LibreELEC.80-images/build.LibreELEC-RPi2.arm-8.0.2/alsa-lib-1.1.2/src/confmisc.c:767:(parse_card) cannot find card '0'

    ALSA lib /home/chewitt/LibreELEC.80-images/build.LibreELEC-RPi2.arm-8.0.2/alsa-lib-1.1.2/src/conf.c:4371:(_snd_config_evaluate) function snd_func_card_driver returned error: No such file or directory

    ALSA lib /home/chewitt/LibreELEC.80-images/build.LibreELEC-RPi2.arm-8.0.2/alsa-lib-1.1.2/src/confmisc.c:392:(snd_func_concat) error evaluating strings

    ALSA lib /home/chewitt/LibreELEC.80-images/build.LibreELEC-RPi2.arm-8.0.2/alsa-lib-1.1.2/src/conf.c:4371:(_snd_config_evaluate) function snd_func_concat returned error: No such file or directory

    ALSA lib /home/chewitt/LibreELEC.80-images/build.LibreELEC-RPi2.arm-8.0.2/alsa-lib-1.1.2/src/confmisc.c:1246:(snd_func_refer) error evaluating name

    ALSA lib /home/chewitt/LibreELEC.80-images/build.LibreELEC-RPi2.arm-8.0.2/alsa-lib-1.1.2/src/conf.c:4371:(_snd_config_evaluate) function snd_func_refer returned error: No such file or directory

    ALSA lib /home/chewitt/LibreELEC.80-images/build.LibreELEC-RPi2.arm-8.0.2/alsa-lib-1.1.2/src/conf.c:4850:(snd_config_expand) Evaluate error: No such file or directory

    ALSA lib /home/chewitt/LibreELEC.80-images/build.LibreELEC-RPi2.arm-8.0.2/alsa-lib-1.1.2/src/pcm/pcm.c:2450:(snd_pcm_open_noupdate) Unknown PCM default

    [2017-10-17 17:37:54 I] * play_sdl_init/SDL_OpenAudioDevice[43] = 0

    [2017-10-17 17:37:54 I] * audio_thread[473] = -11000

    [2017-10-17 17:38:03 D] CLI.exit_code = 0


    Hope these may be things we could sort out if possible. Just want to say thanks for your help.

  • I've been looking around and it seems no sound card is selected.


    most say you can add this to config.


    Try adding this to /boot/config.txt


    dtparam=audio=on


    Dont know if that works with libreelec but I will try it out when I get up in the morning.


    When I type


    aplay -l


    It replys with this:


    aplay: device_list:268: no soundcards found...


  • Please ensure you set up an account with parsec and have the parsec server running on your main pc or cloud pc first.

    Download available from Parsec | Stream Games And Play From Anywhere | Cloud Gaming


    Method:

    Download


    parsec-rpi.deb


    unzip or extract which will give you a data.tar, open the tar file go into usr/bin/ there is a file named parsec.

    Copy this file.


    I then created a folder named .parsec withn the storage folder in libreelec I used sftp application to do this like filezilla. I thought best to keep things in order. Copy the parsec file to the .parsec directory you just made.


    ssh into libreelec type


    cd /storage/.parsec/


    Then hit enter.


    Now type


    chmod +x parsec


    Then hit enter


    Now type


    systemctl stop kodi


    Then hit enter


    Then type


    ./parsec


    Then hit enter.


    Parsec will now start to run after a few seconds and ask you to enter your email address and password for parsec and it will show you your servers. mine was number 1. So I typed 1 and hit enter. It should log in show you your desktop with no sound and if any media is played it will crash and close. Test this yourself if it works great if not then try this fix Which I found from here

    (No sound on RPi3 with LibreELEC · Issue #39 · bite-your-idols/Gamestarter · GitHub)

    TheFix below.


    ssh into libreelec and type:


    mount -o remount,rw /flash
    <br>

    nano /flash/config.txt


    add / change entries below:



    hdmi_force_edid_audio=1
    hdmi_group=1
    hdmi_mode=16

    dtparam=audio=on


    then hit ctrl+x Then Y for yes then enter to save the updated config.txt


    type reboot

    Then hit enter


    Once rebooted ssh into lebreelec

    and type


    cd /storage/.parsec/


    then hit enter


    Now type ./parsec


    then hit enter


    your device should have booted with soundcard enabled and Parsec should connect now. It no longer crashes or hangs. Now plays games and video with sound. Keyboard etc should work. I am currently using a ps3 gsme pad over bluetooth connected directly to pc. So have not checked it connected to Rpi to see if it works. It hopefully should. Will test this when I have a chance. As far as I know parsec is compatible with xbox controller by default. There is also a controller map file to add other gamepads maps too.


    Hope this helps to clear up most of it. Just need to implement into kodi menu to launch easily.


    I have tested running parsec both ways by exiting kodi with the systemctl stop kodi command and leaving kodi running. Parsec will load in front of kodi and doesnt seem to be a problem.

    I also advise looking at this link below with advance settings to change resolution, get rid of blue square and much more.


    Advanced Settings | Improve Parsec Game Streaming Quality


    The config files etc can all be found in the folder you made in /storage/.parsec/


    So as I said need a way of launching it from kodi. Also need a way of closing parsec.


    Just want to say thanks to CvH the admin above for helping me out couldnt have gotten this far without your help.

  • You can use "Advanced Emulator Launcher" to launch the parsec file from Kodi by creating a launcher via it's context menu (pressing "c")


    or you can use the skin "Eminence 2.0" and create a custom menu item with the action " system.exec(/storage/parsecfolder/parsec) " ... is this doesn't work create a shell script with extension .sh , do chmod on it to make it launchable and just add ./parsec into it