[8.90.6] LibreELEC 9.0 Alpha for S905/S912 devices

  • problem serth channel


    Code
    1. 2017-10-22 01:05:10.915 linuxdvb: Availink AVL6211+AV2011 DVB-S/S2 #0 : DVB-S #0 - DTV_CLEAR failed [e=Inappropriate ioctl for device]
  • Be sure to download and rename the correct dtb.img for your device and place it on your microSD.

    I copied dtb.img from 8.x S905X microSD to the 9.x microSD and the libreelec logo appears, but after a while it shows a mounting error (LIBREELEC_DISK can't be mounted).

  • No 23, 29 & 59 hz in this version.

    update:

    Just realized that 8.1.10 doesn't show thees rates either in cat /sys/class/amhdmitx/amhdmitx0/disp_cap, But they show up in kodi display settings, and my AVR reports thees rates when selected. In your build, they do not. If i add them to disp_cap in userdata, they are selectable, but i just get a black screen and have to restart kodi if selected.

    -2re


    8.90 ⇒ MeCool KI Pro ⇒ Onkyo TX-NR656 ⇒ SAMSUNG 65"LED/UHD/PQ1300/T2CS

    LG BP50NB40 USB Blu-ray


    Edited once, last by 2re ().

  • GDPR-2 there is a problem with the firmware for qca9377 they get copied to /usr/lib/kernel-overlays/base/lib/firmware/firmware/.

    So right now no wifi with that chip.

    Code
    1. makeinstall_target() {
    2. mkdir -p $INSTALL/usr/lib/kernel-overlays/base/lib/firmware
    3. cp -PR lib/firmware $INSTALL/usr/lib/kernel-overlays/base/lib/firmware
    4. cp -P usr/share/doc/qca-firmware/copyright $INSTALL/usr/lib/kernel-overlays/base/lib/firmware/LICENSE.qca
    5. }

    The mkdir should not include firmware as that is the only difference between your package.mk and that from kszaq.


    And I noticed rebootfromnand only does a regular reboot.

    Edited once, last by Nokogiri ().

  • Nokogiri You shouldn't be having any issue as all the modules are symlinked to their old location, there was changes in 9.x by the LE team and keeping them at their old location breaks the build.

    DS-1 Extract the img.gz and download rufus and burn the image to your USB drive with that as I've just tried it and had no issues, an easier option and the way I update is to just place the tar file in the Update folder on the Windows share and reboot the device.


    2re I have looked into this, disp_cap only displays what values the kernel is reporting and this is taken from the edid data your tv provides, the necessary kernel options are already enabled for 23/29hz @ 4k, all I can suggest is rebooting your tv/device and see if the option appears if your tv does indeed support these modes.

    Edited 3 times, last by GDPR-2 ().

  • GDPR-2 the module itself is not a problem. But the firmware for qca9377 ends up in /usr/lib/kernel-overlays/base/lib/firmware/firmware/. It took me 20 minutes to realize the problem is that as mentioned earlier the packag.mk creates $INSTALL/usr/lib/kernel-overlays/base/lib/firmware so that the cp -PR copies the folder named firmware from the deb and not only its content into $INSTALL/usr/lib/kernel-overlays/base/lib/firmware/. That means the module can't load any needed firmware. The symlink stuff works fine.


    Code
    1. [ 17.4034[email protected]] wlan: loading driver v4.5.20.037
    2. [ [email protected]] android_readwrite_file: file /lib/firmware/wlan/qcom_cfg.ini filp_open error
    3. [ [email protected]] wlan: driver load failure
  • DS-1 Extract the img.gz and download rufus and burn the image to your USB drive with that as I've just tried it and had no issues, an easier option and the way I update is to just place the tar file in the Update folder on the Windows share and reboot the device.

    Ok, it works.


    I've noticed that wifi is not working and the second reboot, after changing some things in the menu (such as language and stuffs like that) causes a filesystem corruption.

    Edited once, last by DS-1 ().

  • updated to this form sx05re on my s905 box, boots and works just fine but i cant find netflix plugin, tried kodi repo, tried all repos

  • Yeah,

    Kodi crashes each time, when tried to invoke inputstream from amazon/netflix,

    that's why I've reverted back to LibreELEC-S905.arm-9.0-devel-20171020154750-r27181-g427aded12.tar... :)


    updated to this form sx05re on my s905 box, boots and works just fine but i cant find netflix plugin, tried kodi repo, tried all repos


    Intall this repo - repository.netflix-1.0.1 - and then look for the plugin in it. ;)

  • Kodi crashes each time, when tried to invoke inputstream from amazon/netflix,

    Same here. When I select an episode, Kodi restarts.


    And another annoying bug: I was watching a 45min episode in HEVC and playback stopped 2 times without apparent reason. Just as if I'd hit the stop button, it threw me back to the episodes listing..


    I'll see if I kept a log and upload it.

    Running kszaq's LibreELEC 8.2.2.3 and adamg's LibreELEC 9.x 1.0.6 on Cooleme MB1 (S905X - 2GB/8GB)

  • Same here. When I select an episode, Kodi restarts.


    And another annoying bug: I was watching a 45min episode in HEVC and playback stopped 2 times without apparent reason. Just as if I'd hit the stop button, it threw me back to the episodes listing..


    I'll see if I kept a log and upload it.

    Dose this happen if you disable Adjust Display Refresh Rate ?

    -2re


    8.90 ⇒ MeCool KI Pro ⇒ Onkyo TX-NR656 ⇒ SAMSUNG 65"LED/UHD/PQ1300/T2CS

    LG BP50NB40 USB Blu-ray


  • Dose this happen if you disable Adjust Display Refresh Rate ?

    I'll check it when I have some free time.

    But I don't see how it can cause the playback problems I described.

    Running kszaq's LibreELEC 8.2.2.3 and adamg's LibreELEC 9.x 1.0.6 on Cooleme MB1 (S905X - 2GB/8GB)

  • I'll check it when I have some free time.

    But I don't see how it can cause the playback problems I described.

    Well, I have problems with rates at 23, 29 & 59. And if i force Kodi to one of thees rates, it restarts.

    -2re


    8.90 ⇒ MeCool KI Pro ⇒ Onkyo TX-NR656 ⇒ SAMSUNG 65"LED/UHD/PQ1300/T2CS

    LG BP50NB40 USB Blu-ray


  • I don't have a Netflix account so I'm unable to debug that issue unless someone wishes to share their account with me to debug the problem.

    Wifi has been fixed for some devices in the next build.

    I appreciate people reporting bugs but I need a copy of your logs to look into them further.

    Edited once, last by GDPR-2 ().

  • thanks for that, installed netflix just to get the same problem as you. keeps freezing and rebooting after i try to play an episode

  • thanks for that, installed netflix just to get the same problem as you. keeps freezing and rebooting after i try to play an episode

    It would help if you had provided a copy of your kodi log

    Nevertheless I have discovered the problem with the Netflix addon, it will be fixed in the next build.