Posts by aptalca

    That likely suggests the mount is dropping or disconnecting temporarily. The issue is, after reconnect, docker doesn't detect it without a container restart.


    I had a similar issue with a mounted smb share. Switched to docker mounted nfs, which doesn't drop (or maybe comes back properly).


    While I have no idea why it may be happening, disabling and re-enabling the the addon will restart the container and the mount should come back (as long as it's reconnected on the host).

    That's a restriction documented in the readme. Duckdns validation results in a cert with only one address covered. That's because duckdns only allows one TXT record set.


    So it can cover only one of the following at a time:

    domain.duckdns.org

    *.domain.duckdns.org

    nextcloud.domain.duckdns.org


    The readme recommends using the second option so it covers all (sub)subdomains, and using the www endpoint instead of the naked domain.

    If you're gonna reverse proxy, it doesn't matter what port nextcloud is set to as it won't be used. The addons already attach to the lsio network and advertise themselves with the dns host names "nextcloud", "mariadb", "letsencrypt", etc.


    Don't overthink it. Don't modify anything in the proxy conf, just follow the directions at the top and make the necessary changes to nextcloud config.php file so it allows reverse proxy access.

    I can't help you with your domain name or cnames, but if you want a reliable ddns address, look into duckdns. All subdomains to your custom domain automatically forward to your ip. With that, you can do nc.customname.duckdns.org


    For certs, you need to check the logs to see what went wrong. The commands are in the pinned thread about linuxserver docker addons

    In the config folder, you can find the nginx and php logs


    http would require modifying the default nginx site conf, which you can do, but we don't support it. We recommend reverse proxying (potentially via our letsencrypt image)

    If you map the port correctly in your docker run, the port will be accessible on the libreelec lan ip. Then you port forward on your router to make it accessible on wan (internet).

    Docker containers are sandboxed. They only have access to things that you specify. Go into addon settings, turn on additional parameters and input "--device /dev/ttyACM0” and see if that works

    It looks like jeedom doesn't create its database automatically. It expects you to first create a database, and set up a user with access to it.


    So you need to use the mariadb docker addon to create it. But keep in mind that the db and user creation only happens during first start. Once the databases are set up, we no longer touch it, because we don't want to break your stuff. If you want to start over, you need to uninstall the mariadb addon and tell LE to remove user data as well. If you changed the data folder location in the addon settings, you'll need to manually delete that folder.


    Then you can install mariadb addon again. It will open the settings page, allowing you to enter the user and database details. Once that's set up, then you can enter that info into jeedom.


    In jeedom, use the libreelec lan ip as the mariadb address (localhost refers to inside the container).