Can't access SMB shares

  • Hi all,

    I have just did a fresh install of Libreelec after using Openelec for a while.

    I have a msql library set up on my my main windows main and have copy over my advancedsettings .xml from my previous Openelec setup.


    My librarys all work and correctly show what is in the mysql database (so no networking issues) but nothing will play.

    If I try I get the warning "No longer available, do you want to remove from your library".


    The full paths of the files as in the db are "smb://IP/path/file.ext" and they are accessible from other machines.


    I have changed the workgroup name to match the name used on my network and I have tried enabling and disabling the samba server on Libreelec.


    Just wondering if there's anything that I may have missed or is it a known issue?


    Thanks

    Matt

  • No known issue imo, but it would be helpful to upload the log file, to take a look of it.


    rgds

    Hx

  • Here is what looks to be the relevant part of the kodi.log file.


    The strange thing is some fanart and artwork such as posters do display, but mostly not.


  • Ok, there is the section where error occours. But to see what's maybe wrong, we must see the whole log. Please don't post the log here, use the last item in Libreelec-Settings>>System>>[Log] to upload the log-file, and post url.

  • Did you make a backup and restore of database?you are probably seeing the restored library...and there is still a network issue between your box and server...is your windows user account password protected?

  • Heres the logs.

    TFiA


    No, I did not do a backup. As it was a new Kodi version, both Libreelec and my on windows machine (the server) I just started fresh and did a new scan.

    No username or passwords for the windows share, I can access it fine from my phone and other machines. Plus Libreelec IS reading the mysql database so no networking issues?

  • The problem is that Mysql server is not sharing the actual files on your sever but a library (shortcuts to the movies)

    So first you need to make sure that Libreelec can access those movies directly by going to file manager in Kodi and browse to your server and click on a movie see if it works...

    I m suspecting that the Mysql is using samba...if so and you are using LE 8.1.1 or 8.1.0 you need to enable SMB1 from Kodi services settings...If you want to be safer and use higher Smb 2 or 3 you need to make a new account on your server and make it password protected for it to work with LE...It's all in the LE main page...

  • If the path to the media files isn't in your sources.xml then Kodi won't play it - it's a security feature. So make sure the sources.xml on LibreELEC includes all the same paths (ie. sources) as the sources.xml on the Windows machine you are using to scrape the library.

  • Ah, thanks Millhouse and mario77. I did not expect anything to change from changing over from openelec, apart from Kodi being upgraded.


    I did see the options for SMB2 -> SMB3 but did not realise I am using SMB1.


    So I need to enable SMB1 and also add it to sources.xml. I'll try that when I get home.


    Thankyou for the help.

  • Enable SMB 1 to add source then you can go back to default....If it doesn't work you may need to password protect your windows account first or create a second account with password..

  • I have tried setting to SMB1 but still the same. I don't scan or add sources from this machine. This machine just has its advancesettings.xml set to mysql on my main machine. All the media is scanned in from the main machine using the IP.


    The thing is when I look on file manager I cant see any of my window machines on my network

  • Copied sources.xml over and no change. File manager cant actually see any of my machines when I go to the windows shares...


    Samba is set to min SMB1 max SMB3.

  • Samba is set to min SMB1 max SMB3

    Why are you changing the LibreELEC Samba Server settings when you're trying to access a Samba server on another machine?


    Try changing the "Maximum protocol version" to SMB1 in Settings > Services > SMB Client (this needs Advanced/Expert level settings) and you'll only use SMB1 (which means you won't be able to access servers supporting only SMB2+, which is a recommended configuration these days) but may allow you to browse your network (network browsing *only* works with the SMB1 protocol, and even then only under certain circumstances depending on other factors, such as server settings so is not guaranteed).


    If you want to browse your smb shares, then add them as sources, or add them as "network locations" in Kodi:

    IMOdG2M.png

  • I am having the same problem on all my LibreElec media centers, my windows 10 shares use to be accessible but no longer are accessible even via ip address, get the message "Operation Not Permitted". If I launch Kodi on my Nvidia Shield TV and do the same thing via IP address, the shares are completely accessible with no issue. I am not sure what the difference and what LibreElec is doing different than the Nvidia Shield TV is. I know Windows patched some holes with SMB vulnerabilities recently so I am thinking it related to that in some way, but no idea how to resolve it.

  • I had an old version running on my PI2 so installed the latest LibreElec. With Kodi on my PI I have set both protocol versions to SMB1. I can find my WORKGROUP and connect with SMB to my Synology NAS server without problems. I just cannot find my Apple Time Capsule. On my Mac and Windows 10 PC I can find the TC without any issue's. Only the LibreElec with KODI on my PI is having issue's finding it..... Tips?