Cubox i4 Pro

  • Vpeter, running into a bug with this build, when using my IR remote any time I click a button it is registering as 2 - 3 button presses. Doesn't happen if I use a a web based remote interface.

  • Maybe it is the issue mentioned in release notes:

    Quote

    If you experience “double button presses” after updating the Lirc service can be disabled in the ‘Services’ tab of the LibreELEC settings add-on.

    Gone...

  • I am currently using a Logitech Harmony Elite with the harmony hub.


    Also finding that certain video files are not playing the audio, and the video is choppy.

  • vpeter you truly safed my ass. a big "Danke schön!" for this post as I was migrating from openELEC to libreElec wondering why the newest version of libreELEC did not work.

    .. and again thanks for the 8.2 build ;):thumbup:

  • vpeter yeah I took that already and it works like charm for the moment. though I hit the same issue with the IR posted in this thread, but I could fix it by adding a new option to the eventlircd.service ("--repeat-filter").

    Actually one question pops up right now in my mind: How can I handle updates of LibreElece in the future with this specific build?


    Again thanks!

  • How can I handle updates of LibreElece in the future with this specific build?

    Disable automatic updates from LibreELEC settings and update manually. This applies to v8 only. V9 with Kodi 18 will be a different story.

    Gone...

  • First of all, I just wanted to say thanks vpeter for your work in keeping this alive.


    For many years, I have been compiling my own OE/LE for CuBox because I needed to include patches for some third-party drivers. I recently discovered those drivers have been mainlined, so I decided to give your build a try. It works perfectly!


    One question, though: It turns out I still need to build LE anyway this time so I can run the create_addon script to re-compile a couple of addons (the libs in 8.2.x are too new from my old versions).

    I know the imx6 project was removed from LE master a few months ago. I’ve tried to add the sub-directory back but I hit a bunch of different complication errors when I try to build either the latest master or 8.2.5 .

    Can you share what you needed to do to create yourself a working imx6 build environment for the latest versions?


    Thanks again!

  • Current le master and imx6 is no-go. You need to wait to get things sorted. When it is hard to tell.

    Gone...

  • Thanks, I thought that might be the case. I also tried to build from the 8.2.5 tag and that seemed pretty broken too.


    Obviously you’ve been able to build 8.2.5 in order to offer the image download. I am really impressed that you managed it. I and am wondering what patches and or build env changes you needed in order to make this work for you??

  • With linux kernel 3.14 it was build fine

    Code
    1. PROJECT=imx6 ARCH=arm LINUX_VERSION=3.14-sr make image

    Didn't check with 4.4 but I would say it also works.


    I would assume you have problems building le because of your host system (I'm using Ubuntu 16.04.4 LTS).

    Gone...