Live TV unusable since 7.0.2 on Cubox

  • Hello,


    I have been testing every single build since 7.0.2 and on every single build I have the same problem. I was expecting the issue to be fixed in LibreELEC 8.0.0 but the same issue is still there.


    I am using Tvheadend as client and Tvheadend 4.2 as PVR backend. I have a Cubox-i4x4 running kernel version 3.14 of LibreELEC. On the 7.0.2 version (with kernel 3.14) live TV is perfect. Channels tune with little delay, picture is perfect, audio is perfect, deinterlacing is perfect. In the issues below I have the EXACT same hardware.


    On LibreELEC 8.0.0 and all builds from 7.90.001 until 7.95.3, live TV is basically unusable. I started with clean installations so the issue is not with upgrading. I set up Tvheadend in the same way, all other settings for playback and system same as 7.0.2. Once I go to TV, I tune to any channel and channel plays after a bit of buffering (longer than 7.0.2 but reasonable). Then I switch to another channel and sometimes it switches ok with little delay. But once I try to switch again (second time) or even sometimes just switching the first time, the buffering starts, goes to 100% really slowly (10 seconds), nothing happens, buffering starts again to 100%, nothing happens, and so on. I have to stop playback. Then I try it again and same thing happens after maximum of two channel switches.


    I played with audio settings, video settings, deinterlace settings, etc. but nothing helps. I want to mention that on Tvheadend side, there are no errors so the issue is with Kodi. Something changed drastically from 7.0.2 that makes watching live TV unusable on my Cubox. I am not sure if anyone else is having the same issue.


    Addition to the simple tuning of channels, I have another major problem. That is the missing deinterlace settings of "Double rate (inverted)" which I need for many HD channels to deinterlace correctly. In 7.0.2 I have four deinterlace methods and the ones that work are "Double rate" and "Double rate (inverted)". In every version since 7.0.2, those are missing but they are replaced with "Bob", "Bob (half)", "IMX Advanced" and "Low Motion" or something like that. I know that "Bob" method is equal to "Double rate" but "Bob (inverted)" doesn't exist and I need it for proper live TV watching.


    Those are my two main issues. I can post logs if anyone wants to see them but for that I have to switch SD cards and annoy my wife. For now, maybe someone can tell me what's wrong with information above.

  • You do know that v7 is using Kodi Jarvis and v8 is using Kodi Krypton? I would say lot of imx6 changes happen in between.


    I think your problems must comment someone who is also using live tv (I didn't even try).

    Done giving support here because of last events.

  • Vpeter,


    I know that v7 is Jarvis and v8 is Krypton. I am hoping someone can explain and/or fix the live TV issues in v8 since I will not/cannot use v8 until these two issues are resolved. I just don't understand what exactly changed in Krypton or LibreELEC 8 that completely broke live TV.

  • Don't hold your breath waiting for such fixes.
    [hr]
    Can I made you one test image without some kodi patches?

    Done giving support here because of last events.

    Edited once, last by vpeter ().

  • Can you record a short sample of the movie from tvh?

    Done giving support here because of last events.

  • Record the TV using my phone or record using tvheadend? Because tvheadend shows no errors and works fine with Kodi Jarvis. I'm assuming you want me to record what happens on the TV screen when I try using LibreELEC 8.0.0 and live TV.

  • I want a sample recorded with tvh so I can see what happens on playback. Not that I can fix this.

    Done giving support here because of last events.

  • Here is the link to a recorded tvheadend stream:


    Manchester United - Bournemouth.ts - Google Drive


    So, I rebooted a few times, and continued testing switching channels. Seems like all is ok now. I tried switching channels and now I can actually switch.


    Also, seems like deinterlacing is ok. I have to switch from Auto to Bob on all the channels I tested so far. Otherwise, deinterlacing is not good or not turned on.


    Let me know what you think.

  • So I did more testing with deinterlacing. "Bob" works great on some channels. However on some channels no method is perfect. Comparing to 7.0.2, on those channels method "Double rate (inverted)" made the picture properly deinterlaced.


    So for me to switch to 8.0.0 I need the equivalent of "Double rate (inverted)" method. I'm assuming that would be "Bob (inverted)" but that method does not exist. How do I get that method? Can I make my own build? It should be possible if the method existed in 7.0.2.

  • About the deinterlace methods you need to ask imx6 kodi maintainer (mk01).


    And no, compiling custom version will not help.

    Done giving support here because of last events.

    Edited once, last by vpeter ().


  • About the deinterlace methods you need to ask imx6 kodi maintainer (mk01).


    And no, compiling custom version will not help.


    How do I get a hold of mk01? He doesn't seem to be active on Kodi forums and can't find him/her on LibreELEC forum.

  • Maybe you can open an issue for kodi: Kodi - TRAC


    No, he is not on le forum. And yes, he is very hard to catch :)

    Done giving support here because of last events.

  • PAJTAZ,


    I have here exact the same problem and still have, also went back last friday to 7.0.2 updated 7.03 no problems. Than updated to 7.95.2 LiveTv (does not works at first update stopped, but that problem could I solve thanks to this forum members) keeps on hanging while zapping and freezes after two or three times chancing channels. Also tried to install de libereelec 8.0 from sctratch using the USB0SD creator still the same problem. Been playing with al de interlace and deinterlace settings, several kind of audio possibilities, several SD cards simply no luck. BOB (depends on if I try it on an a IIyama it works, if I try it on my Panasonic Plasma it does not work, everything is grey out cannot choose anything) gives indeed the best results but when I switch from satelite (f.e. 19.2 to 28.2) same problems occurs again (I am using ASTRA 1,2,3). Same if I switch from a uncrypted channel to a crypted one. Also the starting of a channel takes a little while.


    I am living alone but have 4 CU-Boxes (one tn IX4X4 is used as server for Debian, TVH and Oscam) so I can test whatever en whenever I like. I must say I find this until now very disappointing, but I am glad that I found out thnaks to this thread that I am not the only person with this problem. Offcourse I can do things wrong but now I am so far that I have deciced to stay on libreelec 7.03 until I have read that all problems which occur now are solved or that someone can tells me what Iam doeing wrong.


    Kind regards
    :huh:

    LibreElec on Cu-Box with KODI

  • FransAlmere,


    I installed 8.0 from scratch. I had problems changing channels on the first boot. After I rebooted, I did not get the problem with changing channels. I made sure the latest Tvheadend PVR client addon was installed and I rebooted a few times. I did not test it extensively so I do not know if the problem is fully resolved but it looked like it was ok. Before rebooting, I also did the same as you: tried different audio settings, video playback settings, etc. I will also say that I tried some other versions like 7.95.2 and 7.90.005 and also had problems with changing channels but those were not fixed after reboot. Only 8.0 seems to work after reboot.


    As for deinterlacing, what I found out by searching Kodi forums and Kodi code updates was that Bob (inverted) deinterlacing method was removed from code. I asked why but nobody answered. For my TV, I need both Bob and Bob (inverted). I asked how I can get the Bob (inverted) again and nobody answered. I will try to do it myself in the next few days. If I manage to do it, I will post the patch here. Or if you cannot compile yourself, I can make an image for you to try.

  • Pajtaz,


    Thanks for your quick response.


    I am gonna give it a last try with a clean boot with Libreelec 8.0. But can you help me by giving me the place were you have found the latest release from the tvh addon. Or did you simply use the update function inLibreelec.


    Over BOB I have missed that it was removed from the code I also needed them both for my Panasonic TV's or should that now go automatic ? But any help in this respect will be appreciated.


    When I have made the clean install with Libreelec 8.0 with the latest update from the TVH addon I will announce it here if it works yes or no.


    kind regards

    LibreElec on Cu-Box with KODI

  • I used latest Tvheadend Client addon available from LibreELEC repository. Basically, update function in LibreELEC.


    For Tvheadend Backend, I use another machine that runs Debian Jessie Linux server. So if you are running the backend in LibreELEC on one of your Cuboxes then I guess you just update but I do not believe the backend is the cause of the problem (at least not for me since backend works correctly, it is Kodi the one with the problem of tuning channels).


    For deinterlacing, from doing my own testing, you will need both Bob and Bob (inverted). Whatever Kodi does to perform deinterlacing, it does not work perfectly for imx6 hardware (Cubox). Seems that Kodi cannot distinguish between needing Bob or Bob (inverted) automatically so I have to select the appropriate method for each channel individually. This is only for HD channels, for SD channels "Auto" is ok. I have Ziggo cable in Netherlands and for channels like BBC One HD I need Bob (inverted). Without inverted the deinterlacing is not correct.

  • pajtaz, would you be willing to test an image with added Bob (inverted) method (I'm looking a way to add it back)? Which image exactly are you using now?


    And can you give me a sample which needs bob inverted method? And which deint methods you are using now (I could quickly hijack one to achieve bob inverted)?

    Done giving support here because of last events.

    Edited once, last by vpeter ().