[8.2.3.1] LibreELEC 8.2 for S905/S905X

  • 2re

    In HDR mode you still get 444 8bit?

    Because for SDR you should be getting 8bit.

    If I don't set 10bit, than everything is played as 8bit.

    -2re


    8.90 ⇒ MeCool KI Pro ⇒ Onkyo TX-NR656 ⇒ SAMSUNG 65"LED/UHD/PQ1300/T2CS

    LG BP50NB40 USB Blu-ray


  • 2re  

    That is SDR only, and 1080P.

    Yes, I know HCFR, I contributed a little bit to it myself :p

    Ok, you/I misunderstood..;) You can use the same calibration for HD & UHD but not HDR. ;)

    -2re


    8.90 ⇒ MeCool KI Pro ⇒ Onkyo TX-NR656 ⇒ SAMSUNG 65"LED/UHD/PQ1300/T2CS

    LG BP50NB40 USB Blu-ray


  • Done some more testing... My TV is now calibrated with 444, 10bit, Switching to 8bit, the colors are under-saturated, and the white balance is way off. I could recalibrate with 8bit, but since LE wont autoswitch to 10bit, than 10bit content will be wrong. So by sticking with 10bit every thing's OK ;)

    -2re


    8.90 ⇒ MeCool KI Pro ⇒ Onkyo TX-NR656 ⇒ SAMSUNG 65"LED/UHD/PQ1300/T2CS

    LG BP50NB40 USB Blu-ray


  • hmm.... Setting playback(GUI settings) to 1080p for HD content(when 444, 10bit), has the same affect as setting 444,8bit....

    So there is some kind of color upmix going on, So is it LE or my TV???

    -2re


    8.90 ⇒ MeCool KI Pro ⇒ Onkyo TX-NR656 ⇒ SAMSUNG 65"LED/UHD/PQ1300/T2CS

    LG BP50NB40 USB Blu-ray


  • 2re

    Interesting. Sadly I don't have an AVR which can show me what the output signal of the box.

    My issue is with my TV switching into BT.2020 mode even in SDR mode if I use 10 bit output, this messes SDR up.

    I guess I'll just have to come up with a script to enable 10bit for when I want to play a HDR video and disable it after playback has started so that the box comes out of 10 bits when the playback stops.


    Regarding 1080P vs 2160P and color issues, I guess your best way to tell is to check what the AVR is saying. But it's possible that the TV responds differently to a 1080P 10 bit signal than it does to a 2160P 10 bit signal.


    I just tried adding a button to the skin UI to execute the echo '444,10bit' command, but using System.Exec just locks up Kodi.

    Well looks like I can't execute the echo command directly from Kodi. I guess it does not have permission to edit the file?

    Doing this via a Python script doesn't work either. Any help would be appreciated. I rather not to rely on an external device to switch between the two modes, and would prefer to do the switching directly from Kodi's UI.

    Any help would be appreciated.

  • What happens if you use 444, 10bit and GUI set to 2160p.(And adjust the saturation). On my TV 720, HD and UHD including HDR is perfect:) What happens on your's??


    ps. Minde that the GUI Colors will be different than the video;)

    -2re


    8.90 ⇒ MeCool KI Pro ⇒ Onkyo TX-NR656 ⇒ SAMSUNG 65"LED/UHD/PQ1300/T2CS

    LG BP50NB40 USB Blu-ray


  • 2re

    I didn't try it, but I also don't want to calibrate my TV this way, I don't see a point or how it can work just as well as it's supposed to in SDR.



  • FYI the Vizio M+P series will only do 444 chroma when the TV is in "Computer" picture mode - which means you can't have "Pure Cinema" enabled - you're gonna most likely have skaky/studdery video :(



    Spent a while figuring that out, but it is mentioned on the rtings reviews that it only supports 444 chroma via Computer mode.


    I've been doing my first HDR rodeo, trying to get it working on a buddies M50-e1 (2017). I was eyeing the TV myself but noticed some stuff I don't like - no 444 chroma unless you're okay with shaky video, NO DISPLAY INFO regarding refresh rate or 10 bit, etc - Just a resolution displayed under info. Bright spots in the corners of TV, subpar video upscaler (best is to set Libreelec to 1080p for all 1080p and below video). The TV does scale fairly decent from 1080p signal. Setting your box to 4K resolution for anything other than 4K is generally a bad idea. Let the TV handle 1080p to 4K scaling.


    When watching 720Pp/480i/p, I'm using an HTPC I built so I can use VAAPI motion compensated, and lanczao3. I then shrink the image to 85-88% which is what you'd see on a 42 inch (make sure to change the % by 1 or 2 each time, to prevent burn in). That's my secret recipe for 720p and below content for this TV.

  • Hello

    Do you know if it is possible to play, with good color diethering (or similar) HDR contents on non HDR TV?

    The playback "works", but I think the color are unsaturated

  • First of all I'd like to thank all contributors that helped making installation of LibreELEC on my Z69 box an almost boring experience :) What can I say, everything Just Works(TM). All my remotes (Yamaha AV receiver, Samsung Smart Touch) are functional without any tinkering.


    However, I have been naughty and installed LibreELEC to internal memory (all still working fine, no worries, and quite a bit faster).

    For giggles I'd like to boot the exerimental 9.x builds from the vacant SD card. But how do I tell LibreELEC to do that? There is a rebootfromnand command but no corresponding rebootfromsd. I have a few ideas what to try but am a bit worried to brick the box. Any official guidelines?


    Thanks

  • maha Simply insert SD card with LE9 and reboot. After running LE from SD/USB you box will look for an OS on SD card and USB drives before booting from internal.

  • maha Simply insert SD card with LE9 and reboot. After running LE from SD/USB you box will look for an OS on SD card and USB drives before booting from internal.

    Well, I am currently running LE from internal and it continues to do so even after inserting the SD card. Would I notice if the boot process skipped a corrupt image? Perhaps I made a mistake when flashing the SD card.

  • Since updating from version 8.2.1.2 to any version above (8.2.2.1, 8.2.2.2 and 8.2.2.3) i realize lags on certain live tv channels (using vu+ addon). These lags only appear when switching to a certain tv provider, all other channels or providers are playing without lags. After downgrading to version 8.2.1.2 the channels of this provider are playing without any lags. Any idea?

  • Do you use 8.90.1 as a daily driver?

    No. I installed it last night on SD card only mainly out of curiosity. Everything I tested worked fine. Since I wasn't really missing anything, I guess I will stick with 8.2.x.x for the time being.