[8.2.3.1] LibreELEC 8.2 for S905/S905X

  • Hello.

    I am an M8Sii and a UHD TV user.

    I installed rc1 this time,

    but I can't change subtitle position at UHD, not at FHD resolution.

    This is a very old issue. I hope it will be fixed in the next version ~

    Thank you.

    Edited 2 times, last by Aloe ().

  • don't suppose anyone has any insight on this?

  • in 8.1.9 i have problems in EPG, i'm using TvHeadend client and EPG data does not appear. I can see it loading but does not show where it should. Already compared settings with kodi installed in laptop and all settings are same, already try clear data, nothing works.Maybe a release issue?

  • If you think it's that version, try using an earlier version, to see if the same problem exists.

    Samsung RU7400 Onkyo HTX22HDX Nvidia Shield HD Homerun Duo (Living Room)

    Samsung UE40ES5500 H96 Pro (Coreelec), Fire TV 4K Stick (Bedroom)

    Synology DS414 Plex Pass

    :)

  • Hi,


    is there any way to force a certain display resolution? Problem is that my S905X isn't capable of displaying the resolution of 3840 × 2160 when it's hooked up to a Soundbar (HDMI IN). Only during the splashscreen when i'm rebooting the box! My only solution to "override" the situation is to boot it up directly on a HDM port of the TV and to replug it into the soundbar after the preferred resolution is set. Downside is that I'm losing CEC-Support because of this "method". Any suggestions?

  • Hi,


    is there any way to force a certain display resolution? Problem is that my S905X isn't capable of displaying the resolution of 3840 × 2160 when it's hooked up to a Soundbar (HDMI IN). Only during the splashscreen when i'm rebooting the box! My only solution to "override" the situation is to boot it up directly on a HDM port of the TV and to replug it into the soundbar after the preferred resolution is set. Downside is that I'm losing CEC-Support because of this "method". Any suggestions?

    If your tv has more than 1 hdmi port, you should be able to connect your box to port 1 and the sound bar to port 2, and somewhere in your tv settings you can set the sound from port 1 to be rooted out through port 2.

    -2re


    8.90 ⇒ MeCool KI Pro ⇒ Onkyo TX-NR656 ⇒ SAMSUNG 65"LED/UHD/PQ1300/T2CS

    LG BP50NB40 USB Blu-ray


  • If you think it's that version, try using an earlier version, to see if the same problem exists.

    Tried with earlier version and with .10rc, the problem for EPG not showing is due to the box not being time synchronized.

    tried several ntp servers but same result. Any setting i'm missing?


    Thanks

  • WiFi works fine. UI seems way too fast and not smooth.

    What does "too fast" mean? The "smoothness" patch turned off vsync at Kodi side but it is handled on kernel side so no tearing should be v

    is there any way to force a certain display resolution? Problem is that my S905X isn't capable of displaying the resolution of 3840 × 2160 when it's hooked up to a Soundbar (HDMI IN). Only during the splashscreen when i'm rebooting the box! My only solution to "override" the situation is to boot it up directly on a HDM port of the TV and to replug it into the soundbar after the preferred resolution is set. Downside is that I'm losing CEC-Support because of this "method". Any suggestions?

    1. Connect your box directly to TV (to make all resolutions available).
    2. Over SSH run cat /sys/class/amhdmitx/amhdmitx0/disp_cap > .kodi/userdata/disp_cap
    3. All resolutions from your TV will be always available.

    kszaq please can you push the tag to github for 8.1.10-rc1 thanks

    Code is not ready to be pushed, I will do it when 8.1.10 is released in 1-2 days.

    1. Connect your box directly to TV (to make all resolutions available).
    2. Over SSH run cat /sys/class/amhdmitx/amhdmitx0/disp_cap > .kodi/userdata/disp_cap
    3. All resolutions from your TV will be always available.


    This worked partially. Now it's locked to 3840 × 2160 @ 60 and doesn't change to HDR and/or 24Hz refresh rate.

  • Great work of kszaq.


    The "LibreELEC-S905.arm-8.2-devel-20170929194713-r26297-g04948e0.tar" upgrade works great in my newly purchased MXQ Pro+ and fixed both WiFi & BT problems as well.


    However I would like to report that after upgraded to the latest build "8.1.10-rc1", the "NHK Live" add-on is not able to work smoothly. Only the audio able to be streamed smoothly but the video stream is stuck like a single frame per second. Same apps works perfectly after downgrade the box from "8.1.10-rc1" back to "LibreELEC-S905.arm-8.2-devel-20170929194713-r26297-g04948e0".


  • Tried with earlier version and with .10rc, the problem for EPG not showing is due to the box not being time synchronized.

    tried several ntp servers but same result. Any setting i'm missing?


    Thanks

    Is the time zone setting under system set correctly?

    Samsung RU7400 Onkyo HTX22HDX Nvidia Shield HD Homerun Duo (Living Room)

    Samsung UE40ES5500 H96 Pro (Coreelec), Fire TV 4K Stick (Bedroom)

    Synology DS414 Plex Pass

    :)

  • 8.1.10-rc1 in OP. Due to Broadcom driver update I call it a "release candidate", please report any new issues over 8.1.9. Remember that you can always downgrade to a previous 8.1.x build with no data wipe, simply follow updating steps.

    Software decoded h264 10bit video in 720p resolution is sometimes not played smoothly with this version on my S905X test box. Interestingly the CPU load displayed only shows 60-70%, but the video is laggy. This problem is not persistent, sometimes it works fine, restarting the same video can result in smooth playback where it failed before. Is software decoded video using the same framebuffer as the GUI?

    Wetek Hub: LibreElec 8.2.3.1 (Philips 42PFL8404)
    MK808B+: LibreElec 7.0.2.7 (Samsung UE55H6270)
    OTT MXQ Pro 4k (S905): LibreElec 7.0.3.12k (Denon X1200W, 7.1, LG PF1500G)
    AKASO HM8 (S905X): CoreElec 9.0 dev build, Acer Revo 3610: Milhouse test

  • Hello, i've installed LibreELEC on SD Card and wi-fi is not working.
    I've got MXQ Pro 4K S905X with android 6.0
    Probably this box got unsupported wifi chipset (9082xs).
    Is there a way to check wifi chipset other than opening box (I don't want to lose warranty)?
    Tried apps like Aida64, CPU-Z but none of them shows wifi chipset.

    @edit
    Ok found a way to check chipset.
    Sadly it's 9083xu
    RIP my dreams about LibreELEC :P

    Edited once, last by Koyo ().

  • Software decoded h264 10bit video in 720p resolution

    That likely 10bit H264 combo (aka 10bit Anime) is NOT supported on 99.99% of media players and has to be CPU Software decoded every time.

    It's an out of Spec "release group" combo.


    AMLogic hardware does not have enough CPU ponies to reliably software decode that content.


    You need to buy Intel hardware or a NVIDIA Shield if you want reliability with that sort of CPU Software decoded video playback or Remux it.

  • RIP my dreams about LibreELEC :P

    Simply get a supported USB wifi adapter. I tested several that I own (with various Realtek chipsets, if I remember correctly) and they all worked and have better reception than the builtin ones. They cost less than 8€.

    Wetek Hub: LibreElec 8.2.3.1 (Philips 42PFL8404)
    MK808B+: LibreElec 7.0.2.7 (Samsung UE55H6270)
    OTT MXQ Pro 4k (S905): LibreElec 7.0.3.12k (Denon X1200W, 7.1, LG PF1500G)
    AKASO HM8 (S905X): CoreElec 9.0 dev build, Acer Revo 3610: Milhouse test