[8.2.3.1] LibreELEC 8.2 for S905/S905X

  • Starting from 8.1.5 release on my MiniMX box, status Led on front panel remains red all the time. Last working version (when led was blue when box is on) was 8.1.4.

    Does anybody else have same issue ?

  • Starting from 8.1.5 release on my MiniMX box, status Led on front panel remains red all the time. Last working version (when led was blue when box is on) was 8.1.4.

    Does anybody else have same issue ?

    Me too. And some other report same bug.

    Edited once, last by Sag ().

  • After the upgrade to the 8.1.x branch I was unable to connect to my "NAS" a Asus router with a USB hard-disk using samba.

    I fixed it for me, and posting this as reference for people who might run into the same problem.


    I tried all options suggested like "fixing" the SMB protocol version but none of them worked. I was able to find the NAS but when I wanted to connect it kept prompting for the password.

    I disabled the password security on my NAS to test if that was the issue, and it was able to connect.

    As neither Kodi nor the logs gave me any useful debug information I tried connecting to the NAS "manually" by using the SSH command-line.


    Quote

    LibreELEC-MeMoBox:~ # smbclient -L <host> -U <user>

    Enter WORKGROUP\users's password:

    Server does not support EXTENDED_SECURITY but 'client use spnego = yes' and 'client ntlmv2 auth = yes' is set

    session setup failed: NT_STATUS_ACCESS_DENIED

    This gave me something to work with, I googled and apparently my NAS isn't having the extended security samba is expecting so I need to disable it.

    By adding "client use spnego = no" and "client ntlmv2 auth = no" to the config file. I added them to /storage/.config/smb.conf and it worked for the manual command-line connecting.


    However Kodi was still unable to connect. As I found out it does not use the "system" instance of samba, but its own with its own config file.

    However you are able to customize it, so I did the following and that fixed my connection problems:



    TL; DR;


    Created file: /storage/.kodi/.smb/user.conf


    Added the following lines:


    Code
    #Samba client options
    client use spnego = no
    client ntlmv2 auth = no


    Works a treat :)

    Now, as a warning, you are disabling some "extra security" with these lines, so use with care.


  • Wow, you are amazing :)

    Wow you are amazing :)

    RPI3 1GB, Z4 RK3368 1GB, MINI MX-G 2GB, Mini M8S II (coreelec.org 9.2.1), H96 Pro (coreelec.org 9.2.1), ODORID N2 (coreelec.org 9.2.1), VIM3 PRO (coreelec.org 9.2.1), Beelink GT King (coreelec.org 9.2.1), Denon AVR-X2600H, LG 60SJ810V
    pel.hu

  • EDIT: Wouldnt it be better - to get a short clear instruction answer instead of "please read this"?

    "please read this" is a short clear instruction answer (to read what has already been written, instead of expecting to be spoon-fed) ^^

    Why would you expect people to repeat the same info over and over for those that won't do a little research for themselves?

    Being directed to the post where your question is already answered, saves you the effort of looking for yourself, without those helping you having to spend all their time repeatedly typing in the same information.


    Good to see you quickly realised what you were doing wrong and successfully corrected it :thumbup:

  • Starting from 8.1.5 release on my MiniMX box, status Led on front panel remains red all the time. Last working version (when led was blue when box is on) was 8.1.4.

    Does anybody else have same issue ?

    I can confirm on my NexBox A95x box. I didnt want to bother kszaq with it since I dont consider its something big and broken. :)

  • I don't mean to be rude, but if tings don't work, and your biggest problem is "Who to Call" then maybe your not as tall as DRAX, and are better of sticking with Android. :)

    -2re


    8.90 ⇒ MeCool KI Pro ⇒ Onkyo TX-NR656 ⇒ SAMSUNG 65"LED/UHD/PQ1300/T2CS

    LG BP50NB40 USB Blu-ray


  • Starting from 8.1.5 release on my MiniMX box, status Led on front panel remains red all the time. Last working version (when led was blue when box is on) was 8.1.4.

    Does anybody else have same issue ?

    This is due to added SYSLED support in 8.1.5. I will make this module optional so that only those of you who want to use it will load it.

  • This is due to added SYSLED support in 8.1.5. I will make this module optional so that only those of you who want to use it will load it.

    Thanks a lot, kszaq. It's nothing critical, but my kids noticed it and I couldn't find anything about on the forum, so suspected my box is broken. Now can wait patiently till next release.

  • Yep thanks for your feedback negt. I tried that one and still no WiFi is seen. Only can see WiFi if using the S905X 2G builds and the cpu reported the same Rev 20 as I get reported with a definite Mk II box ???


    Also tried connecting the box directly up to my main 8 port gigabit switch and it still shows on th eswitch indicators as only a 100Mbps standard port even with it booting up into default Android. So despite it saying on the bottom of the box it is a MINI MXIII, without any mention of a mark II and it also being a couple of mm deeper plus with the older remote too, it is clearly an S905X Mk II box with a standard 100 Mbps Ethernet port. How strange ?? Has anyone else here seen anything like this with one of these otherwise superb Beelink boxes ??


    Once I get a proper Mk II remote this box will be fine as a S905X Mk II box. Just very weird like they have put a Mk II board put into a Mk 1 box and together with a Mk 1 remote.

    Cheers
    RayW


    Tanix TX9 Pro 3/32GB S912

    Tanix TX7 2/32GB S905X

    Beelink MINI MXIII II 2/16GB S905X
    MXQ M12CX 1/8GB S905X
    MXQ M12 1/8GB S805
    Denon X500 AVR System

    LG 55SJ850T Super UHD TV

  • Hello. I have a box S905x and satisfied. Now I want to buy in the other rooms. What to choose now S912 or S905x for LE? Thank you....

  • I've noticed that the HD image looks better on the LibreELEC-S905.arm-8.2-8.1.2 release. I am wrong ?


    Has anything changed in kodi 17.4 compared to kodi 17.3 ??


    The image in version 8.1.2 is very good !!! But the stability of DVB-c in version 8.1.6 is better.


    Does anyone confirm?