Librespot addon

  • Nothing to do with Kodi.

    Please explain what you are doing (from what device are you streaming? Are you streaming a playlist? Do you experience this with a single track? What track? etc)

    I am simply streaming to kodi from my macbook running spotify and using spotify connect for it. I am mostly using playlists. There is no single track or anything that reproduces this.

    This issue occurs seamingly randomly, sometimes after 1-2 tracks, sometimes after a whole day of playing.

  • I am simply streaming to kodi from my macbook running spotify and using spotify connect for it. I am mostly using playlists. There is no single track or anything that reproduces this.

    This issue occurs seamingly randomly, sometimes after 1-2 tracks, sometimes after a whole day of playing.

    Librespot is bad at handling network errors. It is being worked on.

    @

  • Hi Awiouy, I'm using Libreelec 7 because Kodi 17+ is too slow on my Pi 2. How could I get this addon, since it's not in the repository?

    Thanks.

  • Hi Awiouy, I'm using Libreelec 7 because Kodi 17+ is too slow on my Pi 2. How could I get this addon, since it's not in the repository?

    Thanks.

    Backport and build it.

    @

  • Hey,

    after I reinstalled the Raspberry Pi 3 and installed Librespot, I am not able to select the device. I got an other Spotify Connect Add On already, but its not that good like the Librespot.


    Example


    I hope that you can help me with that problem.


    edit: on mobile it says "connecting" and than it diappears.


    Best regards

    Edited once, last by Crysix ().

  • This should fix for LE 9.0 on RPi2

    I have submitted the fix at github.

    I have tested 109b (from your link) as well as version 110 from libreelec-repo on my fresh installed LE9 Milhouse build (from april 1st and april 2nd). Each combination doesn't work for me: my spotify-app doesn't see the device. The dependencies-section says: os.libreelec.tv is unavailable.


    I have activated logging and then uninstalled and reinstalled the plugin. Hopefully the log is useful. (In the log, os.libreelec.tv is shown as loaded.)

    Files

    • kodi.log

      (119.93 kB, downloaded 78 times, last: )
  • Please provide a log produced with "journalctl -u service.librespot"

    @

  • I have tested 109b (from your link) as well as version 110 from libreelec-repo on my fresh installed LE9 Milhouse build (from april 1st and april 2nd). Each combination doesn't work for me: my spotify-app doesn't see the device. The dependencies-section says: os.libreelec.tv is unavailable.


    I have activated logging and then uninstalled and reinstalled the plugin. Hopefully the log is useful. (In the log, os.libreelec.tv is shown as loaded.)

    Please provide a log produced with "journalctl -u service.librespot"

    @

  • Please provide a log produced with "journalctl -u service.librespot"

    Here you go (see attached log), The relevant lines:


    Code
    1. Apr 04 17:40:04 LibreELEC systemd[1]: Started librespot.
    2. Apr 04 17:40:04 LibreELEC sh[16619]: INFO:librespot: librespot 0a89bee (2018-03-11). Built on 2018-03-11. Build ID: iQNpx8nK
    3. Apr 04 17:40:04 LibreELEC sh[16619]: *** WARNING *** The program 'librespot' uses the Apple Bonjour compatibility layer of Avahi.
    4. Apr 04 17:40:04 LibreELEC sh[16619]: *** WARNING *** Please fix your application to use the native API of Avahi!
    5. Apr 04 17:40:04 LibreELEC librespot[16635]: *** WARNING *** The program 'librespot' uses the Apple Bonjour compatibility layer of Avahi.
    6. Apr 04 17:40:04 LibreELEC sh[16619]: *** WARNING *** For more information see <http://0pointer.de/blog/projects/avahi-compat.html>

    The libreelec configuration tells me that avahi is active. Nevertheless, I ended the service and restarted it, just to be on the save side. Next I rebooted my RPi just to be on the save side (adding the output via journalctl -u service.librespot >> /storage/journalctl.txt). That's why there are three logs. Please don't ask me why the last one states "Logs begin at Sun 2018-01-28 16:58:17 CET", it ends at the right time :)

    Files

    • journalctl.txt

      (5.82 kB, downloaded 51 times, last: )
  • I'm having difficulty getting my ALSA setting to work - can't get the correct device input because I'm overlooking something obvious. I can stream through Kodi, but I don't like the delay and would prefer ALSA as I'm running it headless as a music player only. I am connected to my DAC via optical cable from an Intel NUC. I can stream via DLNA from my JRiver to the bolded device below, but want the tool for that dreaded Spotify app.


    Thanks for the help!


    Here is the output from aplay -l (the bolded line is what I want)


    **** List of PLAYBACK Hardware Devices ****

    card 0: PCH [HDA Intel PCH], device 0: ALC283 Analog [ALC283 Analog]

    Subdevices: 1/1

    Subdevice #0: subdevice #0

    card 0: PCH [HDA Intel PCH], device 1: ALC283 Digital [ALC283 Digital]

    Subdevices: 0/1

    Subdevice #0: subdevice #0

    card 0: PCH [HDA Intel PCH], device 3: HDMI 0 [HDMI 0]

    Subdevices: 1/1

    Subdevice #0: subdevice #0

    card 0: PCH [HDA Intel PCH], device 7: HDMI 1 [HDMI 1]

    Subdevices: 1/1

    Subdevice #0: subdevice #0

    card 0: PCH [HDA Intel PCH], device 8: HDMI 2 [HDMI 2]

    Subdevices: 1/1

    Subdevice #0: subdevice #0

    card 0: PCH [HDA Intel PCH], device 9: HDMI 3 [HDMI 3]

    Subdevices: 1/1

    Subdevice #0: subdevice #0

    card 0: PCH [HDA Intel PCH], device 10: HDMI 4 [HDMI 4]

    Subdevices: 1/1

    Subdevice #0: subdevice #0


    Music-Player:~/.kodi/addons/service.librespot #

  • Hi,


    the addon should work with Rpi2+HiFiBerry DAC+, running latest official LE version for RPi2?

    I can't test it atm, that is why I'm asking.


    Is the addon maintained by anybody or the project on GitHub is abandoned now? Don't really see any activity there.


    Thanks!

  • I use HifiBerry DAC+ with Librespot without issue. You will have to edit `/flash/config.txt` accordingly.


    I paused development at librespot and LibreELEC for personal reasons, but expect to resume soonish. There is no current emergency though, since the Librespot addon is working as expected.


    When I resume, I intend to merge librespot to the Snapserver addon (and drop the standalone Librespot addon) to provide a single more general solution. This also allows to use latest versions of librespot, which is rendered complicated by current Kodi hooks/patches.


    I expect this rework to be quite comprehensive, ie build Rust from a package, build latest librespot with vendored dependencies, drop Librespot standalone addon, build latest Snapcast, add pulseaudio alsa plugins to snapclient, (try to) further simplify Kodi with Snapcast, Snapcast control from Kodi user interface, etc.

    @

  • Many thanks for your detailed answer. Great news, and thanks for all your hard work.

    By editing the config.txt you mean the usual enable HifiBerry setting and not something related to Librespot, correct?


    So nice plans, I hope your personal reasons will sort out.

  • awiouy there is an issue whith librespot and tvheadend client.

    If librespot is installed zapping with live tv is broken.

    If switching channels it zappen into blackscreen and THE system freezes and pull out The power plug.

    This issue is on odroid c2 on LE9 and CE9.

    On my S912 the same issue running CE9.


    If remove the librespot addon zapping live tv is working fine.


    Is this a known issue?


    If needed i can provide some logs

  • It is the first time I hear this.

    Please provide LE and addon version, and settings.xml (remove user/password) if any

    @

  • Yesterday I installed Librespot, and it worked perfectly with my Android phone.

    Today I registered a new account on the phone, and Librespot is no longer available on my phone. I don't have username and password set in Librespot.

    Any ideas?


    Edit: OK, I have renamed credentials.json to backup, restarted the service and everything works now perfectly.

  • I use it on Odroid C2 with TVH client and Librespot. Everything works perfectly. My version of LE us wrxtasy's latest build.