Intel Compute Stick BOXSTCK1A8LFCL

  • I have successfully built LibreELEC 8.0.1 for the Intel Compute Stick BOXSTCK1A8LFCL.

    The BOXSTCK1A8LFCL has the following hardware:

    • Intel Atom Processor - Z3735F
    • 1 GB DDR3L SDRAM
    • Intel High Definition Graphics - HDMI 1.4a
    • Intel High Definition Audio
    • AzureWave AW-NB177NF

      • 802.11b/g/n
      • Bluetooth 4.0

    • USB 2.0
    • 8 GB eMMC

    Currently working:

    • Video
    • Audio
    • WiFi
    • Bluetooth
    • USB

    What does not work:

    • Nothing?

    The source is located here:
    GitHub - sorhtyre/ at

    A compiled image is located here:

    UPDATE - 29 May 2017

    * Generic - - Based on LibreELEC 8.0.2 using Generic build options to maintain compatibility with addons.

    Edited 4 times, last by erythros ().

  • Hey, I'm trying to run this version off of a USB key and a hipstreet pc2go. It has the same processor but 2 gb of ram.

    Hipstreet PC2GO Specs - CNET

    Any ideas on what i can do to get it to boot? literally nothing happens and it shoots me back to the bios when i try to boot from the bios menu. If I just run it straight it boots the default windows partition.

  • Ryan,

    I just looked over the hardware for the Hipstreet PC2GO, looks like it's a rebranded BOXSTCK1A32WFC.

    I need a little more information about what you are doing. Based on your description, it sounds like you're trying to boot from a usb drive. Is that correct?

    Walk me through the process you are using to install your image.

  • Yes, I'm trying to boot through a usb drive.

    I downloaded your image and used rufus to write the image to my usb key as bootable.

  • Did Rufus create an EFI boot partition?

    Did you also make sure your BIOS is setup to enable booting from USB?

    I have never used rufus before. There could be an issue with how it writes the partition or sets the boot flags. I can run a few tests tonight and see if I can discover your issue.

    Is there any particular reason why you aren't installing LibreELEC to the internal memory?

  • I didn't want to have to fully overwrite the current windows install before seeing how stability and general running kodi was with libreELEC

  • I didn't want to have to fully overwrite the current windows install before seeing how stability and general running kodi was with libreELEC

    Just bought the same device this week (HipStreetPC2GO). From what I've read, our problem is related to booting from 32bit UEFI (even though CPU is 64bit). Have to replace boot files with 32bit files. Here is a link (I've got it running). Read through thread and follow instruction. Note that to copy files across you need to mount the EMMC partition in live mode after install. Mine was /dev/mmcblk1p1 (you'll notice the partition as the installer formats before installing). I just mounted it to /media (which was empty in live) and copied needed files over from /flash/EFI/BOOT). Delete files in /dev/mmcblk1p1/EFI/BOOT before copying over (they'll be 64bit files)

    32bit efi / uefi support for LE

    Important info is in post #14 and #17. (take care to change grub.cfg to LABEL=LIBREELEC under install and live)

    Edited 2 times, last by chabro ().

  • Question to OP: Did you include wifi/bluetooth drivers before you compiled? From other threads I read, it seems like default support for Intel Compute Stick wifi/bluetooth, will be in linux kernel 4.12. Until now people have been using custom kernels ( Wifi worked with your img. Had a few issues after install (had to reboot twice before my network was seen). Will test over the next week whether I have more issues (like after waking from sleep etc).

    Thanks for sharing your work!

  • Tested Generic- - Update 29.05.2017 on my box Wintel CX-W8 - (CPU Z3735F, 2GB DDR3. 32GB EMMC, WiFi Realtek 8723, Windows + Android)

    Wifi, LAN, Audio - works

    With Stalker Client and SD channels I need to change Deinterlace method for smooth.

    On HD channels - unsatisfactory results.

    But with Android and Windows - the same results.

    May be the Intel HD Graphics on Atom is no good.

  • I have an Orbsmart MW-02, where I installed LibreElec from here on an USB stick and updated it with this version (via normal update, copy .gz to update folder and restart).

    It seems that it works pretty good, even that I have not tested that much yet (WLAN is pretty bad where I tried it, I will try again with better WLAN or USB/LAN adapter).

    But I had a big problem, as I cannot install the NextPVR client, it keeps telling me, that it uses the wrong API version?!

    I have another little Intel PC with normal LibreElec 8.0.2 that doesn't have this problem.

    Any way to get this working?

  • Sorry, maybe has been already answered somewhere, but how can install it on the compute stick? Thank you in advance

    EDIT: Nevermind, I did it, just had to select 64 bit bootloader

    Edited once, last by jeky82 ().

  • Hi - Great build and worked on the first try for me on a BOXSTCK1A8LFCL.

    Any chance you can re-compile for the 8.2, or offer up some instruction on how you did it?

  • I just signed up to say thank you for this build. I really appreciate the time you put in AND that you shared it with the rest of us.

    I downloaded the current version of "normal" LibreElec and both sound and WiFi didn't work so I was considering moving on to something else. I then Googled my ComputeStick model & LibreElec and ended up here. I installed and it's working great.

    For anyone else who installs this in 2018, after installation you need to go into the Add-Ons System Menu and update them. Otherwise the Movie scraper doesn't work and you also can't install other add-ons or skins. If you don't it doesn't error, it just doesn't work.

    The Kodi menus indicate I don't have a Bluetooth device installed. I don't know if this is a bug or I need to do anything. I don't use it anyway so it doesn't matter to me :)

    I know my way around Linux reasonably well, so if I get the motivation to spend some time on it I might try and create a custom release of the latest LibreElec version with these drivers compiled in. If you're still around, could you let me know if there were any gotchas, and whether you have a record of where you got the correct drivers from??

    Once again, thank you for your time.

  • I've been having intermittent crashes, and through reading, have found I need to disable C-States on this CPU to resolve them.

    I couldn't find any concise instructions so have written my own and attached them here so they can be used to help others.

    Enjoy :)

    Disable C-States - LibreELEC x86.pdf

  • Installed on intel 8GB stick and here is /dev/mmcblk1p2 6.5G 287.1M 6.2G 4% /storage, result. Way better than original OS pre-installed on the stick. What a waste of space, LOL.

    HDhomerun is a fail. Maybe if I transcode it through vlc and create m3u. Other than that intel chip is not powerful enough on the fly. Plex works great with my NAS files and so does streaming using mythtv recordings through PVR addon.

    I also power it through my tv's usb port so it's complete incognito and noticed no difference in performance.

    Just my thoughts on this neat little plug-in