Wake from suspend (CEC)

  • Hi guys after a bit of help, my HTPC (specs below) was running 7.0.3 and CEC was working fine, switched off when TV was and woke up when TV was turned back on, however when I updated to 8.0.0 it stopped waking from suspend (it still goes to suspend when the TV is turned off) and I have no idea why. I've updated to 8.0.1 and the problem remains.


    I've seen posts saying there are issues with Pi's but does it extend to any other hardware or is there a Linux setting I need to change?


    Thanks.


    Samsung UE55F6670
    Pulse8 CEC
    Intel Pentium G620
    Biostar H61MLC
    GT 710

    Edited once, last by Marino ().

  • I think its something to do with the cec adaptor...the last that worked for me was libCEC 3.0.1 firmware version 1...after that it never worked properly again...you might be on libcec 4 with krypton..


    Sent from my SM-T280 using Tapatalk

  • I had a thought and checked the pulse eight website, looks like there's a firmware update. Might try that tomorrow and see how I get on.



    Sent from my iPhone using Tapatalk

  • So I updated the Pulse Eight to the latest firmware on the website and it hasn't resolved the issue, any ideas?

  • No luck at all, I think next on my list will be a format/re-install unless anyone has another idea?



    Sent from my iPhone using Tapatalk


  • No luck at all, I think next on my list will be a format/re-install unless anyone has another idea?



    Sent from my iPhone using Tapatalk


    I too have this issue with NUC that is attached to my Onkyo receiver and TV. Prior to the 8.0 series I could wake my NUC from suspend and have it power on both my receiver and tv and, conversely, suspend the NUC and have everything else power down. Now when I suspend the NUC it doesn't shut anything else off and when I wake it from suspend nothing turns on and when I turn the receiver and tv on manually I find the NUC frozen with the Kodi loading circle on the screen.


    My NUC that I have connected to a tv by itself without CEC capabilities suspends perfectly and even wakes the screen perfectly. I'd love to know if a reinstall fixes your issues because this is an annoying issue with an otherwise great release.

  • I m not using a nuc..I m using a rpi2..but have issues similar to yours..rpi's dont have suspend option by default...as there is no support to wake it up...they just go on a kind of standby dimmed screen saver..and that s where cec is failing..on 7.0.3 it used to wake up when I Change hdmi input to kodi or just after kodi entering stanby and pressing a key on my philips tv remote...quick fix was to wake up kodi with a network remote such as Music Pump,Yatse or Kore trough android tablet...but had enough of this and went back to 7.0.3..which is working flawless..On a positive note cec 4.0.1 in LE 8 I managed to use the repeat keypress for the first time as it never worked before on official release..only on millhouse...I mean when you keep a button on the remote pressed and kodi keep getting cec signals...


    Sent from my SM-T280 using Tapatalk
    [hr]


    No luck at all, I think next on my list will be a format/re-install unless anyone has another idea?



    Sent from my iPhone using Tapatalk


    Dont think a format will change anything unfortunately...wish there is a way I can try LE 8.0.1 with Cec 3.0


    Sent from my SM-T280 using Tapatalk

    Edited once, last by Mario77 ().


  • Hi guys after a bit of help, my HTPC (specs below) was running 7.0.3 and CEC was working fine, switched off when TV was and woke up when TV was turned back on,


    not sure if it's the same, but our master bedroom TV tends to wake us up each night around 3 o'clock with a 66% chance.


    But I am using not a PC but a Raspberry Pi3


    Same in the living room with an Raspberry Pi2 and a 20 % chance.
    Both are Samsung TVs with Anynet/CEC


    Both TVs didn't show this behaviour before Kodi 17


  • I'm using a Raspberry Pi 3, and have the same annoying issue :(
    If LibreElec goes in a dimmed state (after 5 minutes of inactivity I guess), I have to wake it up with the Kodi network remote in order to use the TV remote again!

  • Quote


    If LibreElec goes in a dimmed state (after 5 minutes of inactivity I guess), I have to wake it up with the Kodi network remote in order to use the TV remote again!


    Hi,


    can confirm that this is libcec related problem. I see exact same behauviour on Rpi2 + Panasonic TV and LE 7.0.3 with libcec 4.0.1.


    But anyway, the misbehaviour with AVR on the way between Rpi2 - TV makes me stop using CEC on this setup. Now I using Lirc, IR remote + IR sensor on Rpi2 GPIO and couldnt be happier :) Finally everything works in every condition, every HDMI, doesnt matter if TV is powered off from TV source active, or Kodi source active. Doesnt matter on switching TV's HDMI input. Doesnt matter on screensaver or not. Highly recommended for those, whose fighting with more CEC devices on one bus and not-so-working libCEC menu in LE.


    On simple setup Rpi2->TV libcec 3.0.1 works just fine.

    6x Odroid C2 + CoreELEC 9.0.1; 6x RPi2 + LibreELEC 9.0.1; 3x Win7 Kodi 18.1 + vPeter's mariaDB plugin as Library DB

    Edited once, last by JimmySmith ().


  • Libreelec 7.0.3 doesnt use libcec 4.0.1 but 3.0.1.....Libcec 4.0.1 is the updated cec in LE 8.0.0 and above which is having the issue of CEC not able to wake up Kodi..or it's not able to disable screensaver when you wake up the tv or change hdmi input to kodi...
    Well the important part is that a solution has been found and should be fixed in Libcec 4.0.3...Kodi Wake up from tv doesn't work #309


  • Libreelec 7.0.3 doesnt use libcec 4.0.1 but 3.0.1....


    I compiled 7.0.3 with libcec 4.0.1 by myself.


    Agree with your point, and thanks for dig and pinpoint that ;)

    6x Odroid C2 + CoreELEC 9.0.1; 6x RPi2 + LibreELEC 9.0.1; 3x Win7 Kodi 18.1 + vPeter's mariaDB plugin as Library DB

    Edited once, last by JimmySmith ().

  • I have some issue with CEC, it stopped responding after switching tv off and back on.


    Rpi-2 and 8.0.1 LG TV.


    Bringing up 'simplink' aka CEC, display when this issue arose it comes up as 'unidentified device - kodi'. Nornmally just shows KODI.


    Switch tv input and back, gets it working. Or even open simplink on remote clicking device brings back to life also.

  • Are you able to compile 8.0.1 with cec 4.0.3....don't know where to start from as never tryed...code is on github already fixed by opdenkamp Pulse-Eight/libcec


    Its not 4.0.3, at least officially. I can do it only for Rpi2 platform, other would take me loooong time, and I dont have so big disk to store all cache for more platforms.
    Here is Rpi2, for those who want to test it: LibreELEC-RPi2.arm-8.0.1_fixed_cec_commit_3953f8d.tar (138.43MB)

    6x Odroid C2 + CoreELEC 9.0.1; 6x RPi2 + LibreELEC 9.0.1; 3x Win7 Kodi 18.1 + vPeter's mariaDB plugin as Library DB