Ability to disable Ethernet LEDs

  • Hi!


    I am able to disable the Power and SD Card LED on my Raspberry Pi 2/3 running LibreELEC with

    Code
    1. echo 0 > /sys/class/leds/led0/brightness
    2. echo 0 > /sys/class/leds/led1/brightness
    3. echo none > /sys/class/leds/led0/trigger
    4. echo none > /sys/class/leds/led1/trigger


    in autostart.sh.


    What I am not able to do is disabling the LAN / Ethernet LEDs.


    It would be great to disable all LEDs natively from with LibreELEC.


    Thanks.

    Edited once, last by janw ().

  • It is possible but requires adding a patch to smsc95xx.c and compiling the kernel. (Not tested on LE)
    Personally I'd use a bit of black insulating tape :-)

  • This drives me nuts as well as my RPi2 is in my bedroom and the LEDs flashing at night can be an annoyance. I have the patch that Iridium mentioned and tested on the system that the patch was made for. I'm currently syncing/building LibreElec though. As long as the patch works here as well, I will submit it to the team as a Pull Request... so hopefully you'll have the ability in the official builds soon ;)

  • If whatever change you're thinking up is worthwhile it should be submitted to the linux kernel. Then we'll pick up the change in a future kernel release. Patches and hacks are out of fashion around here :)

  • Are we sure it needs all that work - I have an electric blanket with a bright blue LED that is annoying. A bit of tape solves the problem. Sometimes a simple solution is far better that a more complex one.

  • If whatever change you're thinking up is worthwhile it should be submitted to the linux kernel. Then we'll pick up the change in a future kernel release. Patches and hacks are out of fashion around here :)

    I don't know. It's a pretty usecase specific patch, since it would only be something that someone using an RPi2 (3 maybe as well) as an HTPC would really be interested in. I doubt it would be of any interest to linux mainline. Though, at the same time it doesn't look like it hurts anything either.

  • The PR should be sent here: GitHub - raspberrypi/linux: Kernel source tree for Raspberry Pi Foundation-provided kernel builds. Issues unrelated to the linux kernel should be posted on the community forum at https://www.raspberrypi.org/forum then it benefits all RPi users, not just LE, and becomes something we pick up in the RPi backports patch we rebase as part of minor kernel bumps. The folks who maintain that repo will also evaluate and judge whether it's something that should go further upstream to the mainline kernel.

  • The PR should be sent here: GitHub - raspberrypi/linux: Kernel source tree for Raspberry Pi Foundation-provided kernel builds. Issues unrelated to the linux kernel should be posted on the community forum at https://www.raspberrypi.org/forum then it benefits all RPi users, not just LE, and becomes something we pick up in the RPi backports patch we rebase as part of minor kernel bumps. The folks who maintain that repo will also evaluate and judge whether it's something that should go further upstream to the mainline kernel.

    Fair enough, I'll send it there instead.

    It wasn't mine originally, and don't actually know the emails and such that would maintain proper authorship for it either. Though, I think it can be cleaned up a little anyway.


    Thanks for the proper link.


  • Thanks, this works great for me. I may re-host the binary on my own drive or network just to ensure it's always available, but using the link you provided works in autostart to make the box lightless as:



    Thanks again, and ignore my PR since this already able to be done from userspace.

  • What I see from GitHub is that this has been merged in the master branch.

    Can someone tell me how to use this?

    Is it just adding the line:

    Code
    1. ./llctl f0 l0 d0

    To autostart.sh?

  • This is no longer working on the Raspberry Pi 3 Model B+


    Controlling LAN LEDs individually - Page 2 - Raspberry Pi Forums

  • This still doesn't seem to work? I'm using an Raspberry Pi 3B and a 3B+


    I'm using the following lines in my config.txt


    # Disable Ethernet LEDs
    dtparam=eth_led0=14
    dtparam=eth_led1=14


    # Disable the PWR LED
    dtparam=pwr_led_trigger=none
    dtparam=pwr_led_activelow=off


    # Disable the Activity LED
    dtparam=act_led_trigger=none
    dtparam=act_led_activelow=off