Posts by SkywalkerPD

    This still doesn't seem to work? I'm using an Raspberry Pi 3B and a 3B+


    I'm using the following lines in my config.txt


    # Disable Ethernet LEDs
    dtparam=eth_led0=14
    dtparam=eth_led1=14


    # Disable the PWR LED
    dtparam=pwr_led_trigger=none
    dtparam=pwr_led_activelow=off


    # Disable the Activity LED
    dtparam=act_led_trigger=none
    dtparam=act_led_activelow=off


    Hi Guys,


    Thnx for responding!


    I know the IP address is 100% correct. I can ping the device.


    PING 192.168.2.153 (192.168.2.153): 56 data bytes

    64 bytes from 192.168.2.153: icmp_seq=0 ttl=64 time=5.562 ms

    64 bytes from 192.168.2.153: icmp_seq=1 ttl=64 time=2.374 ms


    Samba is enabled. I can connect to the device. SSH is not working as is sFTP off course....


    ssh: connect to host 192.168.2.153 port 22: Connection refused.


    Now trying an update to the latest Millhouse build.

    Running the latest Milhouse build (9.0) on a Raspberry Pi 3. After the last update ssh is not working anymore.


    ssh -vvv [email protected]@192.168.2.153

    OpenSSH_7.6p1, LibreSSL 2.6.2

    debug1: Reading configuration data /etc/ssh/ssh_config

    debug1: /etc/ssh/ssh_config line 48: Applying options for *

    debug2: ssh_connect_direct: needpriv 0

    debug1: Connecting to 192.168.2.153 port 22.

    ssh: connect to host 192.168.2.153 port 22: Connection refused


    FTP isn't working either. Now I read the solutions above, but this is not working for me? I've tried installing system tools to open a terminal windows on the Pi, but nothing happens.


    How can I correct this without doing a fresh install?

    First of all, I agree with that. The wifi in my house has an optimal coverage (for my situation) Before I was using a 5G dongle, the wifi in the new Pi 3 B+ has both modes, and now it switches a lot.

    I can go back to using an external dongle, but that is based on the rtl8812au chipset and LibreELEC is still not fully supporting this. So I have to do a lot of manual stuff to get that working stable.

    I bought the new Pi because it has native 5G, but unfortunately it is not really working for me at the moment, so I'm searching for a workaround.

    If you only associate with the 5GHz SSID then the Pi3+ won't connect on 2.4GHz. I'm not sure how (or if it's possible) to disable only the 2.4GHz radio.


    Power management is disabled by default - it's not a battery powered device.

    Code
    1. [ 291.767088] brcmfmac: power management disabled

    Thnx for the reply Milhouse! I have a mesh network in my home and this uses only one SSID. So it switches between 2.4G and 5G when it finds it necessary.... It would be nice, to block this for my LibreELEC media player.


    Is it possible to use something like this?


    Selection of WIFI band

    Hi,


    Is it possible to tell the onboard wifi module in the Pi 3 B+ to only connect on 5G? (disable 2.4G radio?)


    And for my 8812au 5G wifi dongle I had to disable power management, does this work for the new wifi chip as well?


    8812au rtw_power_mgnt=0

    Not sure if there is any interest after trying several different repositories for RTL8812AU several months ago, but...


    I found GitHub - fariouche/rtl8812AU: Realtek 8812AU USB WiFi driver and I've successfully built and installed it for my 8821 based USB wifi device. I think the biggest issue with 5.2.9 before was that it only worked for 8812 and that caused a lot of LE/Milhouse users to have broken wifi.


    I've been using the 5.2.9 driver for about a week now and haven't had any issues. This driver doesn't seem to support 8814, though I don't know if there are a lot of users with those devices.

    Would like to test this with my Edimax EW-7811UTC that uses a rtl8812au chip. But don't have the experience to make my own build. I would like to test this with LibreELEC 8.2.2?

    Are these changes reset with an update of LibreELEC?

    As an extra I disabled the internal Wifi and Bluetooth of my Pi3 by adding the following to /flash/config.txt


    Code
    1. mount -o remount,rw /flash
    2. nano /flash/config.txt

    Make your changes, then ctrl+x to save. In this case:


    dtoverlay=pi3-disable-wifi

    dtoverlay=pi3-disable-bt

    Code
    1. mount -o remount,ro /flash

    Reboot.

    It may do, power management usually causes problems and makes no real sense on mains powered devices. However the RTL8812AU module is being built with power saving disabled, unless that's no longer supported.


    LibreELEC.tv/package.mk at master · LibreELEC/LibreELEC.tv · GitHub

    I used the these commands:


    echo "options 8812au rtw_power_mgnt=0 rtw_enusbss=0 rtw_ips_mode=1 rtw_vht_enable=0 rtw_ht_enable=1" > /storage/.config/modprobe.d/8812au.conf


    cat /etc/modprobe.d/8812au.conf options 8812au rtw_power_mgnt=0 rtw_enusbss=0 rtw_ips_mode=1 rtw_vht_enable=0 rtw_ht_enable=1


    It is very stable now.... but on 2.4Ghz.... I didn't find a way to use the full ac potential..... (accept maybe upgrading to LE9)


    The things I changed, can someone tell me how to get these back to default?