[8.2.2.3] LibreELEC 8.2 for S912

  • kszaq : I found little bug in build S912. Changes in libhybris lead to kodi compilation error

    Code
    1. In file included from ../xbmc/windowing/amlogic/WinSystemAmlogic.cpp:21:0:
    2. ../xbmc/windowing/amlogic/WinSystemAmlogic.h:54:3: error: 'fbdev_window' does not name a type
    3. fbdev_window *m_nativeWindow;
    4. ^~~~~~~~~~~~

    fbdev_window is defined in opengl-meson-t82x. Cleaning this package fix this error.

    We have to force always build opengl-meson-t82x before building kodi.

  • This works only when opengl is changed. But it is necessary build it always when kodi is built. This condition is only for S912 as there is libhybris.

    This is not what I experienced. 2 situations I encountered:

    1. When you change libhybris and kodi, you also have to rebuild opengl-meson.
    2. If you change only libhybris or kodi, you don't have to rebuild.

    Small inconvenience but not that hard if you remember. I don't think I want to dig into this issue.

  • This is not what I experienced. 2 situations I encountered:

    1. When you change libhybris and kodi, you also have to rebuild opengl-meson.
    2. If you change only libhybris or kodi, you don't have to rebuild.

    Small inconvenience but not that hard if you remember. I don't think I want to dig into this issue.

    In following log you can see missing eglplatform.h in toolchain after rebuilding libhybris.

  • Are you saying that bitstream out is now perfect with the U9-H?


    I was having problems where it would sometimes work and sometimes just digital noise.

    PCM works fine though but once I upgrade to a Atmos or DTS-X processor i will need the bitstream out to work correctly.


    That is the only problem with the U9-H. Every 4K or 1080P file that I've tried has played perfectly including HDR files.

  • Hello!Could someone tell me which is the most stable librelec version for my H96 pro plus and which .dtb should i use? I'm tired of my box because if using regulary it gives me pop up messages all the time like: kodi has stopped,google play has stopped,gmail has stopped...Jesus,everything is stopping...Its killing me....Thanks!

  • Hello!Could someone tell me which is the most stable librelec version for my H96 pro plus and which .dtb should i use? I'm tired of my box because if using regulary it gives me pop up messages all the time like: kodi has stopped,google play has stopped,gmail has stopped...Jesus,everything is stopping...Its killing me....Thanks!


    I got it running on my H96 Pro Plus. Works pretty well. Just DTS and DTS HD Master give PCM sound output to my receiver with audio settings on passtrough. Dolby gives Dolby output. Is there a way to get proper DTS? I might be overseeing something. Andoid Kodi gives DTS and Dolby output


  • I got it running on my H96 Pro Plus. Works pretty well. Just DTS and DTS HD Master give PCM sound output to my receiver with audio settings on passtrough. Dolby gives Dolby output. Is there a way to get proper DTS? I might be overseeing something. Andoid Kodi gives DTS and Dolby output

    activate advanced menu and select the audio formats

  • activate advanced menu and select the audio formats


    I got it running on my H96 Pro Plus. Works pretty well. Just DTS and DTS HD Master give PCM sound output to my receiver with audio settings on passtrough. Dolby gives Dolby output. Is there a way to get proper DTS? I might be overseeing something. Andoid Kodi gives DTS and Dolby output

    ... and after that, shutdown the box, pull ac plug out, then in and after booting dts, dts-hd, Dolby true-hd, should be working. A reboot doesn't work for me, only a complete shutdown and rebooting... but after that I had all formats in sound.

    Based in GERMANY — working in cigar business — part time freelance webdesigner — PS4 Console Gamer and TV Show Junkie :cool:


    S912 with CE on NAND — S905x with CE on SD-Card (with EmulationStation&KODI shanti‘s build) - Odroid N2 with CE on emmc and EmuELEC on SD-Cad — 4K 65“ Sony — 4K Onkyo DD/DTSHD/ATMOS Receiver



  • Hi, I have a problem with H96 Pro Plus (S912/3GB/32GB) and 8.2.1.1 version of this build, device tree is gxm_q200_3g.dtb.


    After a day or two, the device simply freezes and only solution is pulling the power adapter from the device. I have two external disks connected, so it really sucks to do "hard shutdown", because I cannot unmount them properly.


    I have tried to look inside Kodi log and journalctl, but there is nothing which could help me to see what was the cause of problem.

    At first, I thought it was Sabnzbd since I was downloading 50+ GB files, but in last few days I didn't download anything and problem is still here.


    What should I do? Downgrade to lower version of this build?

    Any help is appreciated :)

  • With two external harddrives I sure hope they have their own power supply, or a powered hub between them and your box. You're asking for trouble if not.

    MECOOL KIII Pro (S912)

    Raspberry Pi 2 Model B, overclock mode: 'Pi2' (1000/500/500/2), gpu_mem_1024: '320'