VPN Manager for OpenVPN

  • Thanks for the info. I definitely don’t want to spend time debugging problems with nightly builds. Reporting issues to Milhouse is definitely the right thing to do. Happy to look at issues with any regular builds

    Issue confirmed as starting in #0528, #0524 & #0528 kodi.logs provided within Kodi forum HERE

    rPi3B+, SanDisk Ultra 8Gb SD, Milhouse kernel_5.x LE Testbuild (Kodi 19 Matrix) -> Onkyo TX-SR608 AV Receiver -> Philips 42" LCD TV

    KVIM2 Pro, SanDisk Ultra 8Gb SD, kernel_5.x LE Testbuild (Kodi 19 Matrix) -> LG 27UD69-W 4K Monitor -> AudioEngine A2+ Speakers

  • I pushed out 6.2.0 which adds some minor stuff to display the VPN server name in use (if you care about that sort of thing) and fix to a weird connection bug. Only it also introduced a bug where it'd crash if you connect before boot.

    Fix for that is in 6.2.1, should update automatically via the repo, but if not just reinstall it.

  • Hi,

    Thank you for developing such a great addon! But I am running to a problem.

    I am running kodi 18.2 on libreelec 9.02 on raspberry pi3. Connection is wired via ISP Ziggo Netherlands (50/5) and Private Internet Access. Using latest version of VPN Manager from repository.

    When VPN Manager is disconnected I get 47.7/4.3.

    But when I use VPN Manager I get inly 43.7/0.77(!)

    Tests are done with Arnubox Speedtester.

    Speedtest with PIA VPN client on android phone is 23,9/4,9.

    Local speed between 2 raspberries is about 80/80.


    I tried everything, can't find why the upload speed decreases so much and is no longer usable.


    Do you have an idea what can be wrong? What logfiles can I post or sent for you to see what the problem causes?


    Thanks in advance!

    Frank

    Edited once, last by frank1970 ().

  • I’ve not changed PIA for ages, and the fact it works ok on 17 makes me think it’s not related

    to the PIA ovpn files changing.


    You could download a current PIA ovpn file and start it manually via the command line.

    If this has the same issue then it’s not the addon. If it doesn’t I’ll look at the ovpn files when I’m in front of a computer but that won’t be for a few days.

  • Hello,


    First of all, thank you Zomboided for this incredible addon. Works in combination with AirVPN as a charm. My question is: is there any kind of vpn kill switch implemented in this addon and if so, how reliable is this?


    Thank you in advance...


    peanut

  • No, I never worked out how to do it universally. You can stop the stream if the VPN disconnects but this isn’t immediate.

    Or you can add something to the ovpn files to mess with the ip table. I don’t know what that something would be tho

  • I’ve not changed PIA for ages, and the fact it works ok on 17 makes me think it’s not related to the PIA ovpn files changing.


    You could download a current PIA ovpn file and start it manually via the command line.


    If this has the same issue then it’s not the addon. If it doesn’t I’ll look at the ovpn files when I’m in front of a computer but that won’t be for a few days.


    Edited 2 times, last by frank1970: Speedtest from commandline without openvpn is OK. I used: wget -O - https://raw.githubusercontent.com/sivel/speedtest-cli/master/speedtest.py | python Openvpn can be started OK from commandline, got new external ipaddress. But after that speedtest can't connect at all! I can ping Internet websites though. If you have any ideas I feel welcome. ().

  • I’ve not changed PIA for ages, and the fact it works ok on 17 makes me think it’s not related

    to the PIA ovpn files changing.


    You could download a current PIA ovpn file and start it manually via the command line.

    If this has the same issue then it’s not the addon. If it doesn’t I’ll look at the ovpn files when I’m in front of a computer but that won’t be for a few days.

    On raspbian openvpn also works fine.

    Commandline in libreelec 9.02 gives me also problems with PIA. So it must be Libreelec 9.02 or I am going crazy ;,)

  • Hi Zom,

    I am not going crazy! But angry!

    Tried the VPN via my phone as wifi access point and no problem at all!


    I called ISP Ziggo, after a long investigation they told me that the 2 raspberry pi's are blacklisted! No reason why and no way to get off the blacklist. :(((((

    Must be a MAC address block in the router.

    Greetings,

    Frank

    Edited once, last by frank1970 ().

  • That's really poor. How come it worked for Raspbian though, or was that on a different Pi?

  • In Libreelec IP6 is turned off by default. After turning it on, everything works fine with VPN and dutch ISP Ziggo.

    Don't know why, but it works.

  • Hello, I have installed that plugin and configured with my mullvad account.

    How to be sure that the VPN is used when playing IPTV through the addon IPTV Simple Client?

    Thanks

  • Hi there,


    Firstly thanks for creating the VPN Manager add on, it made getting signed into my Nord VPN account nice and simple.


    I'm new to the Kodi/Raspberry Pi world so am struggling a bit to get my head around some of the issues I'm coming up against. Tonight's headache is getting iPlayer to work. I am signed into NordVPN, location UK, but whenever I try and use the iPlayer it keeps telling me that it is only for use in the UK (i'm in Scandinavia).


    Is it simply a case of the Nord server being blacklisted or am I missing something?


    Happy to post up further details if you can let me know what you need.


    Thanks.

  • Somewhere in the manager, there are settings to exclude certain apps like netflix & bbc iplay


    Just realised you from scandanavia,


    I'm in the uk, even if I i have UK set as my location on nord, it won't work

    Samsung RU7400 Onkyo HTX22HDX Nvidia Shield HD Homerun Duo (Living Room)

    Samsung UE40ES5500 H96 Pro (Coreelec), Fire TV 4K Stick (Bedroom)

    Synology DS414 Plex Pass

    :)

  • I had been told by a mate some months ago that Nord was ok for accessing content in the UK from the US. Maybe the BBC have blocked the Nord servers - this is what normally happens. I had thought Nord were pretty good at rotating their servers to work around these blocks. It would be worth having a conversation with their support team and see what they say.

  • Hello Zomboided,


    First of all, thank you for this great addon. Unfortunately, I have not been able to connect to my TorGuard account any more recently.

    Supposedly, username or password would not be correct. On a PC or mobile phone, however, it works perfectly and I can connect to a server.

    I have attached the VPN log. I hope you can help me.


    Thanks in advance


    Picture