[9.0.0] LibreELEC builds for MX2/G18

  • All up and running using LE 9.0.1 I updated using the method above, thanks.:thumbup:

    First things I noticed my volume button is working again on my MS keyboard which is great,also the gdrive app is working like a champ.

    Anyone using the aeon tajo skin,I think it has a lot of potential!

    Word out


  • hello. Despite my very noobness with android boxes and linux I recently successfully flashed and setup with the add-ons I need the 8.0.2 build and was wondering a few things. First. I have to connect this box to an older TV using the AV output. Is there a way to activate this as it seems to only work with hdmi currently. I found reference to editing a config.txt file for a Pi build to turn on the port but it doesnt seem to exist in my box or the usb...again super noob here. Also, when I flashed in that image from recovery the box would not boot all the way into kodi unless the ext3 formatted USB labeled libreelec_data was still connected...not huge issue there really but the USB I used has an annoying red light that never turns off so the internal storage option would be better...I can't seem to figure that out though. I do have Ubuntu booting for trial on another USB and Im a longtime windows user so any directions provided could go either way but do need to be very step by step for my noobNess to follow...directions such as mount such n such without the actual command are going to cause more head scratching. Thanks in advance for any help and your patience while I learn.

    UPDATE. So I was reading backwards through this thread late last night and came across the \\boxip connection through windows explorer. I attempted this to see if I could locate that config.txt file I mentioned...sadly I get an error stain windows can't find \\ yes I confirmed that is the ip both from the router and the LE settings in the box. Further confusion. I assumed this connection is via the samba svc in LE and verified it is enabled according to that same LE settings section in the kodi ui.

    Edited 2 times, last by DCC2019 ().

  • Hi there.

    1. Regarding the analog AV output I'm afraid there is currently no way to get it to work, sorry. There is no config.txt on the MX2.

    2. To get the internal storage to work you need to create the LIBREELEC_DISK label on it. Turn on the SSH service, connect to the box using e.g. PuTTY (Download PuTTY - a free SSH and telnet client for Windows) and run the following command:

    tune2fs -L LIBREELEC_DISK /dev/data

    You can then remove the USB disk and reboot.

    3. The Samba share is used only for updating from the 8.0.2 to 9.0.1.

  • KOPRajs, Thanks for your reply. That's unfortunate about the AV Port. I'm assuming by "no way to get it to work" you mean it's literally impossible? Not something I could hope gets addressed someday?

    Also, I followed the directions you provided to get the device booting on the internal NAND and it does work now. I still can't seem to see the box via samba...after the device got to booting from internal the IP it was getting changed but I figured that out. I'd like to update the box fully before I consider purchasing any additional harware to convert hdmi down to analog

    I am able to connect via ssh at the IP I found. the ls command there does not show an update directory, could I somehow mount that and transfer the .tar file a page or so back to the box that way?

    UPDATE: Ok so rather than fight with the Samba through windows explorer i downloaded winscp and have successfully connected to the box and can view the entire file system, move items back and forth between my windows system and the box...BUT, i can't find /storage/.update ..../storage is visible off the root but inside are just the photo, movies, backup etc. directories.

    Update again....got it have to manually type in .update in winscp ui. Updated n running like a dream. thx so much for all the hard work....if someone with skills greater than mine ever gets the AV out (where the reset button is hiding) operational as an output too pls let me know how!!

    Edited 2 times, last by DCC2019 ().

  • Actually I've just noticed this commit in Kodi 18 devel log which might have solved the analog AV output problem:

    [AML] read display modes optionally from file · xbmc/[email protected] · GitHub

    You can try to create a file named disp_cap in the /storage/.kodi/userdata/ folder and put 576cvbs text in it.

    Or you can use the following command on SSH:

    echo 576cvbs > /storage/.kodi/userdata/disp_cap

    If you are running the latest LE 9.0.x build the analog AV output might start to work after Kodi restart.

    Good luck!

  • Hello and Thanks again KOPRajs. I gave the command above a try, unfortunately it did not fully work. When booting while the AV out was connected to the old TV before I got a brief white bar that would come on screen for a mere moment but after that nothing but black. I ran the command and went to test it out but now after the flash of the white bar there was a rolling white bar sort of "TV static" -like. I remembered that when we first got the box I had to switch from PAL to NTSC due to a similar output being observed. I searched around here and found that 480cvbs would be NTSC so I edited the disp_cap to that. Still no luck. I then searched these forums for other mentions of 480cvbs and LE 9, tried this as well

    echo 480cvbs > /sys/class/display/mode

    with both files matching regarding 480 or 576 values inside them. still no joy.

    thanks again in advance. if you need me to post any logs to assist simply give me the path to find them and I'll gladly upload.

  • Hi All, I have a genuine MX2 I’ve been running for ages with various builds.

    Currently running Ember quite well, but kodi 15 is really limiting now.

    Im a little overwhelmed by some of the install instructions in this thread as ive only ever previously done the toothpick/SD method. My internal memory is fine.

    Will a straight toothpick install work over Ember?

    edit: SO im still trying:

    1. There is no SSH option to enable on my box??

    2. I copied the image storage to a USBstick with the linked creater. now what? stick it in the box and toothpick method? point it to the sky and pray?

    I appreciate the effort to put this software together, but the instructions are severely lacking.

    Edited 2 times, last by P.Frink: . ().

  • edit: Does anyone know of another build that is installed easily (ie toothpick method?) on an Mx2? Im using ember which is great, but need kodi 18 now.

    If not, I think It's simpler for me to just buy a new box than try to work out all these instructions in here. If anyone would like a free MX2 box, pm me, I'd rather not just throw it out.

  • P.Frink

    Try installing 7.95.3 which doesn't require the named partition (copy .zip file to sdcard and use toothpick method), then enable ssh and use this command to label the data partition:

    tune2fs -L LIBREELEC_DISK /dev/data

    On Windows, you'll need to use PuTTY to get a command-line on the box. On Mac or Linux, it's easier. ssh [email protected] with password libreelec should work. If your local network doesn't support mDNS, you'll need to use the IP address of the box in place of libreelec.local. You can find it in the System:System Info section of Kodi.

    Once the old version is installed, updating is very easy if the box can be reached through the Windows file sharing system. Drop the .tar file of the latest version into the Update folder and restart the box. It should update on boot. Toothpick method may work, but I haven't tried it.

  • Thanks PS, that clarifies things a bit better..., tried to do a toothpick method but now im just getting after a boot screen ....

    ***Error in check_disks:could not repair filesystem, dropping to debug shell, try to run 'fsck' manually:***
    ### Starting debugging shell... Type exit to quit ###
    Sh: can't access tty; job control turned off

    I can attach a USB keyboard but dont know what to do to fix this, tried a search but nothing worked.

    May have bricked it :(

  • You can try to run the following command using the USB keyboard:

    fsck -f /dev/data

    If it doesn't work then you can try:

    mkfs.ext3 /dev/data
    tune2fs -L LIBREELEC_DISK /dev/data

    Then report back with the results.

  • First code gets:

    The filesystem size (according to the superblock) is 1710592 blocks
    The physical size of the device is 1418752 blocks
    Either the superblock or the partition table is likely to be corrupt!
    abort ?
    Then after a seroes of either Y or N it just goes round and round.
    the other xodes are not recognised
  • i should also note the last build I tried to load was openelec and I get a logo splash prior to the linux error.

    The last succesful build I had running was ember.

  • Right, so im doing this the long way, but getting somewhere :)

    - managed to get ember back on

    - then installed an old openelec

    - then installed and have currently running libreelec 7.95.3

    I have enabled SSH. my IP address logs me onto a command line box... login as "ssh [email protected]" but I get access denied on password

    Edited once, last by P.Frink: Update: Got it, login was just "root", pasword "libreelec" Dropped new file into UPDATE folder thru win file manager, MX2 reboot, updated itself.. I have kodi 18!!! Brilliant help guys, this is awesome. ().

  • With the latest (18.1), I am getting freezes when I fast-forwarding or stopping a movie and I had to hard reset the TV box. Has anyone experiencing the same issue?

  • Hello, I've just updated from Libreelec 7.95.3 to Libreelec 9 (great job on the build btw) however when I did the storage dropped to about only 1gb I tried reinstalling android 4.2.2 to check if the NAND was the issue, but it was fine has anyone else experienced this? Also, is it possible to install Libreelec to the nand?