tvheadend, ATSC and epg...

  • Hi!

    Ok, I probably messed up something. Not all channels have EPG data (hopefully the ones that I really use are there) show on the Guide.


    I configured the addon with "Zip Code" and all the channels that I wanted. When I run the script from Kodi it tells me that everything has been downloaded correctly, but I still don't see them.

    In TVH backend I can see that there's still some zap2xml config laying around.

    Is there a way to safely start from scratch ?


    ---
    LE : 8.2.1

    Zap2EPG : 0.6.3

  • Can you confirm that there is data on the zap2it website for the channels you are looking for?


    Also, check the epg source in the tvheadend webUI.


    Finally, take a look at the xmltv.xml file and see if the channels that are missing are in that file or not.


    You are probably seeing the zap2xml epg source data as if you had that running in the past, it will still be there, unless you go to the EPG GRABBER CHANNELS tab and delete all the ones for zap2xml. (note you need to be viewing the UI in expert mode to see that tab)


    Also - you can reload the epg data into kodi by going into the kodi settings/pvr-live tv settings/and selecting clear data.

  • Hi!

    I went into tab "CONFIGURATION -> CHANNEL/EPG -> CHANNELS". There I added the EPG source zap2epg to the channels that didn't had it already. It took awhile, but this morning every channels have nice EPG data.

    Thanks again for your quick and super useful support! Your work is awesome ! :thumbup::thumbup::thumbup:

  • technically you don't have to have tvheadend for this addon to work. Just turn off the tvheadend features in the addon settings. You can setup a cron to run the zap2epg.py file once you configure the setup in kodi.


    It might give you an error that it can't find tvheadend when setting things up - but it iwll not impact the ability to run the zap2epg.py file and generate an xmltv.xml file.

  • Hi,


    I Installed zap2epg and try to run the interface from libreelec.


    I choose country: CAN, Zip code :G8W1A8, provider: Bell satellite east.

    When I click refresh channel: I receive error in the log


    2018/01/09 14:25:06 Running zap2epg-0.6.3 for zipcode: g8w1a8 and lineup: Bell TV - Satellite (Canada (East))

    2018/01/09 14:25:06 Downloading guide data for: 1515524400

    2018/01/09 14:25:07 Could not download guide data for: 1515524400


    The same error appear if I choose Shaw as provider.


    Also no option - Antenna -Over the air . for My Zipcode, but the option is available in the web interface as provider.


    The Xml I need is primary for OTA programming.


    I take a look to the code: so much work inside!! Grats!


    My best regards!




  • It's my bad,


    Local Over the air don't appear in the list, it appear when you press select a lineup!!


    Seem to work great!

    I will give a try for few day! Thank you!

  • Added an option to disable the Tvheadend functions for those that want to use zap2epg without tvheadend.


    Just install and run in kodi and then use cron to run the zap2epg.py script to regularly update your xmltv.xml file.


    Releases · edit4ever/script.module.zap2epg · GitHub


    Enjoy!

  • I installed this addon in Kodi 17.6 and set it up to create an xmltv.xml file (not using TVH) for importing into TV Guide Fullscreen and it's working perfectly so now I'm trying to run the script outside Kodi but I can't seem to get it working. Any suggestions?


  • You need to copy the settings.xml file into whatever folder your're going to run the program from.


    If you want to run it without kodi after you use kodi to get it configured the way you want, copy the userdata folder contents to the same folder that you place the zap2epg.py file in.

  • You need to copy the settings.xml file into whatever folder your're going to run the program from.


    If you want to run it without kodi after you use kodi to get it configured the way you want, copy the userdata folder contents to the same folder that you place the zap2epg.py file in.

    Thanks, that worked!

  • Hi,

    I have a problem with the icon of some channels


    <channel id="10120.zap2epg">

    <display-name>515 MAX</display-name>

    <display-name>MAX</display-name>

    <display-name>515</display-name>

    <icon src="http://zap2it.tmsimg.com/sources/generic/generic_sources_h3.png" />

    </channel>


    <channel id="12508.zap2epg">

    <display-name>516 MAXP</display-name>

    <display-name>MAXP</display-name>

    <display-name>516</display-name>

    <icon src="http://zap2it.tmsimg.com/sources/generic/generic_sources_h3.png" />

    </channel>


    2 of them are Cinemax and Cinemax West, the icon link is wrong.


    I try to fix the link to a right icon, but every time I run update, the new xmltv.xml do overwrite the old.


    Can you fix this?


    Thank you

  • First, please check if the icon shows on the zap2it website for your lineup. If it does - pleae provide your zipcode/lineup so I can test.


    Second, if you know the fix for the icon - on the tvheadend webUI, go to the EPG GRABBER tab and uncheck the update channel icon option. That way when you change the icon url on the CHANNELS tab - it will remain fixed after the next epg grab.

  • I have pushed the 0.7.1 update to zap2epg that deals with an error in the episode id number. This error was causing tvheadend to record all shows on a channel when setting a series recording.


    Please update to fix this issue:


    Releases · edit4ever/script.module.zap2epg · GitHub


    Thanks!

  • Missing icon is from zap2it.com. My zip code is 32801, Lineup: Directv Orlando -Satellite

    I just run zap2epg on tvbox to get xmltv.xml for TVGuideFullscreen, don't know how to use TVheadend webUI.

  • Miker Yes - I can see that zap2it is missing the icons for the SD versions of cinemax. That's an issue with the source data not the addon.


    You can choose to use the HD channels instead for your lineup if you want. Those seem to have logos.


    You could also send a note to zap2it saying that you were using their website guide and noticed when setting up your favorites channels that the logo was missing for the SD versions of channels 515/516.