build for S905/S905X

  • Exactly the way it reads in the OP. #1

    My apologies for not wording question differently. Where is the "Update" folder on the SD card? Is it referring to root dir of SD card or do we just create an Update folder? Thanks.

    Edited once, last by 7up ().

  • Just tested this kernel on Sunvell T95M and now it always got past the bootlogo! :D Thank You!

    LibreElec itself don't start, because of the changed modules not included?

    ssh is working, so I can flash back the original 011 kernel

    tested, kodi crash backtrace: kodi.log (always the same crash) with new 32bit kernel over a stock

  • When updating does the new device tree file placed into Update folder need to be renamed to dtb.img?

  • When updating does the new device tree file placed into Update folder need to be renamed to dtb.img?

    No. Can keep original name. Think from.009 build onwards if I remember correctly.

    Sent from my iPhone using Tapatalk
    .011 running fine for quite some time on TX5PRO 905x for those concerned. From SD card though. 64 bit build.

    Sent from my iPhone using Tapatalk

    Edited once, last by BidiM ().

  • I got a 1gb ram s905x box and new samsung 4k/hdr capable tv running this libreelec build perfectly with just a single issue with hdr movies: the tv recognizes the video is HDR (says "HDR video is now playing" in a quick message), but all the blacks are horrifically blocky. If I check the "hdmi black level" on the TV, it's stuck to "Auto," when it should be set to "Normal." Unfortunately because the source isn't correct, I cannot change this setting on the TV. I had this same issue on android, with no options to change it.

    On a PS4, I can set the full black output range for good HDR playback, and the TV "hdmi black level" option is no longer grayed out. Any suggestions other than just disabling HDR through the sysfs interface (since I want working HDR output)?

    Edited once, last by blinkmxq ().

  • Ive the TX5 (S905X) and is working great with libre from SD
    Now i wanted to install it to internal emmc so i connect trough SSH with WinSCP and run the command "installtointernal"

    i get:

    LibreELEC:~ # installtointernal
    This script will erase BOOT, SYSTEM, DATA and DTB on your device
    and install LE that you booted from SD card/USB drive.
    It will create a backup of device tree and recovery partition on your boot media                                                                                        .
    The script does not have any safeguards!

    And then i get that the device is not responding.
    the box stays also just working nothing change after 60sec WinSCP can reconnect to the device but is not installed on internal.
    Any idea's about this?

    Edited once, last by dynamic2 ().

  • CAUTION: If your box has a non-standard partition layout, you will see an error when trying to boot from internal memory for the first time. To solve it, you need to boot one more time from SD card and run



  • WinSCP cannot respond to interactive scripts, use PuTTy.

  • For boot problems my observation:

    I have 2 MiniMX 1GB box. (one 020b, one 020c), both running the latest 011 LE.
    One connected to 4k tv via 4k avr, one connected to fhd tv with fhd avr.
    The boot problem affected only the box, what connected to 4k tv.
    At boot i see the bear the upper left corner width and height the picture only /3 /3 as normal, and box not boot, only once from 10 attempt.

  • When installing to an S905X device it's not necessary to replace the dtb.img, which of course is very convenient.

    However what about updating? Will the device tree be updated automatically too (with the default dtb.img file inside the img.gz)? Or should we extract the dtb.img file and add it to the update folder?

  • Hi guys, wanted to share my latest experience with beelink S905 mini mx 1GB RAM/1Gbit eth/AP6212

    - I've installed to internal nand the stock and proper dtb.img
    - latest available u-boot (U-Boot 2015.01-g937dd3a (Apr 20 2016 - 11:39:18))
    - i've connected the serial UART and from u-boot reinited the default boot environment:

    # defenv_reserv
    # setenv upgrade_step 2
    # reset

    now the box always boots without freezing (tested over 30 times :)).
    the side effect is that i cannot get it to completely poweroff:
    I've tried shutdown from kodi, poweroff and shutdown -h from ssh without success: "the box always does a reboot".
    The only way to completely power it off is by using the power button of the original remote :/

    p.s.: "suspend" seems to be working though :o (tested over 10 times)
    p.p.s.: after a lot of suspends, tried a shutdown and worked. it seems that f i suspend nd resue at least once , then the shutdown works properly..
    that's real "craziness" man!

    Edited once, last by stormrev ().

  • Could you changes places, so the one connected to avr goes to TV, and the one connected to TV goes to avr?

  • Long time lurker... :)

    Just wanted to say kudos to kszaq for the amazing work he's done. I didn't even know about libreelec and Amlogic devices till about two weeks ago...and here I am rooting the boxes and klutzing around with Linux commands (I'm a Windows guy...)

    Bought a Beelink Mini MXIII II, created a USB drive with the .11 image and the box booted LE right away. Amazing. While libreelec worked just great, I'm gonna send the Beelink back (the luxury of being an Amazon Prime member...). The wifi on that box is just horrible, and I didn't pay attention when buying it, there's no AV out (I need that for one of my older TVs).

    Bought an Enybox X1 2GB/16GB and try as I might it would not boot from an SD card or USB. The reason I bought the Enybox was because it had an external antenna, had 802.11ac, BT and an AV out. I really really wanted LE to work on this box. So instead of sending this one back as well... Set about with a determination to get LE on it.

    - Reading around, it seems that the latest Android build on some of these boxes has boot from SD/USB disabled. Well...that's not good..
    - In addition, I found out later, the box has a non-standard partition layout...
    - Tried to find an older firmware/Android image for the box...no go.
    - Finally rooted the box with TWRP. Not sure if the box was already rooted or not.
    - Hmmph...TWRP STILL wouldn't allow me to boot from SD or USB without finding an alternate ROM that was pre-installed.
    - Screw dat. Backed up the stock ROM and flashed the .11 build straight to NAND. gah! what have I done!!! :)
    - Well...lo and behold LE works right out of the box and booted up perfectly!
    - except.....
    - the remote didn't work...took a while to figure out how to extract the remote.conf from the ROM backup I took...and then found that the vendor *ucked around with the standard code and introduced custom code in that file. Fixed that, put the file in LE and the remote worked right away.
    - BT and Wifi worked great OTB. The wifi on this box (AP6255, not sure what the Beelink has, even though it's 802.11ac as well) is leaps and bounds better than the Beelink. I'm sure the external antenna helps.

    Got Kodi setup the way I need with my stuff and this tiny lil box is smoother and faster than a box that's 10 times (maybe even 20) big physically and maybe 5-6 times more expensive. I had bought an Nvidia Shield sometime back (sold it, didn't like it) and to my eye, the picture quality of the S905X is better than the Shield using LE.

    The box can play 4K rips from my server without a hiccup over wifi...except for a few (like Hunger Games Mockingjay...the bitrate on that hits 90mbps at times). The average 4K rip bitrates I have seen are around 50mbps and it plays them flawlessly, no buffering.. over Wifi. Amazing.

    All in all, just wanted to say thank you to kszaq. Well done.

    Edited once, last by kapone ().

  • Where does one get the U-Boot for these devices and how to install it ? Are sources and compilation instructions available ?