v7.90.009 bug reports for Odroid C2

  • Amazing release of Kodi for the Odroid C2; well done!


    What works:
    + audio sync with passthrough including DTS HD MA, Dolby TrueHD, Dolby Atmos
    + h264 10 bit; h265 4k playback
    + smooth Kodi GUI



    What needs work:
    - Atmos, DolbyTrueHD, or 4K (with higher level audio) the video playback is choppy (most of the time; sometimes it manages to playback smoothly)
    Unfold g1gbn9k6yR
    Eclipse thx_eclipse_long_4K_uhd_DTS-HD_MA_51-thedigitaltheater.mkv


    - stream playback of a particular stream, for the majority of times, does not work; always works if acceleration is turned off
    index_2200_av-p.m3u8?sd=10&rebase=on


    - 3D does not auto switch TV; 3D MVC files play back as 2D


    - 60 seconds after audio playback is stopped there is an audible click


    - Airplay does not work (even with disabling picture/videos)


    - Playback jerks periodically at a regular interval (self correcting audio sync?)


    Here is debug log with all these issues logged.
    (I intended to provide a debug log of each incident, but deleting the kodi.log file/deleting the contents of the log file would cause Kodi to not record the debug log. I would essentially had to delete the log, restart kodi to rebuild a fresh log, and then create the log for each instance; maybe this can be fixed as well).

    Files

    • kodi.zip

      (63.54 kB, downloaded 64 times, last: )
  • There should always be a kodi.old.log present as well, a renamed file from the previous boot instance.

  • There are also audio-video-sync issues. At least when playing 24fps (23.976) content (standard Blu-Ray framerate) there is on my TV a sync offset of about 175ms (audio ahead of video). I assume that this varies from TV to TV, because this seems to be the processing time my TV needs for the pictures in 24fps mode. My Odroid C2 is connected to an AV-Receiver. This leads to my assumption that Odroid C2 does have a broken LipSync (so called feature) support in the last builds, where HDMI should correct this offset via a handshake or so.


    This offset was also discussed on forum.odroid.com because others also noticed it since wrxtasys 7.1 community builds. His 7.0.2 builds were not affected apparently.

  • I can confirm the audio crackling problem. But not only after 60 seconds after playback. But sometimes also at some random time. Note: I have deactivated GUI sounds completely.


    Apart from that the switch from RPi3 to Odroid is worth the upgrade. HEVC in 1080p play without a problem. And I haven't noticed audio-sync problems so far, but I'm also quite undiscerning when it comes to that.


    ----


    Edit: the crackling / click noise is gone for me. Just go to the Settings-> Sound, Use Option "Fixed" and Limit the sample rate to 44.1KHz and also use "Keep Audio device alive": always.
    Works for me.

    Edited once, last by gaelic ().

  • Basic stereo 16/44.1 music output to either USB DAC or SPDIF (using HifiShield) is still problematic - clicks and pops.