RetroELEC Kodi+Wayland+Emulationstation+RetroArch (x86/XU4/RPi)

  • Logs would help. The preferred is OpenAL, which uses Pulseaudio as a backend by default. Sounds like Kodi starts up before the RetroArch process has let go of the display, that's something I might be able to fix.

  • I am interested in giving this build a go, and have a choice of hardware - which one will be better for RetroArch and game emulation in general? (performance etc):

    1. RPi 4b (4Gb RAM variant), currently running the recommended RPi 4B build of LE v9.2.0

    2. ASUS Chromebox CN60 (i7 CPU, 8Gb RAM), running LE generic x86 also v9.2.0


    I realise the CN60 has the edge in CPU & RAM, what I'm more asking about is which of my two options for hardware is better SUPPORTED in terms of emulation, specifically MAME.

    Cheers,

    tU

  • New images uploaded:


    • Linux 5.5-rc4
    • F2FS as default filesystem (both image and installer)
    • Kodi is now set up to use ALSA only to fix passthrough issues
    • Latest Kodi Leia git brings some bugfixes
    • The usual updates to cores etc.


    For anyone having issues, post logs.

  • Installed the new image - fresh install, no update.


    * Kodi works out of the box incl. PassThrough. I needed to change the PassThrough device to HMDI (from SPDIF) to enable 7.1 PassThrough


    * I can now select ES from within Kodi and ES comes up. I could only switch back to Kodi once (the first time). After that, I always get stuck with a running kodi (incl. gui sounds), but no display - just a blank screen.


    * I can now start n64 games from within ES, but the sound seems crackling - using the default 'openal' driver in RA. (Previously, I had to use 'alsa' - and there was no crackling). Choosing the 'alsa' driver now results in no sound at all. Maybe I have to specify a specific device ? But as fas as I understand the goal is to use 'openal', correct ?


    * Firefox still cause GPU hangs from time to time. I can not say if the kernel update helped or not. I will file a bug report with the DRI guys.


    kodi.log and related dmesg output is attached.


    If you need any other log files, etc. please let me know.


    Thx!

    Files

    • kodi.log

      (32.72 kB, downloaded 84 times, last: )
    • dmesg.txt

      (1.51 kB, downloaded 94 times, last: )
  • oh. and once kodi is in this 'no display' state, restarting it (via kill) does not help. kodi comes back up (gui sounds are there and I can see it burn CPU cycles in 'top') but there's still no display. Is the display somehow 'suspended' ?

  • Waspoeder


    Hm, actually there doesn't seem to be any issue with using ALSA playthrough while Pulseaudio is running. Tested here with DTS-HD and Atmos.

    Probably my old reciever then

    Thanks gonna try the new build


    Happy newyear!

  • There's no comparison, pretty much any PC will absolutely smoke the RPi which can't even run recent MAME versions.

    cool, thanks for confirming that :)
    I wasn't sure, given the latest RPi has significantly improved graphics chops, (BUT I guess that's only useful for 4K / HEVC decoding and the GFX processing can't be used for emulation horsepower???).

    The i7 CPU in the CN60 is pretty old I'd have to check but it maybe a 1st/2nd gen.

    Anyway, thanks I will have a go with the CN60!

  • Great LibreELEC spin! The combination with ES/Libretro is a winner.

    My NUC8 is on your latest release. There is this issue when I power down via the Kodi menu (power off) or with the TV remote (HDMI-CEC) the box goes to sleep. In the LibreELEC settings "Shutdown function" is set to "Shutdown". The issue arises when the setup is switched back on but there is no output on the display (the TV stays black). I can hear the sounds of Kodi and when I ssh into the box all looks fine. To resolve the issue I have to hard power down the whole setup manually.

    I would prefer a real "power off"... the system boots of an SSD and is plenty fast -- any ideas?

  • Great LibreELEC spin! The combination with ES/Libretro is a winner.

    My NUC8 is on your latest release. There is this issue when I power down via the Kodi menu (power off) or with the TV remote (HDMI-CEC) the box goes to sleep. In the LibreELEC settings "Shutdown function" is set to "Shutdown". The issue arises when the setup is switched back on but there is no output on the display (the TV stays black). I can hear the sounds of Kodi and when I ssh into the box all looks fine. To resolve the issue I have to hard power down the whole setup manually.

    I would prefer a real "power off"... the system boots of an SSD and is plenty fast -- any ideas?

    This seems related to my issue when switching between Kodi and RetroArch. I assume, that Kodi is 'shut down' in this case which might trigger some action via CEC. I thought I had disabled any CEC triggers towards my TV or receiver. Let me check.

  • Hello guys!


    escalade today I finally found some time to install your latest build.

    For a long time I wanted to switch to a system with integrated emulators.

    clean system, ssd empty, once I'm on the settings screen the keyboard does not respond correctly, it takes long time to respond to each command.

    after 5 minutes I finish the setup and go immediately to see the use of the cpu ... all the cores at 100% (i5-7400)

    unrecognized video card (nvidia gtx1050ti) ... set on a vmware driver.


    what can I do?


    ps. I'm not very skilled ... please help! ;(

  • Howdy,


    I’ve recently started delving into finding an all in one solution for a media player that goes a bit beyond Plex and happened to run across this particular version.

    I’m testing with some older HW at the moment, an X58 based system, though with a GTX 1650.


    I’ve seen older posts relating to this issue, but simply, I’m getting a file system corruption message immediately after launching the installer.


    I’m using the most recent version. And as I’m only able to get to this point, there’s not a whole lot I can provide other than what I’ve described at the moment.


    I’m currently using a 256GB SanDisk cruiser fit. I’ve also tried a 64GB micro SD. Somewhere is a 32GB flash drive that I usually use for these kinds of things but can’t for the life of me find it. Though I’ve had issues with some larger drives in this regard in the past, I can’t say whether this is that, or the image itself at this point.

    That said, I’m open to suggestions and can provide any additional info required.


    Thanks in advance...

  • I’m testing with some older HW at the moment, an X58 based system, though with a GTX 1650.


    I’ve seen older posts relating to this issue, but simply, I’m getting a file system corruption message immediately after launching the installer.

    I'm also running some older hardware and hitting the same issue:


    Intel Celeron 1007U 1.50 GHz

    Intel NM70


    The generic libreelec installs fine but the retroelec img gives a file corruption error immediately after the installer launches. I'm assuming this is similar to the issue I had back in 2016: RetroELEC Kodi+Wayland+Emulationstation+RetroArch.


    Is it still possible to get a generic build that runs on older cpu's. I'm currently running on one of your older 2017 builds but I'd like to update my setup to use kodi 18 vs 17.

    Edited once, last by bdunning ().

  • New generic image out:


    • Linux 5.5-rc5
    • Fixed some Plymouth (boot splash) / installer issues - now installs and runs fine on VMware Fusion Pro
    • Updated OpenAL, RPCS3, Sway/wlroots, alsa-lib to latest git
    • The usual RetroArch/libretro updates - highlight is the new dynarec for beetle-psx


    Railgun  Etabeta16  bdunning


    My images are built and optimized for the Intel Silvermont architecture which is now 7 years old. Anything older than that probably won't run and you'll have to build for yourself. Newer generations of nvidia is not supported, as I'm now using the open source nouveau driver. Nvidia Wayland support just isn't there yet.

  • I am getting the system corruption message as well is there any way around this or should I just stick with retroplayer in vinilla kodi, miss being able to play ps2 on my machine.