Pi 3: wlan power-save enable by default

  • Hello,

    my "problem" is, that the power-save feature of the integrate wlan on Raspberry Pi 3 is enable by default in LibreELEC 7.0.0 and maybe, it's a bug?

    Last week a have "upgraded" from Rasperry Pi 2 to Pi 3 and using the same SD-Card with LibreELEC 7.0.0 (which was upgraded from OpenELEC 6.0.3 on Pi 2). But I'm not sure, maybe the following issue is solved in LibreELEc 7.0.0 (with a "fresh" installation, without ballast from OpenELEC or Pi2).

    I have found the solution in the OpenELEC forum (OpenELEC Mediacenter - OpenELEC Forum - Raspberry Pi 3 wlan issues (1/1)). But the name of the addon in LibreELEC 7.0.0 is "Network Tools".

    The current power-save status of the integrate wlan in the Pi 3 can see with the following command (by default it's activate):

    LibreELEC:~ # /storage/.kodi/addons/virtual.network-tools/bin/iw wlan0 get power_save
    Power save: on

    With the command

    LibreELEC:~ # /storage/.kodi/addons/virtual.network-tools/bin/iw wlan0 set power_save off

    you can disable it. But it's only temporary. After a restart of LibreELEC it's enable again.

    With the script "autostart.sh" (it should contain the last command) you can do this automaticly. You have to put it on the SD-Card (/storage/.config/). Now the power-saving of the integrate wlan on Pi 3 is disable by "default".

    But is this a bug? Can somebody confirm this?

    For me it's working now and I have no problems, but maybe other users have same problem and that's why I have open this topic.

    Thank you.

  • Powersave *is* disabled, but in the kernel, so iw isn't aware of it.
    You should the message "brcmfmac: power management disabled" in dmesg log.

  • Ok, I can see the message, but without disable the power-save with "iw" the wlan goes in power-save modus after a few minutes (e.g. I can't open SSH, sftp or samba connections anymore and the internet-connection on Kodi is very slow).

    After I have disable the power-save mode with "iw" everything is fine and I have absolutly no problems with wlan anymore!


    Here is my dmesg log:
    [Bash] LibreELEC:~ # dmesg log [ 0.000000] Booting Linux on physical CPU 0x0 [ - Pastebin.com

    Edited once, last by kar82 ().

  • Hello,
    on LibreELEC (official) Version: 7.0.2 (on RPI3)
    first install -> Libreelec Addons/Program Addons/Network Tools


    logon via ssh and test -> iwconfig

    wlan0 shows up like -> Power Management:on

    then -> nano /storage/.config/autostart.sh

    add -> iw wlan0 set power_save off

    -> save and exit
    -> reboot

    logon via ssh and test -> iwconfig

    wlan0 shows up like -> Power Management:off

    ...maybe the solution

  • This worked perfect for me. I had to install iw and iwconfig through the unofficial openelec repo but was able to get this working by creating the autostart.sh and pointing to the location of my iwconfig ( /storage/.kodi/addons/tools.iw/bin/iw wlan0 set power_save off )

    Edited once, last by Yabbo ().

  • Thanks...done it here too...wasn't sure if it was still an issue...but it was and now is working fine..

  • Hi!

    I need to disable wlan power save because it renders my kodi remote apps on my iPhone and iPad useless if I'm on wifi.

    I have installed the addon Network Tools and tried the various paths suggested in this thread but no matter what I do I can't set power_save to off.

    If I try any of the commands

    /storage/.kodi/addons/virtual.network-tools/bin/iw wlan0 get power_save


    /storage/.kodi/addons/virtual.network-tools/bin/iw wlan0 set power_save off

    I get

    iw: not found

    However I can use the iwconfig command, which is how I know that power_save is not off.

    In /storage/.kodi/addons/virtual.network-tools/bin there is no iw. There are:







    Edit: I figured it out, the command is "iwconfig wlan0 power off"

    How do I install iw?

    Edited once, last by Tenbrink: I figured it out! ().

    • Official Post

    iw was moved to the image when we added the wireless regdomain feature, so between 9.0 and 9.2