S802/S812-Libreelec images for 7/8/9

  • Hi Julio,


    i could also use the optical output.

    But i remember THX and/or DTS isn't working through that connector isn't it?


    Ohw2, and can it use both outputs at the same time?


    Thanks for the idea! Now, where was that TOSlink cable?



    BTW, i have the same minix as well having the same issue.

  • S802/12 are able to play H265/HEVC at 4K2K = Ultra HD = 3820 x 2160 vs S905/12 that can do 4K = 4096 x 2160

    And not because they are weak (they are faster that any S905 in existence) but because they use the 1.x HDMI protocol that has this limitation.

    OK good to know. I'm only after h.265 @ 1080p so nice to know its viable. I checked quickly and could see it was using SW decode hence jerky stop/start. Shall investigate more around file format, player and test some others. Maybe could have been a 10bit HEVC and I read S812 can only support up to 8-bit.

  • I'm using optical output with a Pioneer SBX-300 sound bar, and decode AC3 and DTS perfectly with RC2 M8 image.


    BTW, RC2 has new sound options for DTS, check it!

  • Hi all,


    If anyone else is interested in trying the M8S+ 8.2 RC3 build, I made the image that you can download from here (I suggest to install it first on an SD card, test it for awhile and install permanently on the NAND):

    LibreELEC-S8X2.arm-8.2.RC3-M8S-PLUS.img.gz


    Note: the WiFi card is not supported (only the Ethernet port).

    I'm using it and it works so far. The pass-trough is available for every HD sources but there is a problem with the HD-MA sources: a noise is reproduced.

    Regards.

  • You can retry boot from sd from .img , all will go ok now

    LibreELEC-S8X2.arm-8.2.rc2-M8.img using OpenELEC-MX3G.arm-DualBootSD zip to activate sd card boot.

    Result in picture.

    Thank you for trying.

  • Demetris Can you include the following patch for the x8h-plus:

    This fixes 8bit hevc playback on my '1st gen' x8h-plus. We found that there are some variations over the lifespan of the x8h-plus, and your current build causes serious artifacts with hevc. Increasing the buffer fixes it for me.

  • LibreELEC-S8X2.arm-8.2.rc2-M8.img using OpenELEC-MX3G.arm-DualBootSD zip to activate sd card boot.

    Result in picture.

    Thank you for trying.

    I would recommend this.

    1. Flash oem android firmware

    2. Burn LE image to sdcard

    3. Try to boot with toothpick

    4. Done

  • The box is an M8 which has a Linux proprietary version of Kodi. (ArnuBox)

    I would recommend this.

    1. Flash oem android firmware

    2. Burn LE image to sdcard

    3. Try to boot with toothpick

    4. Done

    I always knew this would be the case.

    Once i Flash Android there is no going back to the original Linux on the Box.

    Their Android Firmware is readily Available but the Linux Image will not be made available after Android is Flashed.

    Linux is Flashed by them and shipped out.

    Oh Well, Worth a try. Thanks again.

  • Hi Demetris,


    thanks for the image.

    Under the "Audio output device" section, the ALSA HDMI output device is no longer available.

    Only these two devices are available:

    - ALSA: default (AML M8Audio Analog): PCM (in the previous image, this device was labelled without the PCM)

    - PULSE: default (Bluetooth Audio)

    By selecting the 1st device listed above, no audio is reproduced at all. Pass-trough is not available.

    I didn't test the Bluetooth Audio.


    Thanks.

    Edited once, last by Avok78 ().

  • Hi Demetris, i don't know if my soundbar is compatible with DTS-HD MA but:


    - With DTS-HD->ON and DTS->ON in options and DTS-HD MA content, i hear nothing.


    - With DTS-HD->OFF and DTS->ON in options and DTS-HD MA content, works OK!

  • Hullo. First thanks for the images! Secondly I have a mxiii+ with which I can test the HD audio codecs if you'd like?

    Edited once, last by elgrecko ().

  • Hi Demetris

    version RC2 MXIII-plus works on my old box MXIII-G 2/8 well. I tested Wifi, Lan, Spdif,

    only DTS audio all works OK.

    Just the wrong use of the power button on the remote controller "suspend"? the box is sleeping but badly starts will help hard reboot. Over the menu context works Ok. I came back to version 8.0.2b where the button opens the context menu and can be turned off or restarted.

    I Can somehow restore this feature from the previous version?

    Thank you

  • Hullo. First thanks for the images! Secondly I have a mxiii+ with which I can test the HD audio codecs if you'd like?

    Can you please try the latest RC2 image for your device and report back?