Empty list under "Available Versions"

  • Hello everyone :)

    My friend decided that she should learn a bit more than the VERY basics about kodi and libreelec that she knows now, so I installed le 11 on a vmware vm to help her out. If she breaks it, it
    In detail, I got the .ova file and had vmware player convert it to its own format and create a new vm. Then I beefed up its specs a bit: 2 cpu cores instead of 1, 4gb of ram instead of 1 and 512mb of video memory instead of 128. I also switched the network to nat mode. The remaining options inside le are the default ones, ssh is enabled and the vm works just fine... if you exclude some frame drops here and there when navigating the ui.

    Back to my friend. One thing she MUST learn is to update the os itself and that is why I installed le 11.0.0 and not 11.0.1, so as to show her how to upgrade to it. I showed her how to download the file and place it inside the update folder that is accessible through samba, but she still finds it a bit complicated, so I went the easiest way possible: through libreelec settings > updates. Under there, I have set

    - automatic updates = manual

    - submit statistics = enabled (not that it matters)

    - show update notifications = enabled

    - show custom channels = disabled

    - update channel = libreelec 11.0

    And the list under "available versions" is completely empty, although kodi does show a notification for an update at startup. What is weirder than that is that kodi's log just stops at a random position every time, e.g. from 2 subsequent boots



    Any ideas?

    p.s. Networking was set to bridged this time, so as to connect with ssh and get the logs.

    Edited once, last by jim_p (May 17, 2023 at 10:31 AM).

  • I think I found why...

    I noticed that when selecting addons from the main menu, there is a tile saying "music addons" that just flickers in and out of the menu (it appears and disappears again and again). Sometimes, this also happens under videos, where the "video addons" tile does the same and so on for the other categories. So I thought it must be something with the internet connection...

    I used ping, nslookup and traceroute on google and everything worked, so I tried downloading something. And wget told me there is no space left on the device

    # wget http://speedtest.ftp.otenet.gr/files/test100Mb.db
    Connecting to speedtest.ftp.otenet.gr (
    saving to 'test100Mb.db'
    wget: write error: No space left on device

    Because /storage is less than 30MB and full as it seems!

    # df -h /storage
    Filesystem                Size      Used Available Use% Mounted on
    /dev/sda2                25.2M     24.6M         0 100% /storage

    I ran parted, which offered to fix it, but nothing changed

    So, why doesn't it occupy the remaining ~4gb of the space?

    In case it is important, I noticed that the bootloader boots the installer option. Why? Isn't the os already installed?

    That is why I also tried the run option, but nothing changed.

    p.s. Can someone move this to the virtual machines section? Thank you.

  • Since I could not resize the storage partition via parted itself, I chose the noob frienly way of gparted (from its live cd) and I now have all 3+gb available for it. Proof

    # df -h /storage/
    Filesystem                Size      Used Available Use% Mounted on
    /dev/sda2                 3.3G     24.8M      3.2G   1% /storage

    The flickering tiles issue is gone, wget can download stuff as usual and the logs... log everything now.

    However, the list under "available versions" remains empty and this is what the log says. I saw that waiting there at the end and waited for like 10 minutes, but it was not populated

    2023-05-17 15:11:45.768 T:916      info <general>: SETTINGS: run # Received openConfigurationWindow
    2023-05-17 15:11:45.782 T:877      info <general>: Loading skin file: /usr/share/kodi/addons/service.libreelec.settings/resources/skins/Default/1080i/service-LibreELEC-Settings-mainWindow.xml, load type: LOAD_ON_GUI_INIT
    2023-05-17 15:11:45.794 T:877     error <general>: Control 1000 in window 13000 has been asked to focus, but it can't
    2023-05-17 15:11:45.794 T:916      info <general>: SETTINGS: run # Waiting
  • Episode 3. I decided to use the custom channels option and I added the greek mirror there, i.e.


    There is a releases.json file in there, just like the one under the nightlies server which I used a year ago on my rpi 3b, so the server does qualify for updates. Still no luck though :(


    I also tried adding the nightlies server there as a custom channel and all the nightlies of le 11 showed up under available versions. Then I removed it, because I do not want to upgrade to any nightly.

    After that, I flashed the image of le 11.0.0 on a usb stick and booted from it (in run mode). And there still nothing under available versions, so something is definitely wrong with the update server of the stable versions.

    Edited once, last by jim_p (May 18, 2023 at 12:19 PM).

  • a) Disk expansion of OVA is broken, see here. A fix is in the queue.

    b) For OVA boot mode is changed from installer to run but boot message remains installer.

    c) Only auto update seem to be working.

    For manual updates of "LibreELEC-11.0" Generic-legacy the entry in releases.json is wrong. It is

          "Generic": {
            "displayName": "Generic",

    but should be

          "Generic-legacy.x86_64": {
            "displayName": "Generic-legacy AMD/Intel/NVIDIA (x86_64)",
  • Thank you for your reply, you explained a lot in just 3 lines!

    As for the issue in releases.json, when can we expect a fix? I noticed that there is also a releases_v2.json file in the mirror. Does this contain the fixed code? If so, how can I make the update mechanism use it.

  • releases_v2.json is WIP for update process changes of (maybe) LE12.

    I've no idea how releases.json was generated after 11.0.1 release. This "Generic"/"Generic" may be intentionally but then a copy with "Generic-legacy.x86_64" can be added. Maybe someone else does know more.

  • Any ideas on when it may be fixed? Although I do know how to do the update manually, I will scrap the vm altogether if it remains broken for the time being.

  • So, I tried the ova file for the generic x64 non-legacy. It has the same issue with the partition resizing, but the update function works properly, Then I tried the ova file for le 10, which has neither of the 2 forementioned issues and it just worked properly on first try.

  • I also had an empty list on LE 11.0.0 at first. I had to switch to update channel 10, and then back to 11 to fill the list with LE 11.0.1.

    I've been informed the developers about that issue, but no reply. I hope it will be fixed at LE 12.

  • Hello everyone...i know this is an old subject, but i just realized that libreelec got a couple updates and i did not see them.

    So i went to my update list and no new versions available...completely empty.

    Using the generic legacy version due to being a chrome user and i am on 11.0.1

    Would be great to get any hint...