HDR on x86 Hardware

  • I think this is an issue with your TV (firmware?).

    Intel driver default to 4K/24 12-bit RGB. Maybe your TV doesn't like this video mode.

    Try to force 8 and 10 bit with proptest (copy it to /storage and chmod 755)

    # systemctl stop kodi

    # ./proptest

    It should look something like this (values may be different for your box):

    # ./proptest 326 connector 328 8 (this will force 8-bit for Connector 326 (HDMI-A-2))

    # ./proptest 326 connector 328 10 (this will force 10-bit for Connector 326 (HDMI-A-2))


    # systemctl start kodi

    and try to switch to 4k/24.

  • just for info, it does work with a 11500 cpu and asrock Z590 gaming motherboard with native HDMI, i just get lipsync issue's with that combo

    will try and work out how to run proptest tomorrow hopfully

  • I have the same issue on my NUC11TN no 4k/24 unless 8bit is forced. The gemini nuc was fine.

  • Try this build


    I upgraded from 06.18 to this version, kodi is normal, no panic, but still the same problem.


    I tested at NUC11PAHI5 with LG OLED65BX.

    If i turn on the nuc11 first, and then turn on the TV, it recognizes 4k+120hz and plays hdr video normally.

    But if i turn on the TV first and then the nuc11, it can only recognize 4k+60hz, and hdr video playback black screen.

    For example, when the TV is on, and restart the nuc11, this issue will occur.

  • Hello!

    I'm also having similar problems with my LG OLED65C8 and 10th gen minipc as some people described. The TV does not switch into HDR mode. I've tried the LibreELEC-Generic.x86_64-11.0-devel-20220618165047-07254d4 build with no luck, I've also tried LibreELEC-Generic.x86_64-11.0-devel-20220627031313-1e2c94b and test_ycbcr444 but those latest ones does not boot on my machine, both giving the same error and freezing:

    [ 0.091865] Spectre VZ: WARNING: Unprivileged eBPF is enabled with eIBRS on, data leaks possible via Spectre v2 BHB attacks!

    [ 0.549581] fail to initialize ptp_kum

    Ok, I've been reading the forums again and noticed that regarding 20220627031313 build

    (This build will boot only on Tiger Lake and newer hardware e.g. NUC11).

    So that solves my question why does it not boot on my gen 10th hardware. So back to the original question about HDR - does any one previously complaining that their TV does not switch found a working solution\build for them?

    Edited once, last by ebol (July 14, 2022 at 8:48 AM).

  • Do we have a list of confirmed devices that are classed as working ? Thinking it could be worth setting up some sort of matrix to help users decide which mini pcs could be best.

    I had a ton of problems with the 11th gen I5 nuc so i'm today trying a 10th gen I3.

  • I'm trying to get HDR working on 10th gen I3-10110U, no luck so far. I've also tried tweaking brodcast rgb and max bpc using proptest, so maybe it is a device problem .

  • At the end of the day it is simple for people to make a USB and test to see what works for their use-cases, and a major task to aggregate and maintain results as we move frequently and continuously through combinations of newer kernels, drivers and firmware - which is why that idea dies on its arse each time someone raises it or well-meaningly starts a thread on the topic.

  • Cool so made lots of progress this time using new box BXNUC10I3FNKN2.

    Installation hung at 'migrating addons' as i was upgrading from LE10 - however then after restarting it now goes into Safe Mode. Coming out of same mode puts it into a boot loop but keen to see how this can be fixed.
    Log attached below and any help much appreciated.


    Can confirm though that HDR10 files playing flawlessly, awesome work!

  • Coming out of same mode puts it into a boot loop but keen to see how this can be fixed.

    It's a self-inflicted problem that will be solved by uninstalling/removing the incompatible piracy shitware that caused the issue. If you want to use those add-ons you are not welcome in this forum (aka, you should read our forum rules again).

  • Well for anyone else with these issues my fix was to backup my .kodi folder - do a fresh clean install and then restore using the kodi folder. None of the addons or anything had changed but it appeared to work.