Le 9 (or newer) on s905 (mxq pro 4k)

  • Hello everyone! This is my first thread here, so please excuse any mistakes.

    As of last Friday, I am the new owner of 2 old tv boxes: an mxq (amlogic s805) and an mxq pro 4k (amlogic s905, 1gb ram, p200 bootloader). I decided to install libreelec so as to make them useful again.


    Installing it on the one with s805 was an easy task. I found 9.2.6 in this thread, flashed it on my sd card, started the box with the "toothpick method", it booted just fine and I simply connected via ssh and ran installtointernal. It took me 15-20 minutes at most.


    Before that, I also tried the build from this thread and it worked fine too, but I decided to find something newer since kodi 17 is no longer supported.


    However, installing anything on the other one, the one with s905, has been a big pita so far! First and foremost, the device itself does not have a reset button, so making it boot to recovery was a tedious task by itself. I had to install a terminal emulator on its android based os and use reboot update.

    Then, I started with coreelec 19 from the sd card and all I managed was to put the device into a bootloop because of the wrong device tree. The device was on bootloop even with the card removed! After that, I came accross this build. I only ran it once from the sd, but it was enough to get me out of the bootloop. I did not want to install it because it is on kodi 17 too.

    Index of /s905/


    So I went back to coreelec to try 9.2.7 this time. Why? Because I noticed my device has p200 bootloader and 9.2.7 had a device tree for that (gxbb_p200_1G_1Gbit). It booted just fine, so I got excited and I ran installtointernal instantly... and I regretted it a few minutes later! After it was installed to its rom I discovered that the wired interface was not working at all and the wireless one was dropping and did not reconnect! I still wonder how I managed to make installtointernal work while connected wirelessly. My tv and my router are in different rooms and all I can use is wireless when I connect any box on the tv.


    All this led me back to the forementioned build from kszaq with kodi 17. I ran it from the sd card and both wired and wireless worked fine, so I decided to install it to its rom. But now, when I start the box without the sd card, it shows nothing on the tv. Not even the amlogic logo with the tiger. It is just black. When I start it with the sd card, so it boots FROM it, I see libreelec booting as usual and reaching kodi 17.

    What am I doing wrong?


    If it helps, I also tried lakka's build for s905. It boots, but it does not detect any wireless networks... And I have no idea how to install this on the internal memory so as to help more.


    Please share any ideas and thank you in advance :)

  • for the S905x one and a m ale usb a to a cable (usb burning tool from amlogic) or with a burn card you could try to install an androidtv based ROM to internal.

    I am using the builds from aidan at xda-developers


    Or you can find the orignal android image of this device to get everything back.

    • Official Post

    Forget the S805 device, it was never supported by OE/LE in the past and modern kernel support is making positive but glacial progress and is a long way from being easily usable. The S905 box might be somewhat useable; the choice is CE which should offer best support, or you accept the very "work in progress" state of modern kernel support in LE images.


    NB: Users are obsessed with running from internal storage but this complicates the bejesus out of testing images which may or may not work and provides only marginal performance benefit. You'll need to restore the correct vendor u-boot to make further progress. There are a very limited number of people supporting Amlogic hardware in these forums and I have subzero interest in install2internal issues; that script is a complete waste of personal time.

  • First of all, it is not the s905x, it is plain s905.

    I am not really interested in reinstalling something that is actually an android rom. I would prefer something like libreelec or lakka and use it for a single purpose. The main idea for le on it was to gift it to an old person that would use it for youtube and some iptv.

    However, if reinstalling the original rom will solve any of my forementioned issues, I am willing to try.

    • Official Post

    I would prefer something like libreelec or lakka

    CoreELEC (CE) is a fork of LibreELEC, and has continued with the Linux 3.14 kernel for various hardware models. They did this until Kodi 18 (afaik), so you could try CE for now. I run CE on a 1GB S905 Wetek HUB at my parents home, it seems to run decently stable.

  • CE 9.2.7 will run fine on a S905. For Kodi 19 there is no build from CE.
    chewitt and test.libreelec.tv have an alpha version of LE, but this is far from usable at the moment for your usecase. If you are using only youtube (and nothing else, it should work). But youtube runs on CE as well. Only downside is, that it is based on Kodi 18.9 and will stay there.

  • As I have said above, I know that there is an existing ce build (9.2.7, kodi 18.9) for s905. I have tried it already, it does boot, it does install to the internal rom, but it has connectivity issues. I don't know if those issues are related to wrong (?) device tree I have used. All I know is that there is no wired connectivity and the wireless one drops and does not reconnect. Unless this major problem is fixed, coreelec is a no go for me.


    Moreover, since the info I get under settings > system info > hardware is way too generic as seen here, is there a way to get something more specific, especially for the cpu and the bootloader?

    Imgur: The magic of the Internet

    Edited once, last by jim_p ().

  • you can always lock into the logs - there is even a dmesg. And if your connection is unstable, than a USB device could help.

    Or you simply go throught different dtb files until you find one for gxbb which allows stable network connection.


    For this tests I would use a SD card or USB stick.


    For repairing your internal storage I already said: find the right android to get back you original u boot

  • The system info page is probably pulled by /proc/cpuinfo and similar "files". Dmesg, on the other hand, does not anything useful as you check check here. There is no info about the cpu or the bootloader in there.
    http://ix.io/2WDh


    When you say "a usb connection can help", do you mean to connect the box via usb (type a to type a)? I do not have such a cable, but I will try and find one. Also, can I use a usb stick and do everything I already do with the sd card? Obviously, the box has to be able to boot from that usb...


    As for the device trees, I think I tried the one that comes as close as possible to the hardware I have. That means there is no point in trying the ones that come for devices with 2gb of ram or trying the ones that come for a very specific device (i.e. wetek hub and mecool ks2). Thus, the only device tree that remains is the one named


    gxbb_p200_1G_100M_RealtekWiFi


    I doubt it will work, but I will give it a try and report back. What is the worst thing that can happen if I use the wrong device tree?


    p.s. In case I have not mentioned it already, I have noticed that its remote control does not work on anything except the stock rom. This is a small issue for me, because I know any *elec can work via hdmi cec. But MY tv (= the one that I want to connect the tvbox to) does not have hdmi cec. Thus, using an distro like lakka, which works properly only with a game controller, is possibly a more viable option.

  • I did a few more tests and here are the results.


    Ce 9.2.7 with no device tree because I forgot to paste the copied file.

    It boots fine and both wireless and wired network worked. I installed it to the rom and it fails to boot, going straight to black screen.


    Ce 9.2.7 with the forementioned device tree for realtek wifi.

    It boots fine but I only tested the wireless connection and it seems stable. Shall I make the big step and install it to its rom?


    Lakka boots fine from the sd, but no wired or wireless connection can be done. In fact, all I see under scanned wifi networks is some garbled text and none of the 2 wireless networks that are available near me.

  • The 1g in the dtb refers to gigabit LAN.

    Try all for gxbb.


    Remote can be configured in LE and CE by ir keytable


    Have a look inside the folder rc_keymaps for a how-to. You need the right Scancodes and then the remote will work.

  • Da Flex
    Understood. However, coreelec may be the only way to get a fairly recent and functional version of kodi, because the le one that also works comes with kodi 17 and this version will be unsupported by addons soon because it can't run python3. At least kodi 18 can...


    tavoc
    Allow me to disagree. The difference between this

    Code
    gxbb_p200_1G_1Gbit


    and this for instance

    Code
    gxbb_p200_2G_1Gbit


    is that the first one is for devices with 1gb of RAM and the second one for devices with 2gb of ram. I assume that those devices have the same bootloader, cpu etc but differ in ram.
    Actually, after checking almost all the device trees, I think they are named with this pattern

    Code
    (some amlogic related code)_(bootloader version)_(amount of ram)_(wired network speed)_(extra info when needed)

    As for the remote control support, I read yesterday that it is actually broken for this device in any *elec. It is 7.30am now that I am writing all this and I can't find the page in my browser's history, but I will post again when I find it.

  • Let's bring the discussion back to le and let's say I want to install the le version that is mentioned here.

    you accept the very "work in progress" state of modern kernel support in LE images.

    Where can I find an recent/nightly/unstable image of le 10 for s905 (or even s805)? Will I need a specific device tree to make it work? Because lakka uses something generic and I assume that is the reason that none of its network interfaces works...


    How often does it get updated and from where? Will I have to manually download the image file inside the .update folder to update it every time?

    I do not mind daily or very frequent updates. Besides, I use a rolling release distro on my pc for the last 13+ years and I am used to it. What worries me is the whole procedure of "put the right thing on the right place or the hw won't work as it should (if not at all)".


    Right now, I use le (latest stable versions) on an old x64 laptop and on an rpi3b+. I also used it on my rpi zero from late 2016/early 2017 until the first releases of 9.x that came with kodi 18.1/2 in early/mid 2019. Then kodi itself became too slow for the zero, so I switched to lakka and added a couple of games.


    Speaking of the zero, I think that menu navigation and the general responsiveness of both ce (on s905) and le (on s805) feel a little less sluggish than the zero. The rpi3b+ literally flies compared to them. All of them were tested on the same tv, with the same remote control (the tv's remote) and via cec.

  • Please excuse this offtopic post.

    Where can I open a new thread about an issue I am facing with the x64 version of le 10beta1?