LE 9.95.1 - Backup Reboot LibreElec on RP4

  • Hello,

    I Just updated all my Raspberry Pi 4 to the 10Beta1 (9.95.1) and now, Im unable to make a system backup thru the interface.

    When I start the backup, I see the percentage going up. Once à 99% or 100%, the whole LibreElec Reboot.

    My friend have a similar setup as me, and he crash around 30%.

    What kind of "debug log" we could produce to see where it jam ?

    Oh, and We didnt follow the notice about starting from scratch. We are using a vanilla version without any plugin except the mariaDB. The upgrade process went smooth without any incident.

    I suspect that might be a "corrupted" movie thumbnail or something like that.

    The backup make around 2GB normally.

    First time I "tried" the Beta1, I made a new install, from scratch, like the notice. But I had too many thing to repair in my customisation of the interface (silvo). But I didnt test backup. I could try to install it from scratch on a new SD card to see if I can make a backup.

    But preferably, I would like to look at a log and find where it hang.


    --- EDIT ---

    I've installed a fresh 9.95.1 on another SD card without doing anything else.

    The backup work. So Im looking for a log that will explain me why it crash.

    Edited once, last by MasterYoda ().

  • Can confirm this happens to me too at 40%

    It also happens when transferring files with file manager, if a file is more than 2gb size once it reaches 40-60% libreelec crash and restarts

    This happens to all nightlies libreelec 10 and the beta and I have tried with 3 separated SD cards so I believe libreelec 10 is causing the problems somehow

    So this problem is persisting when :

    1) backup files

    2) transferring 1 or more files bigger than 2gb

    3) transferring 1 or more files bigger than 1gb through local network

    4)Downloading online content (legit content) through some addons

  • I also got this issue on RPI4, so i can't complete a backup (it crash around 30%)
    it is true that i have a few plugins installed

    but the used space on my sdcard is only 500MG (out of 28G)

    if you can explain how to "add debugging to the cmdline.txt file" I'll be happy to try to locate the root cause in the log


  • Has anyone tried LE 10b2 and if the bug is fixed?

    edit: the bug is still there in 10b2. No Backup through LibreElec Settings possible. It crashes after about 40%

    Edited once, last by ApexDE ().

  • I can confirm the issue too and there is a simillar issue when I copy more then 5GB files through the file manager

  • i believe it‘s not the same bug, because i can copy large files over samba without problems but can‘t make backups.

    • Official Post

    Copying files is a straight on file copy, a LE backup also involves the tar tool to compress all files into a single backup file. The thumbnails folder can grow quite a bit, and handling all small thumb files can take quite some time, but of course shouldn't fail even on a (still) slow CPU device that the RPi4 is.

    The thumbnails of my Kodi clients are now centralized on a file server, approx 5.1GB, using path substitution and a system NFS mount. They are not touched by LibreELEC's backup/restore tool. It makes me a quick backup file of 58 MB. (It's a pretty clean setup, only 2 add-ons).

  • I'm not a dev, but I'm wondering what's on the other end of the connection when copying large files (or making backups), and which file protocol is being used.

    Could you elaborate the question , like what do you mean by file protocol?

  • performing a tar-backup via ssh commandline and copying that backup file over samba to a remote pc works (size: 4-5 gigabyte)