Audio passthrough testing

  • DTS, Dolby, Dolby+, DTS-HD MA, Atmos works only on 1080p 60HZ with micro cuts

    In my case

    For Orange pi plus one H6 , 4K 30Hz doesnt work! Canot sound on this resolution


    HDR content seems warm / yellow colorized on TV . It's not the TV with the PC I see the colors well. IS possible to fix it?


    Thanks!

  • DTS, Dolby, Dolby+, DTS-HD MA, Atmos works only on 1080p 60HZ with micro cuts

    In my case

    For Orange pi plus one H6 , 4K 30Hz doesnt work! Canot sound on this resolution

    This sounds like you're using old image. Can you check and report which version of the image you're using? What do you mean "doesn't work!"? No image at all or only no sound? I fixed plenty of H6 display related issues recently and all my monitors and TV work ok. There might be case where [email protected] may not work perfectly, but [email protected] work on both 4k capable devices I have.

    HDR content seems warm / yellow colorized on TV . It's not the TV with the PC I see the colors well. IS possible to fix it?

    HDR is fine, 10-bit output is not yet implemented. BTW, this is no passthrough related, so off topic.

  • This sounds like you're using old image. Can you check and report which version of the image you're using? What do you mean "doesn't work!"? No image at all or only no sound? I fixed plenty of H6 display related issues recently and all my monitors and TV work ok. There might be case where [email protected] may not work perfectly, but [email protected] work on both 4k capable devices I have.

    version LibreELEC-H6.arm-9.80-devel-20200708214100-87cbddb ...Ooooops my fault I try the new version Thanks

    I mean 'doesnt work' --> no sound.. of course

    Anyway thanks for the project!. Its fantastic!


    EDIT: I have uptate version to LibreELEC-H6.arm-9.80-devel-20210204215059-a05199a there is no sound in Orange Pi One Plus H6 on [email protected] . If I change to [email protected] , works well all formats with micro cuts

    Edited 2 times, last by caracolo: add comentes ().

  • caracolo I try to test your use case with my Orange pi Lite 2 (H6) but sadly nothing work well on that little thing...


    - No Ethernet port

    - Only usb2 work (no usb3)

    - try to put a usb hub with the dongle for the remote and an ethernet USB adapter but I can start only 1080p content... Ehternet adapater no enough fast I think.


    So, sorry I can help you... But I can confirm that passthrough work in 4K 30hz with my Pine H64.

    Libreelec : Raspberry 4, Orange pi lite2, Orange pi PC(and +), Pine H64, Rock64, RockPro64, soon Orange Pi 3 and PC2

    Divers : NVidia Shield Pro, NVidia Shield Tube, N2 and C4

  • caracolo


    Finally, I successfully play a 4K HDR Atmos in the definition 2160p at 30hz with my Orange pi Lite 2 (The first time, I burned the worng image, my bad )


    It's a real pain using Lite 2 compare to the Pine H64 !! It doesn't stop rebooting each time I use a little bit too much ressources... And I must reboot it between two test else it freeze.


    But anyway, is' not the subject of this thread.


    In 2160p 30Hz

    Atmos -> Ok

    DTS HD MA -> Ok

    DTS:X -> Ok

    I stopped there, other sound formats are not a real challenge...


    But with little sound cutoff...

    Libreelec : Raspberry 4, Orange pi lite2, Orange pi PC(and +), Pine H64, Rock64, RockPro64, soon Orange Pi 3 and PC2

    Divers : NVidia Shield Pro, NVidia Shield Tube, N2 and C4

  • jernej Is it possible to have a new release of your "librelec passthrough edition" with all modifications you did since febuary ?

    Libreelec : Raspberry 4, Orange pi lite2, Orange pi PC(and +), Pine H64, Rock64, RockPro64, soon Orange Pi 3 and PC2

    Divers : NVidia Shield Pro, NVidia Shield Tube, N2 and C4

  • jernej No problem for me ! Thank you !

    Libreelec : Raspberry 4, Orange pi lite2, Orange pi PC(and +), Pine H64, Rock64, RockPro64, soon Orange Pi 3 and PC2

    Divers : NVidia Shield Pro, NVidia Shield Tube, N2 and C4

  • No, not really. This is Allwinner subforum which doesn't have passtrough enabled by default. You should provide link generated by pastekodi command in that other thread.

  • Done, currently based on 9.95.1 - 10beta1. Please report if it works better or worse.

    Sadly, with the new passthrough version sound doesn't work any more on my Orange Pi PC. There is always a quiet, but noticeable noise. The UI sounds work, but all sound in media files or streams do not. In irregular periods there are sounds to hear for a fraction of a second. It makes no difference if I have set 'passthrough' on or off.

  • Kristian Test images are updated to beta2. This time I actually test them and they work as well as before.

    Sorry for the late reply, I was away from the device the last days.


    Sadly, it still does not work. It is "playing" the sound for a fraction of a second, but then silent. UI sounds work. No difference whether passthrough is set to on or off. Then I installed the normal 10.0 beta 2 version. That works without problems, of course no passthrough. My devices: Orange Pi PC and Onkyo TX-SR507 (a HDMI 1.3a 5.1 receiver).